TiVo Community Forum banner
1 - 20 of 54 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter · #1 ·
I've seen some complaints around here how the Series3 boxes no longer support third party wireless network adapters. I wonder if anyone has considered using a cheap wireless router as a network adapter? Take a look at this link:

http://www.wirelessforums.org/alt-internet-wireless/linksys-wrt54g-repeater-extender-1561.html

From what I've been able to tell, it should be possible to have two wireless routers in a home with one acting as a gateway to the Internet and another acting as a remote hub for TiVo and any other Ethernet connected devices in the room. Here is the setup I have envisioned for a future family room:

Code:
                 Internet
                    |
               Cable Modem
                    |
Office            Router------------\
                    |               |
                    |            ethernet
                    |               |
                    |           Office PC
                    |
             (wireless link)
                    |
                    |
                    |
Family            Router-------------------------\
Room                |            |               |
                 ethernet     ethernet        ethernet
                    |            |               |
                   TiVo     Game Machine     Family PC
With a setup like this, it won't be necessary to buy a TiVo branded wireless adapter. You just use the built-in Ethernet port on the TiVo. An additional benefit is that most wireless routers have multiple Ethernet ports so you can hook additional devices up and probalby come out much cheaper than if you had to buy wireless adapters for each device.

Of course, some extra setup is requried. The second router has to be told it is a "router" and not a "gateway" which is how your Internet connected wiress gateway is probably operating. You will need to change the IP address on the 2nd router so that it doesn't conflict with the first one. You'll need to make sure DHCP and any other advanced services are disabled on the second router being that they would conflict with the gateway. Finally, the wiress settings have to be identical for both routers so that they can talk.

Does anyone see any major holes in this idea?
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #3 ·
MikeMar said:
Are you doing this for cost? Then you have to buy an additional wireless router, but that's probably cheaper anyways.
For cost alone this probably wouldn't be worth while unless you want to connect multiple devices, happen to have an extra wireless router sitting around, or don't mind buying a wireless router off of eBay. The TiVo adapter costs about the same as a LinkSys WRT54G, but the user would have to decide if they want another box sitting around.
 

·
Registered
Joined
·
25,992 Posts
Or just use a wireless bridge instead of the second router. That's what they're designed for.

I currently use a wireless bridge on my PC, and just bought another one to use with the Series 3 and Series 2 TiVos.
 

·
The Question
Joined
·
11,633 Posts
I don't think a wireless router works the way you want for the second router. That is, it can't be used as a wireless bridge.

In any case, for the second unit, you don't want a router at all. A router is designed to "route" IP request to different networks. You just want to use the second unit as a switch---that is, to send signals within a given network.

Networks are complicated enough without usuing inappropriate hardware...you want a bridge like this.
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #7 ·
Amnesia said:
I don't think a wireless router works the way you want for the second router. That is, it can't be used as a wireless bridge.
Perhaps the posting I linked to is incorrect, but that appears to be exactly what is being described. It is a technique for WDS (Wireless Distribution Service).

In any case, for the second unit, you don't want a router at all. A router is designed to "route" IP request to different networks. You just want to use the second unit as a switch---that is, to send signals within a given network.
When a WRT54G is changed from "gateway" mode to "router" mode, it stops taking all external traffic and sending it through the NAT (network address translation) engine to feed out through the Internet port. From what I understand of the Linksys, when it is in router mode you can do non-translational rules based routing between the Internet port and the wireless/wired side of the box. Between the wireless and 4-LAN Ethernet ports the box does act as a switch. The critical thing is to have the default gateway address broadcast or hard configured on end devices to point back to the box connected to the outside LAN.

Networks are complicated enough without usuing inappropriate hardware...you want a bridge like this.
Nice and simple, but costs more than the WRT54G by over $10.
 

·
Forum Denizen
Joined
·
2,620 Posts
StuffOfInterest said:
Does anyone see any major holes in this idea?
Nope, I do it now.
I use the older Belkin 54g routers that had a bridge mode built into them. They also supported WDS so the TiVo at the far end of the house is serviced by the bridge in the middle of the house instead of the weak signal from the more distant router near the DSL modem. Unfortunately Belkin's newer version routers dropped this capability. I believe there is a Linksys router that can be upgraded with third party software to give you just this kind of behavior now. Check in the Home media features forum for details.

If you have multiple devices in the family room, then one router, used as a bridge can be cheaper than 3 wireless adapters, so it is a good way to go in that respect also.

Good luck,

CuriousMark

edit - I think the upgradeable wireless router is the WRT54GS (please correct me if wrong)
 

·
Registered
Joined
·
15 Posts
I do this now. I have one Tivo hardwired to an Apple Airport Express. The Apple Airport Express connects to my Linksys WRT54GS using a WDS bridge. The WRT54GS is the only device that is actually connected to my cable modem.

It works great. I originally had the Airport Express near my TV/Media cabinet because I wanted to stream iTunes wirelessly to my stereo. Since the Airport Express already had WDS capability it was a no brainer. I didn't want to run Cat 5 all the way to basement from where my cablemodem and router are.

Google "Ryan Schwartz Airport Express" and you'll find a great website describing the exact steps.

PS I did put Sveasoft Alchemy firmware on to my WRT54GS to get the WDS feature. At the time, factory Linksys firmware didn't have this feature.
 

·
Series 3
Joined
·
32,296 Posts
Harrison said:
.

PS I did put Sveasoft Alchemy firmware on to my WRT54GS to get the WDS feature. At the time, factory Linksys firmware didn't have this feature.
When did Linksys put this in their official firmware?
 

·
Registered
Joined
·
868 Posts
I do this kind of thing all the time with Buffalo routers and dd-wrt. The stock firmware on most routers doesn't provide WDS. And those that do usually don't play well with others. You're probably fine if you get 2 devices that can do WDS from the same manufacturer, but mixing brands often breaks things.

Another option with dd-wrt is client bridge mode. Which works more like what you seem to want. The second router (the client bridge) connects to the main router over wireless and bridges the LAN ports over the wireless link. The nice thing about this setup is that you don't need any special software on the base wireless router. The client bridge device looks like any other wireless client to the main router. So if you already have one router that can't do dd-wrt, this is a good way to go.

Be very cautious buying hardware. Most routers do NOT have bridging capability and even fewer will talk with another brand device. For an out of the box setup, Buffalo has a "Ethernet Converter" that will work with their routers doing exactly what you want. You need all Buffalo equipment to do this though.
 

·
Registered
Joined
·
107 Posts
I'll second kb7sei here. I have (an old) WRT54G flashed with dd-wrt connected to my cable modem and handling wired PC duty, with both an Airport Express and a Buffalo WHR-G54 (also with dd-wrt; openWRT should also work) spread around the house. All are running in WDS/client bridged mode, and work just fine together, you just have to be unafraid of flashing a new system onto your router (it really isn't very difficult).

Depending on the specials, you can find a Buffalo cheaper than the TiVo adapter, and as a bonus you can stick it behind your TV and attach several wired devices to it simultaneously (like game consoles or the like) for simplicity's sake.

And Linksys slipped WDS into their firmware a while ago...I remember being unable to use WDS with my Airport Extreme when I first got it, then one day I updated my Linksys firmware and it just started working. Go figure.
 

·
Registered
Joined
·
161 Posts
I can confirm the above. I actually had the Buffalo bridge mentioned in the thread and, while it worked for the normal network traffic - TiVo getting guide updates, Yahoo HME apps, etc. - it DID NOT work for the Java Apps, including the Blockbuster third-party app or for the HD-Photos app in desktop 2.4.

On advice of someone here at TCF, I got a Buffalo router (Circuit City periodically has rebate deals for ~$30) and used dd-wrt to turn it into a bridge that allows the Java apps to work properly.

I'll dig up that old thread in the HME section and post a link later with details if anyone is interested...
 

·
Series 3
Joined
·
32,296 Posts
Jazhuis said:
And Linksys slipped WDS into their firmware a while ago...I remember being unable to use WDS with my Airport Extreme when I first got it, then one day I updated my Linksys firmware and it just started working. Go figure.
Huh, I have a version 6 WRT54 series that's sitting in my office doing nothing.
I'll have to check it out.
 

·
Registered
Joined
·
25,992 Posts
stevereis said:
I can confirm the above. I actually had the Buffalo bridge mentioned in the thread and, while it worked for the normal network traffic - TiVo getting guide updates, Yahoo HME apps, etc. - it DID NOT work for the Java Apps, including the Blockbuster third-party app or for the HD-Photos app in desktop 2.4.
Really... Hmmm... I'm getting one today. I will see how it works out. Why would it not work with those apps?
 

·
Registered
Joined
·
161 Posts
MickeS said:
Really... Hmmm... I'm getting one today. I will see how it works out. Why would it not work with those apps?
Here is the thread I started in the Home Media & TTG section titled: Buffalo Conveter = no HME apps?
I have no idea why, but it seems to be a common problem. Stu_Bee posted a link to another forum where folks were having similar issues. He also avised using the router and dd-wrt.

I was perfectly happy with the bridge for a while because I wasn't using any of the Java Apps. It was only when I tried to use the Blockbuster Rental app and HD Photos app that I realized there was an issue. It also NOT the S3. I have an S2 connected via a Linksys USB200M adapter and it had the same issues when on the bridge.
 

·
Banned
Joined
·
3,959 Posts
My Series3 is plugged into an Apple AirPort Express via the ethernet port. It connects to my main wireless router (an Apple AirPort Extreme) and works fine.
 

·
Registered
Joined
·
25,992 Posts
stevereis said:
Here is the thread I started in the Home Media & TTG section titled: Buffalo Conveter = no HME apps?
I have no idea why, but it seems to be a common problem. Stu_Bee posted a link to another forum where folks were having similar issues. He also avised using the router and dd-wrt.
I installed it earlier, but I have not tried the apps you mention. I did however try the "Same Game" and that worked fine.

I've never used much else, so I might be OK anyway.

I'm going to try the Unbox application right now.
 

·
Registered
Joined
·
161 Posts
All the regular HME stuff works fine. It was just the Java enabled stuff that did not show up. If you do not need them, then the Buffalo bridge is fine.
I really wanted HD photos on my S3 and big DLP so had to do something else to get that.
 

·
Registered
Joined
·
25,992 Posts
stevereis said:
All the regular HME stuff works fine. It was just the Java enabled stuff that did not show up. If you do not need them, then the Buffalo bridge is fine.
I really wanted HD photos on my S3 and big DLP so had to do something else to get that.
Well, crap...

I run Galleon for music and photos (mostly for the music app), and that is Java based - it does NOT work with this bridge, I just found out. :(

However, the TiVo "ToGo" and "GoBack" both work with it. Go figure.

Also, Unbox worked fine.

I can't get TiVo Desktop to run reliably on my PC, so I've been using Galleon. I guess I will have to either get two TiVo Wireless adapters, or some other bridge/router...
fortunately, I can still use this one elsewhere.

:(
 
1 - 20 of 54 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top