TiVo Community Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Okay, so a lot of water got into my UPS (don't ask), I heard zapping sounds and it shorted out my TiVo. I immediately unplugged everything, went out to buy another UPS, came home and made sure all of the plugs were dry and plugged my TiVo into a normal surge protector (since the UPS wasn't fully charged yet).

The TiVo booted up nicely, but a few seconds into a program, the picture dumped to black and the TiVo would not respond to the remote. I unplugged the TiVo, and here I sit.

I have two (nearly full) 160GB hard drives so I'm worried I'm going to lose everything. Thoughts?

Chris
p.s. this is by far the best forum for everything TiVo/TV related! Thanks in advance for your help!
 

·
TechKnow Guide
Joined
·
12,027 Posts
Did the Tivo get wet, too? A dying UPS should not have "zapped" the devices plugged into it. The fact that your Tivo booted up and allowed you to start watching suggests that it wasn't damaged. I would suggest trying to restart/reboot it again.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
No, the TiVo did not get wet. But I've had hard drive problems in the past (due to bad wiring in my apartment), so I was worried that any kind of electrical disturbance might further damage my drives....anyway, I just rebooted it, and so far, so good. I'll keep my fingers crossed and make a DVD recording of my Season Pass list.....

Thanks!
 
1 - 3 of 3 Posts
Top