TiVo Community Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi. I am trying to install the new version of Tivo Desktop (2.5) but the installation prompts me to uninstall version 2.4 first. When I click the button to uninstall version 2.4, I get an error message that says "Sorry. Tivo Desktop requires Windows XP SP2 (Service Pack 2 or later)." I click OK and am taken back to the installation prompt telling me I have to uninstall version 2.4 to proceed.

I get the same error message when I try to uninstall from the control panel of my Windows Vista Ultimate system.

Any ideas how to uninstall Desktop 2.4 so that I can install version 2.5?

Thanks!
 

·
Registered
Joined
·
4 Posts
I get this same problem. I also ran the Fix24Setup.exe which I am afraid didn't work since I had 2.4 Preview and not just 2.4.

I love my TiVo, why does it have to be so rebellious sometimes ;-)

-Jeff
 

·
Registered
Joined
·
4 Posts
Update - I took matters into my own hands last night and removed C:\Program Files\Tivo, C:\Program Files\Common Files\Tivo, and whatever else I could find on the C: drive. I removed the TiVo Beacon service (sc delete TiVoBeacon2 or whatever the service is called, see details in Services GUI). I then took to the Registry and went nuts (maybe make a backup first ;-). I removed anything I could find that said TiVo (almost). Rebooted, and I was able to install 2.5. Yay. Maybe I didn't need to do all this, but it worked and I'm happy enough with that.

Now, in summary, Windows, and especially the Windows Registry, stink.
 
1 - 9 of 9 Posts
Top