TiVo Community Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
20 Posts
Having the same problem. I have submitted a formal complaint to the BBB about this issue.

I strongly urge you to submit a detailed complaint about this problem if you are affected. I will post this suggestion to the other threads if possible.
 

·
Registered
Joined
·
20 Posts
As I posted in the other thread:

I'm serious about people submitting a complaint to the BBB (bbb.org). A couple years ago I had a problem with the hotspot LTE service in my Ford Ranger, and AT&T is the company Ford is contracted with. AT&T wasn't fixing the problem after about a year, so I finally submitted a formal complaint to the BBB. AT&T responded quickly and was eager to resolve the problem, which they did.
 

·
Registered
Joined
·
20 Posts
I submitted my BBB complaint, and Tivo did respond by calling from the Executive Relations office. They gave me a direct number to call and kept in touch with me every week. Ultimately, they are also getting no updates from the engineering team. Last time I asked them to request specifics--what is the reason for the delay? Why is this taking so long, exactly?

They also offered me a "discount" on a new unit at $25 off. That was the same price Amazon sold it for at the time. I have told them that I already paid for two Minis with lifetime service--why should I buy more when they aren't even supporting the products I have? They later offered another $30 off when the new model was on sale for the whole world, but it's the principle. Something Tivo doesn't have--principles.

They also told the BBB after an initial call that they tried "repeatedly" to contact me. I responded with the fact that they called once and left no voice mail. Then I got an email. I called back the next day. The BBB closed the complaint a little over a week ago when Tivo said I refused the discounted replacement. I told the BBB they weren't being given the full story and that my money spent included lifetime service. After that, everything went silent.

Not a surprise, but Tivo doesn't care and isn't working the problem. There's no way they're working on it without a resolution after so long. They'd make a bigger gesture if there was any concern over keeping customers or honoring the money already spent on their products.
 

·
Registered
Joined
·
20 Posts
The Tivo Executive Relations office has just informed me that this bug will not be fixed, in spite of the fact that they advertised we could do this. I was also told that all users will be forced onto TE4 "soon". Time for Dish I guess.
 

·
Registered
Joined
·
20 Posts
OK, I just got another call from the Executive Relations team. The same person that told me this won't be fixed says they just today got a notice from the engineering team that a fix for this will roll out the first week of May. Here's hoping this news is accurate! Sorry to have shared my last update, but I'm only relaying what is supposed to be the authoritative source.
 

·
Registered
Joined
·
20 Posts
Boy, it's still not working for me. They called on time earlier this month, and both units failed to downgrade. After that I've been waiting. They just called and said now I need to upgrade the Roamio again, then update, then downgrade and that will work. My units still stuck.
 
1 - 8 of 8 Posts
Top