TiVo Community Forum banner

Trouble upgrading Series 1 - cannot expand

849 Views 1 Reply 2 Participants Last post by  gastrof
I have a Series 1 SA, Philips HDR212.
Trying to replace the 80 GB original drive with a 250GB Quantum as well as install a Cachecard with NIC. Nothing on my Tivo, so no need to backup any video.

Problem # 1
So, downloaded mfstools 2.0 and backed up drive using the command :
mfsbackup -6so /mnt/dos/tivo.bak /dev/sda

Connected new drive and restored via:
mfsrestore -r 4 -s 127 -zpi /mnt/dos/tivo.bak /dev/sda

When I tried to expand with mfsadd -x /dev/sda, the error message is :
Expand of /dev/sda would result in too many partitions.

I currently have 6 partitions on the new drive. When placed back in my tivo, I only have 79 hours available.
I tried to use winmfs to expand, but winmfs will not see the drive. Winmfs saw the old drive when I made a backup. I made backups with both mfstools2 and winmfs, but the restore with winmfs kept freezing the Tivo, not sure if this was because corrupted file or whatever. Should I just reset and start again?

Okay, problem 2.
Installed a Cachecard with 512 RAM and network interface. After installing the drivers, the Cache is seen and I can telnet into the Tivo via a network.

When I insert the proper dialing prefix of #,401 to make the Tivo update through the network, the update fails.
I believe the Tivo version is version 3.0xxxx. The card does have a static IP and the proper gateway. Maybe my DNS is not setup correctly?

Any help, especially with expand my drive is appreciated.

Thank you
1 - 2 of 2 Posts
Sounds like something for the TiVo Underground or TiVo Upgrade forums.
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.