TiVo Community Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
I'm trying to transfer some files to my tivo using tivoftpd but am running into a problem.

I used Steve Jenkins guide to install turbonet in my T60 and all went great.

I have the copy of tivoftpd from his bootcd in /var/hack/bin. It starts up ok and I'm able to login from my windows machine via the command line ftp. When I try to send a file though I get this error:

"503 Only ASCII and binary modes are supported"

I get this error even after I manually set the transfer mode to ascii by doing "ftp>ascii"

Anyone have any thoughts as to why tivoftpd is doing this?

tricky
 

·
Registered
Joined
·
255 Posts
I'm sure you shoud be transferring files in Binary mode not ascii. Try typing "bin" followed by enter and then try transferring.
 

·
Registered
Joined
·
255 Posts
Personally I've found Filezilla to be the most reliable Windows ftp software with TiVo. Just remember to set it to binary not auto and make sure it's set for single connection. Also don't forget to Disconnect before closing it otherwise you'll need to restart ftp on TiVo
 

·
FavoriteColorIsClear
Joined
·
419 Posts
It is no different then doing ftping to a computer or server. Try smartftp, wfsftp, cuteftp, filezilla, bulletproof.....

What ever ftp program you choose...maybe you should read the help or readme to find out how to use them. It is actually pretty simple.
 

·
MacTiVo
Joined
·
130 Posts
I have had the same problem using an Apple Mac running in Terminal mode. After certain commands, you get the following messages:

500 Syntax error, command unrecognized.
227 Entering Passive Mode (192,168,0,200,4,2)
503 Only ASCII and binary modes are supported.

Don't see why this should be a problem when ftp'ing from another UNIX host - I'm using Mac OS X Tiger 10.4 which is UNIX based.

Any suggestions, or is a commercial FTP package the only answer? On my Windows PC, I can use Microsoft FTP client and it works fine.
 
1 - 9 of 9 Posts
Top