TiVo Community Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
Hello everyone. First time, first time.

So, I just bought my HD TiVo yesterday and everything's running smoothly except on the TiVo desktop side of things.

I'm using a Powerbook running OSX and I downloaded and installed TiVo Desktop for Mac Version 1.9.3.

I've gone into System Preferences/Other/Tivo Desktop and I've published my music and photos.

Alas, I'm not seeing my music and photos anywhere on my TiVo.

My Firewall is turned off, but...even still, when I go to System Preferences/Sharing/Firewall..."Tivo Desktop" does not show up in the "alllowed" list.

I've also read about navigating to /Library/Application Support/TiVo to do some stuff, but there is no "TiVo" folder or anything similar in my "Application Support" folder.

My knowledge of manipulating stuff on the mac is slim to none, so I don't really know where to go from here. Any advice? Maybe uninstall and reinstall? But how do I uninstall?

Thanks,
Chris
 

·
Registered
Joined
·
2,064 Posts
If you've started the server, and it's running (you'll have a 'Stop' button in the TiVo Desktop preference pane) then it could be your router; that's come up frequently in the last few months.

So, a few questions:

- how is your TiVo connected to your Mac (what does your home network look like?)
- what brand of router are you using?
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #3 ·
Hi Dennis,

Yes, I've starter the Server.

I'm using a D-Link Wireless router with cable internet. The TiVo connects to it using that TiVo Wireless G USB Adaptor.

The router would really affect this in a way that my mac wouldn't show any reference to TiVo accept for under System Preferences/Other?

Thanks for replying!
 

·
a rkester says what?
Joined
·
14,221 Posts
Is the Tivo on the network and verified as functional? (AKA can it call out to get guide data etc)

Can you access the Tivo via a web browser (I dunno if the HDs can do this or not)?

This way we can confirm it is connected correctly before we troubleshoto the Tivo software side of things.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #5 ·
Yes, the TiVo is on the network. Its pulled all the guide info and every other network related function on the TiVo box itself works perfectly from what I can tell.

How do I attempt to access it from a browser, if it were to work?

Thanks.
 

·
a rkester says what?
Joined
·
14,221 Posts
You should be able to point your web browser at:

https://xxx.xxx.xxx.xxx/nowplaying/index.html and see all the content on your tivo's now playing list. Assuming it's connected correctly. It will ask for a name (use "tivo" and password (aka your media id #). If this comes up then we know your tivo is fully connected to the network and that the tivo desktop software is probably to blame.

Obviously you want to put your tivo's IP address in place of the xxx.xxx.xxx.xxx

You should get something like this:
 

·
a rkester says what?
Joined
·
14,221 Posts
A quick fix that helps sometimes is just to turn OFF and then back ON the Tivo server via the preference panel. This has helped mine when it has lost connection to the Mac on occassion.

Also try reinstalling it to make sure you have the latest version as a possible option to try.

I'm not at home so I can't look at mine to see if I can help more.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #10 ·
rkester said:
A quick fix that helps sometimes is just to turn OFF and then back ON the Tivo server via the preference panel. This has helped mine when it has lost connection to the Mac on occassion.

Also try reinstalling it to make sure you have the latest version as a possible option to try.

I'm not at home so I can't look at mine to see if I can help more.
No, this is a great start. I'm not at home either, so I'll have to try the browser thing in a little while.

Are you a Mac user? Any advise on how to uninstall before I try to install again?

Thanks again for all of your help.
 

·
a rkester says what?
Joined
·
14,221 Posts


I just DLed the installer to see if it offers an uninstaller too... checking now... No uninstaller that I can see. If you run the installed again, it just offers to "Upgrade" your installation. I'd try that just the same.

FYI, there is also a way to enable the Video tab (in the above screen) easily too to share video that is MP2 (Not sure if this works on Tivo HD or not) format. You can do so using a little freebie app that comes bundled with VisualHub (a great Shareware video converter).

 

·
Registered
Joined
·
7,679 Posts
myyours said:
This is no time for jokes!

:)
Sorry, we like to pick on each other and help at the same time.

I'm getting a MacBook or iMac soon, so this info will come in handy

And this is my1,500th post. Took over 6 years.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #13 ·
Alright. I've made some progress. My music and photos are now available on my TiVo. All it took was one more install and everything clicked this time.

However...upon typing in https://xxx.xxx.x.xxx/nowplaying/index.html, I was greeted with an "Access Forbidden: No authorization." So something still isn't right.

I'm going to play around with a couple other things and see if I can't crack this.

Congrats cowboys2002 on 1500 posts. I'll be lucky to hit 15 in 6 years.
 

·
Registered
Joined
·
45 Posts
You should try going to http://(your tivo's ip) with out the /nowplaying because that is when it should allow you to log in. Also try https://(you tivo's ip).

Also you should be able to find it via Bonjour or Rendevious whatever it is now.
 

·
Registered
Joined
·
45 Posts
You have to use https and if you do it the Bonjour way delete everything after the "./" and change add the "s" in to https. Then you will be asked for a username and password. Username is "tivo" and the password is your media access key.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #16 ·
No luck with either of those ideas either, bkane. Access Forbidden no matter how I swing it. Thanks though!
 

·
Registered
Joined
·
2,064 Posts
myyours said:
No luck with either of those ideas either, bkane. Access Forbidden no matter how I swing it. Thanks though!
It's an HD TiVo. You can't connect via https without a MAK, and TiVo doesn't assign MAKs to the HD units (yet? -- this might happen if and when multi-room viewing and/or TiVoToGo get enabled for HD TiVos)
 

·
Registered
Joined
·
2 Posts
Hi. I'm having the same problem: can't get any info from my tivo's web server except the standard page that's available in the non-secure server. I get "Access Forbidden" when I try to get anything from the secure server - never prompted for a username or mak.

I'm using a Mac and trying to hit a Tivo HD. I can't ssh to it either.

I didn't see an actual resolution to this problem in the thread... did we decide it's just no doable at the moment??
 

·
Registered
Joined
·
2,064 Posts
wit_happens said:
I'm using a Mac and trying to hit a Tivo HD. I can't ssh to it either.

I didn't see an actual resolution to this problem in the thread... did we decide it's just no doable at the moment??
Both the Series 3 and the TiVo HD require a MAK but aren't assigned one because of the whole TiVoToGo/CableCARD issue. It's just not doable right now.
 
1 - 20 of 21 Posts
Top