TiVo Community Forum banner
1 - 12 of 12 Posts

· Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
So far my new TiVo experience is terrible.

Haven't been able to successfully get my new BOLT activated and working (5 days now). I've called TiVo Customer service 7 times. They cannot find my account. They try to pull it up by my phone number... my name... my address.... my email... my TSN.... Nothing. "Sorry sir, I can't see your account. I can't help you." ...

Customer Service has been horrible.... Difficult communication.... After they "can't help me", they say someone will call me back in 20 minutes. Never had a call back yet (several days).

I called the Cancellation number to CANCEL my TiVo service. So frustrated at this point I would just send my BOLT back for a refund and get DirecTV.

RETENTION Department..... "Sir, I cannot locate your account, so I cannot cancel it."

I can log into my account at TiVo.com, and all my info (name,email, etc...) all seems correct. My billing history shows my service payment, and my device, but I cannot CANCEL online. The website directs me to call Tivo... where they say I don't exist.

QUESTION...

Is there any sort of higher level customer service that can help me? Is there any way to cancel if they can't resolve the issue? Should I just dispute the charge with my credit card company?

A few additional details....

Activated new TiVo BOLT on Monday. Did the activation online through the BOLT Set Up steps. Paid $149 for 1 yr service.

Comcast installed cable card on Friday. Cable card reads good, seemed to be a knowledgeable installer.

TiVO BOLT stuck on "Acquiring Channel Information" 2%.. for 2 days.

If anyone can help, I would really appreciate it. Like many of you (probably), I took a leap of faith and ordered the TiVo equipment, and hoped it would be a better solution than using Comcast or DTV equipment, The family questioned the expense involved, but I believed it would work well and everyone would like the functionality. So far, this has been a terrible experience with no path forward from here. I want to get it working or get it gone and I can't do either.
 

· Registered
Joined
·
2,615 Posts
So far my new TiVo experience is terrible.

Haven't been able to successfully get my new BOLT activated and working (5 days now). I've called TiVo Customer service 7 times. They cannot find my account. They try to pull it up by my phone number... my name... my address.... my email... my TSN.... Nothing. "Sorry sir, I can't see your account. I can't help you." ...

Customer Service has been horrible.... Difficult communication.... After they "can't help me", they say someone will call me back in 20 minutes. Never had a call back yet (several days).

I called the Cancellation number to CANCEL my TiVo service. So frustrated at this point I would just send my BOLT back for a refund and get DirecTV.

RETENTION Department..... "Sir, I cannot locate your account, so I cannot cancel it."

I can log into my account at TiVo.com, and all my info (name,email, etc...) all seems correct. My billing history shows my service payment, and my device, but I cannot CANCEL online. The website directs me to call Tivo... where they say I don't exist.

QUESTION...

Is there any sort of higher level customer service that can help me? Is there any way to cancel if they can't resolve the issue? Should I just dispute the charge with my credit card company?

A few additional details....

Activated new TiVo BOLT on Monday. Did the activation online through the BOLT Set Up steps. Paid $149 for 1 yr service.

Comcast installed cable card on Friday. Cable card reads good, seemed to be a knowledgeable installer.

TiVO BOLT stuck on "Acquiring Channel Information" 2%.. for 2 days.

If anyone can help, I would really appreciate it. Like many of you (probably), I took a leap of faith and ordered the TiVo equipment, and hoped it would be a better solution than using Comcast or DTV equipment, The family questioned the expense involved, but I believed it would work well and everyone would like the functionality. So far, this has been a terrible experience with no path forward from here. I want to get it working or get it gone and I can't do either.
If you haven't already done it and even if you have, do it again, reboot your Bolt, i.e., pull the power for a few seconds and then reapply it. Depending on what may be going on with Tivo's servers, it is not unusual for 24 hours to pass on a Tivo not purchased directly from Tivo to become fully activated.
Rebooting, power off and on, usually makes the Tivo connect to Tivo's servers and pick up any new account settings.
 

· Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
If you haven't already done it and even if you have, do it again, reboot your Bolt, i.e., pull the power for a few seconds and then reapply it. Depending on what may be going on with Tivo's servers, it is not unusual for 24 hours to pass on a Tivo not purchased directly from Tivo to become fully activated.
Rebooting, power off and on, usually makes the Tivo connect to Tivo's servers and pick up any new account settings.
I have, but that's a good idea. I will do it again. Good to know that there is sometimes a delay in the action at TiVo. That at least gives me some idea of what could be happening.
 

· Registered
Joined
·
5 Posts
Discussion Starter · #10 ·
So.... Now I log in to My TiVo.com account. Everything is there. I click on the support button and fill out the form to e-mail a support question.

and it will not accept my request for support because the form includes info like e-mail address and TSN from the box and again.... I don't exist.

How cant the Tivo.com site (and my account) be so separate from all other account info?
 

· Registered
Joined
·
5 Posts
Discussion Starter · #11 ·
Good news... COMCAST was able to push out some "signals" to the cable card, and the TiVo BOLT is now working. Such a relief. TiVo Customer service still tells me my account doesn't exist, but it's working, and I can access most things on TiVo.com. so I can live with that for now.

Thank you for your suggestions.
 

· Registered
Joined
·
2,883 Posts
Good news... COMCAST was able to push out some "signals" to the cable card, and the TiVo BOLT is now working. Such a relief. TiVo Customer service still tells me my account doesn't exist, but it's working, and I can access most things on TiVo.com. so I can live with that for now.

Thank you for your suggestions.
Personally I would still slowly, when you have time, figure out why TiVo can't find your account. Murphy's Law says this problem will become relevant to you again, at the worst possible time.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top