TiVo Community Forum banner

Tivo-Amazon/unbox movie rentals stopped downloading with Fall 2007 update

2288 Views 9 Replies 6 Participants Last post by  scottb
So last weekend I tried out Tivo-Amazon/unbox movie download rental and it worked great. This weekend, after the Tivo fall 2007 service update, I tried to rent and download another amazon/unbox movie title, and the download never started. I go to my email, and I find an email from amazon that it has been already downloaded, and charged for. So I think to try it again, and I rent again from my Tivo, and get charged again, but no download. So I reboot Tivo and do a test "Connect to the Tivo Service" and that works okay.

Also, another new problem with the new Fall 2007 service update. When going to the "Download TV/Movies" menu to get to the Amazon/Unbox option, with the new Fall 2007 service update, I get "Please Wait......" and it never gets there. I had to press the Tivo button to get back from the "Please Wait...." forever screen. Repeated tries does eventually get there, but it is not reliable, as it was before the update.

Does anyone else see this behavior? I have a Tivo S2 TCD200040 with a wired ethernet adapter to a 6 Mb Comcast connection. And no, I don't have any problems with my ethernet network, and daily calls always work fine.

Any help would be appreciated. :(
1 - 10 of 10 Posts
I have downloaded from Unbox since the update with no problem. It can take quite some time before the download begins however depending on the server load.
This may have been an amazon problem not and not a tivo problem, I got the update the other day, I transfered a show no problem, but had the same exact behavior trying to connect last night.

First I went through the 99 cent blurb on the tivo central page and got the please wait (forever it seemed) I hit the tivo button to exit back to tivo central chose the blurb again but this time chose the getting started. Thought maybe withhte update had to reinitialize amazon, came back out, clicked on 99 cent browse BINGO browsing the pages I get about 3 deep and it goes unresponsive, back out to tivo central chose amazon unbox through NORMAL menus (not 99 cent blurb) connect browse everything seems to be fine and operating normal for about 8 minutes browsing all kinds of pages finally decide to buy a rental, choose and get the neverending please wait.

Finally I gave up with the impression that it was probably friday night overloading and went and played a video game instead.

This morning no problem same process no neverending wait. Transfered the rental fine watching hot fuzz as I type.
See less See more
Here's some updated info about my progress so far with amazon.com/unbox and the Tivo Fall 2007 Service update:

Tivo support had me reboot everything, router, modem, etc., and the movie is still stuck in queue at amazon.com/unbox. Tivo support believes that since I have downloaded CNET content since the Fall 2007 Service update, that there isn't anything wrong with the Fall 2007 Service update causing the amazon.com/unbox downloads to fail.

So I'm done with amazon.com/unbox.
I took my ethernet cable that was running from the TiVO to the router (Apple Airport, g version) and plugged it instead into an Airport Express' ethernet port and my download problem has been solved. Doesn't make intuitive sense to me, but there you have it.

I haven't check the slow menus yet to see if this (for some reason) solves that problem too. I can't imagine they're being sent down in real time :)
This actually does make sense. If the tivo's ethernet adapter was not getting the correct duplex negotiated with the old switch, you could get tons of collisions and dropped packets, which will kill TCP/IP performance.
Yeah, I'm gonna replace that switch and see what happens. Time for GB instead of 100 anyway :)

It's working fine with the other stuff plugged into it, but other things are more forgiving!
Unbox is working again for me. I went to Tivo's own Help Forum's and found out about unlinking/relinking my Tivo and Amazon connections. And following those instructions, and waiting at least 30 minutes or more between changes, it again works.

Tivo Fall 2007 Service update (9.1) broke it, Tivo Support couldn't fix it, and once again, the Tivo user community resolves the issue.

If anyone wants details, let me know.

1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.