TiVo Community Forum banner
1 - 5 of 5 Posts

· Registered
3 Posts
Discussion Starter · #1 ·
Ug!! I just got my cable and internet installed in my new apartment today. I am trying to repeat the guided set up but I'm stuck unable to connect to my network.

My set up is a Motorola SB5101 cable modem -> to a Linksys WRT54GC router, on which I am using the wired connections only. My PowerBook and TiVo are conected to the router. The PowerBook gets on the internet just fine, but the TiVo is another story.

When I do the network setup as:
+Get IP address automatically
+No DHCP client ID
I get the error N02, no DHCP server located. My modem has DHCP enabled. I haven't be able to connect to my router to see what it says.

I've also tried manually setting the IP address but then I get the N13 error. I'm not quite sure what to set it to...
According to my computer:
My computer IP address is: (I've put in,,,,, nothing works)
The subnet mask is:
and the router is:
DNS server (optional): blank I've tried putting in just 0s and I did a search for comcast DNS servers and put some of those numbers in but nothing works.

I've tried cutting the router out of the equation, but it doesn't help.
I've restarted everything multiple times, but to no avail.
The only firmware update i could find for the modem is something for vista, I don't think I need that.
I can't access my dumb router, but I update the firmware for it a few months ago so it is probably up to date. I've been able to connect through the router before.
The things that are new to the equation are the modem and the comcast internet service.

Is there anyway to get out of guided setup?

Help please! I don't want to miss the start of Top Model tomorrow.

I do not have a phone line I can do the setup through.

· Series 3
27,200 Posts
I don't think you have your cable modem correctly connected to your router. is not a private network IP but is in fact... (checks ARIN) a Comcast direct IP address.

Make sure that the cable from the modem goes into the Internet jack on the Linksys.

You should be getting IP addresses in the 192.168.1.xxx range, IIRC

ETA: Also in this setup you have two DHCP servers (Comcast and Linksys) broadcasting on your local network.
Very, very bad....

· Registered
3 Posts
Discussion Starter · #3 ·
You're right, it isn't properly connected. I have the modem plugged into the computer 4 port on the router, not the internet in. I can't connect to the internet at all when I'm connected to the router correctly. If I plug my computer straight into the modem I do get a IP address. But when I connect my TiVo straight to the modem it still doesn't work.

How should I fix this?

· Series 3
27,200 Posts
The issue is that the way you initially set things up, only your Powerbook is "authorized" to connect to Comcast Internet (via MAC address).

You need to switch that "authorization" to your Linksys.

I would try first:
  1. Power down cable modem.
  2. Connect cable modem correctly to the Internet port on Linksys.
  3. Power up cable modem.
  4. Connect laptop to Linksys.
  5. Open up a web browers and enter in the address field. This should take you to the router's web interface and you can test whether or not you're getting connectivity. The Status Page should tell you if you're getting an Internet IP address in the 71.228.135.xxx range.

It may or may not be necessary to "Clone the MAC Address" of your Powerbook.
There should be a link to do this under the router's setup page.

ETA: I'm assuming that you've set up or tried to st up the router correctly to begin with.
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.