TiVo Community Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
284 Posts
Discussion Starter · #1 ·
I need some expert help.

I have a Belkin 7230-4 Wireless Router and a working USB adapter. Transfer speed between the computer and TiVo is nothing to complain about, it's 1:1.

The problem is my cable broadband download speed tends to be anywhere from 1/4 to 1/8 of what it can be when hooked up through that router. I've checked the router website and cannot find anything that helps to fix the problem.

So, I'm thinking about getting a different router. "Auto speed sensing" might be what I need. The Linksys WRT54g seems to have that.

I'm just concerned that switching my router will increase the download speed from the internet at the expense of the transfer speed.

If anyone has a comment or suggestion to get the best of all worlds, it would be greatly, greatly appreciated. :)
 

·
Registered
Joined
·
6,965 Posts
Maybe I am being a little thick but when you say your download speed is 1/4 to 1/8 of what it can be, what are you comparing it to?

Maybe you could be a little more specific on what all the pieces of your network are and how they are connected.

Thanks,

atmuscarella
 

·
Registered
Joined
·
284 Posts
Discussion Starter · #3 ·
I have Road Runner. When I hook up my computer directly to the modem, the speed is in the 2-4mb download range (depending on the time of day). Turn around and hook up the Belkin router and the speed decreases to the 300-500k download range. The Belkin site says the MAC address needs to be cloned to the router, which I did. No difference.

So right now, it's a cable broadband modem outputting to the Belkin wireless router going to the computer.

The D-Link USB 802.11b adapter I have on the TiVo is working fine and I have no complaints on that transfer speed between the PC and TiVo.
 

·
Registered
Joined
·
6,965 Posts
Are you sure you have the terminology correct, just for reference:

1024 Kilobytes (KB) = 1 Megabyte (MB)

however:

1024 Kilobytes (KB) = 8 Megabits (Mb)

I think my DSL connection at home shows as a 3 Megabit (Mb) connection (not 3 Megabyte (MB)) and I get 200-400 KB/sec downloads. At work on a T-1 line I see about the same download rate as I do at home.

Have you actually seen 2-4 Megabyte (MB) (2000 - 4000 KB) downloads when you connect directly to the cable modem?

Anyone else want to comment on this?

Thanks,

atmuscarella
 

·
Registered
Joined
·
284 Posts
Discussion Starter · #5 ·
Oh, I don't doubt I have the terms wrong. :)

I just compare speed tests results between direct connection and wireless router connection. On the same speed test site, the direct connection shows a 2000-4000 download speed while the routered connection shows 300-500. Which is where I get my 1/4 to 1/8. Plus, it's such a big gap, it doesn't take much surfing to know there's a difference.

http://www.speakeasy.net/speedtest/
 

·
Registered
Joined
·
284 Posts
Discussion Starter · #7 ·
I do have encryption enabled, but the computer in question is connected via ethernet directly to the router. I didn't think that would affect it?

I just disabled the encryption and reran the speed test. It's still showing the lower numbers.
 

·
Registered
Joined
·
6,965 Posts
Ok that site is giving the info in Kilobits/sec (Kb) which means your cable modem is a 2-4 Megabit (Mb) connection which makes sense. It also means the 300-500 Kilobits/sec you are getting through your wireless router is terrible.

Do you have a friend that could let you borrower his/her wireless router to see what happens with another router?

Have you talked to the cable company to see if they have any recommendations?

If you were going to buy the Linksys WRT54g locally and if it is easy to return I would go ahead and buy it and see how it works.

At this point I think you need someone that knows more about Belkin 7230-4 Wireless Routers than I do to recommend changes on the router.

Good Luck,

atmuscarella
 

·
Registered
Joined
·
284 Posts
Discussion Starter · #9 ·
I don't know of any wireless routers to borrow.

I called the cable company "it's a router issue". I swear that would be the answer regardless of the real problem. :rolleyes:

At this point, I think I'll be going out to Circuit City and just try that Linksys. It couldn't hurt.
 

·
Registered
Joined
·
284 Posts
Discussion Starter · #11 ·
davezatz said:
Have you tried updating the firmware on the router? Is the router new and/or has it always been slow? Have you tried a factory reset to see if that helps any?
Firmware is up to date on my router. But, the firmware hasn't been updated by Belkin since 10/04, which is something I was focusing on. The most recent Linksys update on the router I was looking at was just yesterday, so that's why I was thinking of switching.

Router is less than 2 months old, the Cable broadband is new. I had 384k DSL prior to this.

Factory reset was done a week or so ago to the same results.
 

·
Registered
Joined
·
284 Posts
Discussion Starter · #13 ·
Wow! I didn't even know about that. I'm glad this is really a router issue and not something I didn't know how to fix. Thanks a million!

Off to CC to get a Linksys.....
 

·
Forum Denizen
Joined
·
2,620 Posts
I have the F5D7230-4 ver 2000, so I decided to test too. On DSL I get
Download Speed: 1385 kbps (173.1 KB/sec transfer rate)
Upload Speed: 131 kbps (16.4 KB/sec transfer rate)
Which means my router is fine. What version is yours?

I am Curious
 

·
Funkadelic
Joined
·
4,705 Posts
For whatever it's worth, I migrated from a similar model Belkin to that Linksys model (though there are several versions/iterations now) due to connectivity problems. I don't recall having throughput probs though. I'd definitely look for something that updates firmware now and then - at least you know the model is still supported.

The Linksys has been rock solid, probably the most stable and reliable router I've used. Though I just saved a few bucks and bought my mom a Dlink that had a huge rebate - hopefully I won't be kicking myself troubleshooting it all the time. ;)

(Surprisingly the cheapie Belkin had some port forwarding options I don't have with the Linksys, but I can deal.)
 

·
Registered
Joined
·
284 Posts
Discussion Starter · #16 ·
CuriousMark said:
I have the F5D7230-4 ver 2000, so I decided to test too. On DSL I get
Download Speed: 1385 kbps (173.1 KB/sec transfer rate)
Upload Speed: 131 kbps (16.4 KB/sec transfer rate)
Which means my router is fine. What version is yours?

I am Curious
Ver 3000. I wonder if this is strictly Cable broadband related?
 

·
Registered
Joined
·
6,965 Posts
davezatz,

Was the D-Link a DI-524? I picked one up a few weeks back for $20 after rebate. Has been working great as my second LAN since I installed it. It was recommend to me by one of the moderators on Wi-Fi Planet Forums. Seems like a great router for the price.

Thanks,

atmuscarella
 

·
Funkadelic
Joined
·
4,705 Posts
atmuscarella said:
Was the D-Link a DI-524?
I just called my mom... I got her a starter kit which includes that specific router (DI-524) and also a USB adapter (DWL-G122) for her PC. Now all I got to do is fly down one day and set it all up. :) Glad to hear the router is doing well!

(I've thought of maybe setting my mom up remotely via LogMeIn, but not sure how slow that would be over dialup. In retrospect, it would have made more sense to set it up at my place then mail it to her.)
 

·
Registered
Joined
·
284 Posts
Discussion Starter · #20 ·
The new Linksys is installed: download speed is what it should be, connection strength with the TiVo is at or above what it was, and transfer between PC and TiVo is about the same. I'm happy :):up:
 
1 - 20 of 22 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top