TiVo Community Forum banner

Series 2 Locks up when booting following latest service update

1045 Views 5 Replies 5 Participants Last post by  heg
During the latest service update (10-12-2007), my Tivo series 2 locked up on the update screen. After waiting overnight, I power cycled it to try to re-boot it. It continues to lock up in the "Just a few minutes more" screen.

Has anyone else had a problem with this service update?
1 - 6 of 6 Posts
Somewhat common.

Unplug, wait a while, plug back in, keep trying.

And see here (click me).
happened t0 my 80 hour & they admit problems but want me to for over $150
[email protected]

calling them back right now raising hell, any one else?
Thanks for the reply. Mine finally fixed itself after multiple power cycles and much patience.

Sounds like a Tivo upgrade problem not a disk problem. See the thread referenced in the 2nd post above.
My Series 2 locks up now (I have the new 9.1 software) when I try to access the Download Tv Movies menu to go to Amazon Unbox and it will lock up when I try to access the Kidzone menu.
Any idea why? All of the other features seem to be working.
O-o-oh, yeah! We turned on the TV at breakfast this morning and got a TiVo screen saying it was installing a new update. The screen said it could take up to an hour, maybe more. We turned it off and tried again five hours later - no change! Unplugging it and repowering it did no good. It tried to boot, but never succeeded. I have no idea what software version is on it or what version it was trying to install.

Dang, we really can't watch TV any longer without TiVo. Live TV is so unforgiving. No replays, no watching shows when I want to-not when the network schedules them. I want my TiVo back!
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.