TiVo Community Forum banner

Roamio pro upgrade issue

1209 Views 4 Replies 3 Participants Last post by  joeytino
I am upgrading my Roamio Pro and picked up a 10GB WD100EFAX (Supposedly a still safe drive) I am not transferring anything so I installed it and it only reflected 187 HD hours available after the initial setup. I know it should have seen the first 3tb of space. I have tried to clear the drive writing all zeros as well as trying to clear the MBR and it still does not change anything. What am I missing?

1 - 5 of 5 Posts
When a drive is over 3TB the built in auto-format does NOT format the first 3TB. I don't know where that myth got started. :(

What actually happens is that it formats the drive for the full size and reboots, but then a bug in the software that doesn't like partitions over 2TB takes over. At that point it takes the lower 32 bits of a 64-bit field in the MFS volume header that lists the total volume size and reformats the drive again using that truncated figure.

DIY 10TB Roamio
Thank you for your reply.

I found that myth in several places on here and other places so it is out there and was pretty much the main cause of my confusion. I followed the process you linked and I am at 4GB after copying over the data from my old drive. Once I get back home I will follow the rest of the process to add the rest of the drive. Finally I want to downgrade back to TE3 as my wife HATES TE4 with a passion so this was her chance to go back.
Finally I want to downgrade back to TE3 as my wife HATES TE4 with a passion so this was her chance to go back.
A rollback to TE3 will delete all programs on the drive.

How to Rollback Hydra from Roamio and Mini's v1
That is not a problem. However once I rolled back I lost over half of the recording time from around 11,000 SD recording hours to around 4,800. I tried to re-run the commands and though the msadd ran OK, mfsaddfix went as far as coalescing then stated no free partitions found. Erasing MFTools added partiton pair. Put it back in the Tivo, the divorce message came up and once that completed the Tivo was OK, but no added space of course. I tried zeroing out the drive and try again starting with a TE3 image I created and I still ended up in the exact same spot with the same issue running mfsaddfix. Perhaps the zeroing out missed something. ( I used diskpart.) I really do not want to zero out the drive again but perhaps that needs to be done unless there is something else I can do.

Update: If I run a mfstools info it displays 14 partitions and says I can expand 4 more times. I think there is my issue as the Roamio max is 14 partitions and I did not get everything when I wiped it in Windows. Still odd that downgrading wiped out the expansion.
See less See more
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.