TiVo Community Forum banner

registry key problem installing TiVo Desktop

2025 Views 3 Replies 3 Participants Last post by  ttwiv
I just tried to install TiVo Desktop 2.4a (using an administrator enabled account), and at the end of the install process I get the error: "failed to create key Software\TiVo\Desktop\Transfer".

This might have something to do with the fact that over a year ago I installed an older version of TiVo Desktop under the account "Administrator", but since I've stopped using "Administrator" and instead use "twalker", which has administrator privs. I uninstalled TiVo Desktop from the "Administrator" account some time ago.

The one thing I tried was to edit the registry and for the key: HKEY_LOCAL_MACHINE\SOFTWARE\TiVo and right-click that key and select "permissions" and add "twalker" with full control. That did not work. I also tried uninstalling from twalker (where I installed it from this time) and reinstalling (with that new permission set on the key) -- still no luck.

Any ideas?
1 - 4 of 4 Posts
Do you have any security suites or program that might be blocking you from installing?

From the forums tivo com area I found this.

I was finally able to get this to work. Here is what I did.

1. Start registry editor as follows:

Start -> Run... -> regedit -> OK

2. Be extremely careful with Registry Editor. One false move can mess up your OS.


4. Expand +Software

5. Right click on Tivo -> Permissions...

6. For each user select the "Allow" "Full Control" box.

If this does not work you might want to re-install 2.4a and try the above steps again.
See less See more
I had exactly the same problem. After every installation I would get two pop ups; one said failed to add key software/tivo/desktop/transfer, and the other, failed to add key software/tivo/desktop/publisher.

I was on the phone with Tivo support for over an hour. It became obvious I was dealing with someone that had a script to follow rather than someone that has any clue what my problem was. I was finally told it was the fault of my computer and call the computer manufacture about it.

After looking around on this community I saw the last post and it became clear this was a problem that Tivo should recognize and have an answer for. Here is what I found out all on my own:

It appears that Windows XP home addition defaults to a lot of user settings at install that may be in part due to the manufacture of your computer. One key area is setting user permissions on files, folders AND registry entries. I would also assume that running some antivirus programs or network security programs (even in the past and uninstalled) can leave your windows with many of the permissions set to not allow you to do things...one being changing a registry key.

The last post was on the right track; however it did not work for me at first. What I found on my system was that the TIVO key was being entered in TWO places in the registry:


I right clicked on each of those entries and selected properties. Both keys did not have full permissions so I selected FULL PERMISSIONS for both profiles/users that displayed then exited the registry editor.

Running the desktop again I got rid of the popup and got anew one saying something about the server not running. I rebooted and PRESTO! Tivo Desktop was working.

On my machine; an HP Pavillion762n I checked the registry afterwards and it added the 2 missing keys "transfer" and "publisher" to the HKEY_CURRENT_USER branch.

Tivo tech should know this is happening and have a quick patch to fix this install bug.
See less See more
Grappler -- did this happen to you after you installed from one user account (e.g. administrator) then uninstalled then tried to reinstall from a different user account that has administrator access?

I too solved the problem the way you did (adding full control permissions for the user on the HKEY_CURRENT_USER/SOFTWARE/TIVO key). I've been meaning to come back to this thread and log such -- but let it slip through the cracks.

Yes -- before I solved the problem myself, TiVo support told me to contact Windows support (or PC support) to find out what's wrong with my registry. It may not be TiVo's fault that the permissions are that way -- or it may be their fault if such is a side effect of the way their uninstall process works -- which is why I'm wondering if you had first installed it under one user, uninstalled it, then re-installed under another user before you got the problem.
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.