TiVo Community Forum banner
1 - 4 of 4 Posts

· Registered
3 Posts
Discussion Starter · #1 ·
I have a TiVo brand 540040 that I purchased a month ago. I immediately and successfully upgraded it using Weakness bracket, instructions, and their CD image to add a 120GB Maxtor drive. After a couple of weeks listening to the slightly aaudible whine of the original 40GB Maxtor quickview, I decided I will upgrade the A drive to something bigger and quieter. My first upgrade was such a breaze, and I felt like superman, so I undertook the second and fatal upgrade...

1. I bought a WD 250GB drive at Best Buy ($69 with 2x $40 rebates)

2. I read and re-read Hinsdale's How To.

3. Burned MFS tools with large drive support ( PTVupgrade LBA48 CD v4.01 )

4. Put in the drives:

hda, Primary Master - FAT-formatted extra HD
hdb, Primary Slave - Original B drive
hdc, Secondary Master - Original TiVo A drive.
hdd, Secondary Slave - CDROM

5. Sizes reported fine, so no locked drives.

6. Went through the backup routine:
mkdir /mnt/dos
mount /dev/hda1 /mnt/dos
mfsbackup -f 9999 -6so /mnt/dos/tivo.bak /dev/hdc /dev/hdb

7. Size of the resulting file was ~ 600MB.

8. Instead of being smart and following the recommendation to test the backup first, I went ahead and just restored the backup onto the new drive, simultaneously expanding it onto the original B drive:

unmounted, turned off the PC, and put the new A drive as hdc
mount /dev/hda1 /mnt/dos
mfsrestore -s 127 -xzpi /mnt/dos/tivo.bak /dev/hdc /dev/hdb

9. The restore went successfully, I unmounted, shut down the PC and took out the drives.

10. When I started my TiVo, it showed the welcome screen, then the Almost There screen abd then it rebooted and went back to Welcome, then Almost There... You get the picture... After about 4 reboots, I came to grips with reality and turned it off. After ensuring that all cables are tight, and still getting nowhere, my assumption became it's either a bad new drive or a bad backup.

11. To test those assumpptions, I tried to first perform the restore onto the new drive only (250GB) - result: Tivo stuck at the Welcome screen forever.

12. Then I restored only onto the original B drive (120GB) - result: Reboot Loop.

13. Then I tried the original combo - A:40GB, B:120GB - result: reboot loop.

14. Bad backup?

15. What do I do now? I would hate to go back to clean slate (Vonage kinda worked for me for the initial setup but it was a big pain), but if I have to, how do I do that? Meaning, how do I return the whole thing to the factory settings, preferably with my new drives in place - A:250GB, B:120GB.

· Registered
1,601 Posts
You need to get a fresh image from somebody on the forum. One other thing, for your ultimate combo you need a bigger swap file than 127KB - 1KB for every 2GB hard drive space which will mean using tpip command after restore - better do some more reading.

While waiting for a fresh image download the drive fitness test for your 40GB drive from manufacturer's web-site and check your drive.

· Registered
3 Posts
Discussion Starter · #3 ·
Dear funtoupgrade,

to quote your sig: "If I have asked a question please don't tell me to search the forum - I don't have an hour to waste."

To tell you honestly, I am an amateur in this. I really have little acumen or resources to educate myself using the haphazard school of forum reading. If you have a suggestion on how I can get my system to work, I will listen very carefully, but vague statements like "uses tpip" whatever that is, make no sense to me.

Thank you!
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.