TiVo Community Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hi,

I'm attempting to add a start up program to /etc/rc.d/rc.sysinit.author - however this file does not get run when the system is rebooted.

In addition I have made changes to to rc.sysinit and these do no get run.

I have also set up a /.profile to extend the path when using telnet and this does not get run.

I can successfully run all the commands entered in bash and they work fine, however they are not run from the rc.sysinit.author etc.??

ANy help would be appreciated.

Cheers
 

·
Astute User
Joined
·
17,877 Posts
You have to chmod 755 the files
The first line in both has to be #!/bin/bash
 

·
Registered
Joined
·
20 Posts
classicsat said:
You have to chmod 755 the files
The first line in both has to be #!/bin/bash
I'm trying to get the file attributes changed on my rc.sysinit.author file too(to get it to run endpad on starting), but always get the following when telnet'd to it.

bash-2.02# chmod 755 /etc/rc.d/rc.sysinit.author
chmod: /etc/rc.d/rc.sysinit.author: Read-only file system
bash-2.02#
bash-2.02#

I cant have always had this as I have a line in the rc.sysinit.author that runs tivoweb on startup... but now I cant edit it or change the file attributes.

I'm newish to all this, so any help will be appreciated
 

·
Astute User
Joined
·
17,877 Posts
You have to mount the partition as RW.
 

·
Registered
Joined
·
20 Posts
Billy66 said:
Type this command

mount -o remount,rw
Have typed the above in at Bash promt...this is what I got on screen..

bash-2.02# mount -o remount,rw
usage: mount [-hV]
mount -a [-nfFrsvw] [-t vfstypes]
mount [-nfrsvw] [-o options] special | node
mount [-nfrsvw] [-t vfstype] [-o options] special node
bash-2.02#

Is the syntax correct??
 

·
Again with shoelaces
Joined
·
3,273 Posts
It is correct. Make sure that you see that "o" is the lowercase letter "o" and not the number zero. You should be able to simply copy that and aste it into your telnet client.
 

·
Registered
Joined
·
20 Posts
Thanks for reply Billy...

I get the same again..

Pasted from the thread this time to be sure.....

bash-2.02# mount -o remount,rw
usage: mount [-hV]
mount -a [-nfFrsvw] [-t vfstypes]
mount [-nfrsvw] [-o options] special | node
mount [-nfrsvw] [-t vfstype] [-o options] special node
bash-2.02#
bash-2.02# chmod 755 /etc/rc.d/rc.sysinit.author
chmod: /etc/rc.d/rc.sysinit.author: Read-only file system
bash-2.02#
bash-2.02#

Not able to FTP to tivo now either... going to do a reboot to be sure....
 

·
Registered
Joined
·
20 Posts
David Platt said:
Actually, it's not quite correct. ;)

You're missing a '/'. Try:

mount -o remount,rw /
David

Thanks very much. Worked a treat. Do I need to change it back after I have modifies the file??

Would I use

mount -o remount,r /

??
 
1 - 12 of 12 Posts
Top