TiVo Community Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
#
#!/bin/sh
#

if /sbin/insmod -f /lib/modules/turbonet2.o devicename=eth1 macaddr=00:0B:AD:69:C6:67 ; then
/sbin/ifconfig eth1 192.168.2.200 netmask 255.255.0.0 up
/sbin/route.tivo add default gw 0.0.0.0 netmask 0.0.0.0
fi

dials up on phone ok (but is not on my lan (wrong subnet))

#!/bin/sh
#

if /sbin/insmod -f /lib/modules/turbonet2.o devicename=eth1 macaddr=00:0B:AD:69:C6:67 ; then
/sbin/ifconfig eth1 192.168.1.5 netmask 255.255.255.0 up
/sbin/route.tivo add default gw 192.168.1.1 netmask 255.255.255.0
fi

now this is on my lan and I can telnet, ftp bash etc but I can't make programme calls at all either over the phone or broadband (after ,#401 prefix.)

can one of you guru's please point out the error of my ways?
thank you
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
Firstly, thank you for the replies.
Here is my file now
#
#!/bin/sh
#

if /sbin/insmod -f /lib/modules/turbonet2.o macaddr=00:0B:AD:69:C6:67 ; then
export DYNAMIC_NET_DEV=eth0
/sbin/ifconfig eth0 192.168.1.5 netmask 255.255.255.0 up
/sbin/route.tivo add default gw 192.168.1.1 netmask 0.0.0.0
fi

This came from my running nic_config_tivo
Here I discovered that it was set to use dialup still.
Changed that so it now says daily call network.
I am unsure as to what settings to put into the phone setup,
does it still need the ,#401? what about the Phone available and Dial tone detection ?
I have currently got no prefixes and both detections to off (the wife has tried all combinations this afternoon) but now I get the error on Connecting (Failed. Number unavailable.)
Is there anything anyone can think of for me to check please?
The trouble with buying one with a card already fitted is you don't know what else has been done to it, although the previous owner assures me that his did work over the internet.
Oh I can ping that TiVo server as well.

Thanks in advance.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #8 ·
Hi, ok I've updated the cachecard drivers to the 20050218 (from silicondusts site)
I've put the phone settings to None, None, Tone, On, On.
When I try the test call I get, Preparing Done, Dialling Done, Connecting Failed. Number unavailable.
My router is indeed 192.168.1.1 and I've even set the DMZ to be the TiVo's ip address just in case any ports needed to be open.
It's doing my head in now lol.
Want any logs or anything?
Sorry to be such a pain.
Thanks
Jim
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #10 ·
Right then I've done this :-
Hacking the Ident.itcl file

* From the # prompt type:
/var/hack/joe /tvlib/tcl/tv/Ident.itcl
* Look for this line puts $conn "IDB_TIMESTAMP: $now"
* Insert puts $conn "Content-Length: 0" directly after that line
* Save the file:
Ctrl-K-X
* From the # prompt type:
mount -o remount,ro / (Makes the File System Read Only)
sync (Flushes your changes to disk)

and this
To avoid the problem with the daily call failing when using internet data downloading you need to make sure your each of your rc.sysinit.author or rc.sysinit.author.edit (the one the Startup Editor utility edits) command lines ends with preferably >/dev/null 2>&1 & or at least an & sign. If the lines don't have this ending then these utilities aren't properly backgrounded and interferes with the operation of main Tivo applications such as the Daily Call.

And still I get Failed. Number unavailable.
Anybody know of any other files I can check please?

Thank you in advance for your patience and suggestions
Jim

Edit, this is my rc.sysinit.author file

#!/bin/bash
echo "Running rc.sysinit.author..."

/var/hack/tivoweb-tcl/tivoweb >/dev/null 2>&1 &

/var/hack/endpad.tcl -s 1 -e 4 -sugqual 40 -sugeq -auto >/dev/null 2>&1 &

# /var/index/tyindex > /dev/null 2>&1 &
# /var/index/tyserver > /dev/null 2>&1 &

# /var/hack/vserver/vserver &

/sbin/route.tivo del default

echo "rc.sysinit.author is complete"
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #11 ·
OK I got the call to complete by typing this into a bash prompt
route.tivo add default gw 192.168.1.1
should I change my rc.sysinit.author to have this instead of route.tivo del default ?
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #13 ·
Right oh mate, I'll give that a go.
I'd like to thank all of you for your help.
Much appreciated.


...now to enable mode 0.... :eek:)
(well there's 200GB of hard drive in it and it's connected to an LCD panel so why not!!)

:)

Cheers all
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top