TiVo Community Forum banner

Problems With Tivo DeskTop Version 2.8.2 Recognizing My Premiere XLs

3016 Views 14 Replies 6 Participants Last post by  bacevedo
Here is my setup:

I have 4 Tivo Premiere XLs and 1 Tivo HD hard wired through an 8 port gigabit switch to my Verizon router (MI424WR), which I have daisy-chained to a Netgear wirelsss-N router (4-port).

The reason for this setup is for a couple of reasons:

1) The Verizon router is a wireless-G router and I wanted my laptops to work of a faster wireless-N router, which is why I daisy-chained the Netgear router.

2) I have 5 Tivos (plus 1 Xbox for my son and 1 Verizon DVR) but the router only have 4 LAN connections. So I needed the 8 port gigabit switch.

My new PC has Tivo Desktop version 2.8.2 installed. The Tivos transfer shows between each other no problem (and at a fast rate between the Premieres). However, I cannot see my music or pictures on any of my Tivos.

To really confuse the situation, I have another older PC that has Tive Desktop version 2.5 installed and I used to be able to see my music and pictures on the Tivos until recently but now that has gone silent.

I called Tivo and the answer I got was that Tivo Desktop does not work with a gigabit switch as "most users are not that sophisticated". But I know it does work as my old PC with Desktop version 2.5 used to work.

Does anyone have a clue as to what is going on here or how to fix this problem? I'm thinking perhaps if I were to put an older version of Tivo Desktop on my new PC that might help but I do not know how to get an old version of this software or which older version to go with.

Any suggestions would be appreciated.

Thanks in advance !!!
1 - 15 of 15 Posts
Are the router and wireless router on different subnets? What is an example IP address of your TiVos and your PCs? The TiVo Beacon (or Bonjour) won't traverse subnets, so if TiVo Desktop is on a different subnet from the TiVos, they won't see it.

You could try connecting your PC with TiVo Desktop to the same switch as the TiVos and see if Music and Photos appears.
Right. If you are using two routers, you are likely splitting your LAN into two subnets. Set up the one that isn't connected to your ISP as an Access Point, set it up with a static IP address on the other router's subnet, and make sure it isn't doling out IP addresses as a DHCP server.
I have the switch hooked up to one router only which is putting out addresses to the Tivos. I think Tivo Desktop has a problem dealing with a gigaswitch. I was hoping to see if a prior version of Tivo Desktop did not have this problem.
Windracer - thanks for the quick response.

My PC is on the same subnet as the Tivos. That is what has me stumped.

From my Verizon router, I have a line to the gigabit switch which is where all the the Tivos are all wired into. Also from the Verizon router is a line to the PC where the Tivo Desktop is setup. Also from the Verizon router is a line to the Netgear router of which no Tivo or PC is hooked up to. The idea behind using the Netgear router is to use it's wireless-N capability.

This is why I say there must be something within the gigabit switch that is stopping the Tivo Desktop software from "seeing" the Tivos. Phyically it should "see" each Tivo. When I called Tivo support they told me that Tivo Desktop "does not like gigabit switches" and it would not work with a switch. I think they were just trying to get me off the phone.
I was wondering if perhaps an earlier version of Tivo Desktop might work because I did call Tivo support awhile ago and got someone on the phone who did seem to know what he was talking about and suggested that an older version might work but my phone call was cut short (I've had that happen to me a few times when I call Tivo - and I'm calling using a land line).
See less See more
Ok, I just wanted to clarify that your PC wasn't on the wireless router.

I see no reason why TiVo Desktop wouldn't work through a switch. In my setup, my PC is hanging off a switch (albeit not a gigabit switch, it's an old Buffalo wireless router that has the wireless disabled) that is connected to a MoCA adapter and all of my TiVos are using MoCA as well, and TiVo Desktop works just fine.

Any firewall software on the PC that could be blocking TiVo Desktop? Finally, are you using the TiVo Beacon or Bonjour for the TiVo Server? You could try switching from one to another and see if that helps.
I've shout off my Firewall and even took my anti-virus off my PC just to see if that was the problem. No luck. I'm also running Windows XP Pro, not an earlier version of Vista. At this point, I am at a loss as to why Desktop will not recognize my Tivos.

WINDRACER - How do you obtain an earlier version of Tivo Desktop? Are you running 2.8.2 on yours PC?
Forgot to say in my last post - I've tried both Beacon and Bonjour. Nothing worked.
I'm using 2.8.2 on Windows 7 Home Premium x64. You might be able to find older versions of TD floating around (try searching here on TCF maybe).

I know I've read about routers filtering out multicast packets (which would affect Bonjour). Does your switch have a web configuration page you can get to? If so, maybe check the settings to see if anything might be filtering that traffic.
I have almost the same issue as JANNINO. I installed TD 2.8.2 and was not able to see my music list on any of my TiVo's (two Tivo HD's and one S2). Although, the problem could have been present TD 2.8.1 since I haven't used the music feature for a while. Seeing a list of movies, etc. on the PC works fine.

Anyway, I was able to track down a copy of TD 2.8. After cleaning up the previous installation of TD 2.8.2 and installing TD 2.8, that resolved my issues.

I searched this forum and tried a few solutions that worked for others but they did not work for me.

My pc/media server is Windows 7 x64.
DinoBambino - How did you track down an older version of Tivo Desktop? I'd like to try that solution to see if that would work.
I am having the same problem with 2.8.2 with my 2 premeires that are on 14.8.

I installed 2.8.2 (was using 2.8 before) last night and started having problems today.

This is definitely an issue with 2.8.2. When I was installing it, it gave me an error that I had a newer version of the Bonjour software, so it didn't install its version of Bonjour. It's possible that was the problem, but I am not going to waste my time trying to figure it out.

Thanks for the links to 2.8. I guess I will just go back to an older version until TiVo posts a new version that does what it is supposed to do.

I am also on Windows 7 Pro 64 bit, so maybe it is an issue with that OS setup.
OK, so it just started working again on its own. I was getting ready to uninstall 2.8.2 and figured I would look at it one more time. When I went in, it was working again.

Not sure what changed (I hadn't done anything), but it worked itself out.
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.