TiVo Community Forum banner

My Lifetime Phillips Series one... Dead?

1506 Views 6 Replies 5 Participants Last post by  designbot
I have a series 1 Tivo that I upgraded 4 years ago with a turbonet card, and 80GB hard drive, and lifetime service. About 8 months ago, I found it sitting at the "tivo is starting, please wait a minute" screen.

It wont boot anymore. I put the original HDD back in the unit to see if the drive died, changed the drive jumpers, removed the turbonet card, etc. Nothing works. It just sits at that screen and fails to boot up.

I guess the motherboard is shot? Do I have any other options? It has lifetime and turbonet card installed. I would really hate for it to go to waste.... :(

I basically wanted to sell it if I can get it working. I dont know if it has any value or not in its current stage
1 - 7 of 7 Posts
It does have value if you sell it on eBay as is. For about $90 you can get Philips to exchange the unit for a refurbed one and transfer the lifetime over to the replacement unit.
Even th ough i have opened it, upgraded it, etc?
Philips does not care but you will need to remove all the upgrades or they will be gone.
I have an old Sony that started doing the same thing yesterday morning. We put a bigger hard drive in it last Xmas and tried all of the things "grenex" did with the same result. Anyone know what is going on?
Hate to add to this thread, But for about 5 days or so I have been trying to get my series one Phillips backup and running. I have finaly made a large post on what I have done, and so it seems hopeless for my series one.
My Philips got stuck at the green screen about a week ago too.

Maybe the Series 1's heard about the TiVo HD's coming out...
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.