TiVo Community Forum banner

missing thumbnail decoder????

33211 Views 37 Replies 18 Participants Last post by  LONDON1939
Anyone know the solution to this one? I'm trying to transfer tivo files to mydvd studio and it says that I don't have the thumbnail decoder? Where do I get one? Thanks in advance.
1 - 20 of 38 Posts
I know your pain. Just got MyDVD 6.1, set up my style for the first attempt at burning a DVD, went to add a TiVo recording, it asks for the password which I provide, says it's importing media, then quickly gives me the following error message:

"Could not make a thumbnail. Make sure you have the appropriate decoder installed. -47010"

The number following the message leads me to believe it originates from WMP, but here's the kicker: when I play the TiVo recordings thru either TiVo Desktop 2.0 or TiVo2Go within MyDVD (both of which use WMP 10.0 to handle the actual playing), they play just fine, sound and video perfectly synched. I've been reading some of the threads regarding codecs, and have attempted to make a few changes to try to solve this problem to no avail. Can anyone point me in the right direction please?

Thanks for any help.
I'm in the same boat :(. I also get the following error when I try and record one of my shows to DVD using MyDVD.

"Could not make a thumbnail. Make sure you have the appropriate decoder installed. -47010"

Any help would be greatly appreciated. The sonic knowledge base has a couple of suggestions but nothing that seems to work:


search for "47010".

Thanks in advance,
I finally "fixed" this problem! Here's what I did...

  1. Uninstalled All Sonic software
  2. Rebooted
  3. Reinstalled Sonic Software
  4. Problem went away!

That's right, all I did was uninstall and reinstall Sonic and everything seems to work. This "solution" doesn't make me feel good however; I'm happy that it's working. Anybody else come up with a better solution?
At least someone got this problem solved for themselves. You're right about Sonic not being much help. I tried your suggestion, even going so far as to remove the "\program files\common files\sonic shared" and the install directories, but upon rebooting and reinstallation the same problem reared it's ugly head. Maybe I should try uninstalling again and searching the registry for all instances of "Sonic" and deleting them for a real clean install, but that be more of a headache than it's worth.

The Sonic site seems to indicate that the problem may be a corrupted video stream. The TiVo recordings I have were recorded at the highest possible quality setting, so maybe MyDVD doesn't know how to handle them? I'm guessing here. I really don't know which way to go - wait for Sonic to fix this (that could be a loooooong time) or call customer support and ask for a refund as the program is not delivering the functionality for which it was purchased. With 7 episodes of Deadwood sitting on the HD waiting to be burned, this is quickly getting exasperating.
See less See more
I doubt that High quality is the problem. My shows were recorded at high quality. When you uninstalled the program, did you reboot like it suggested? Let me know what you end up doing. I'm not sure that I've really "fixed" the problem. I hope it doesn't come back the next time I try and reinstall.

Also, are you able to play your recordings in WMP? If yes, I would expect that the recordings are not corrupt. Just my opinion...
Yes, I did reboot after uninstallation and yes, the recordings play fine in WMP, correct A/R, sound and video all synched up. I didn't mean to imply that the recordings were corrupt, but that possibly because they were recorded with the HQ setting, it may be scrambling MyDVD's little mind trying to interpret them. Being as I have not yet been able to get past this bug, I'm reaching for straws to come up with an explanation as to why. Anything seems possible at this point.
I know what you mean. I was reaching for straws as well. Once again, let me know if you figure out this problem. You might want to give Sonic a call...
I have the same problem, and a completely clean reainstall did not help.

I'm a complete newbie at TivoToGo, having just purchased a new computer that can actually handle it. :)

The reference to thumbnails reminds me that I don't get tivo video thumbnails in Media Center either, but at least they play there. Is it normal for WMC not to produce tivo thumbnails?

*sigh* Well, I'm working on it too.
Well, this doesn't make me feel good. I thought my "solution" would work for others :(.
Here is what the Sonic support site says about this problem. It's not specific to TTG, but it does mention "conflicting codecs" (in other words, MyDVD is poorly written and can only handle certain codecs). I had installed some codecs before MyDVD, so I uninstalled them and now it's working for me.

Cannot complete last command, could not make thumbnail. Make sure you have the right decoder installed. DVDError - 47010.

Importing Issues
When trying to import a video file, the message "Cannot complete last command, could not make thumbnail. Make sure you have the right decoder installed. DVDErr - 47010." pops up.
Sonic is currently looking into the exact cause of this error.

Right now, we have seen this error occur in a couple of instances. The first being that when a user uses scene detection while capturing the video. Try disbaling automatic Scene Detection while capturing and see if the problem imporoves. In some case, glitchy or old VHS tapes have a hard time being converted into the small video thumbnails. With Scene Detection activated, the large number of thumnails maybe cause the error. Again, Sonic is looking into the exact root of the problem and will update this page as soon as more is known.

Another reason for this problem could be the files are being imported may either be corrupt or not compliant for either a VCD or DVD. Make sure that you go through the parameters of a compliant files with the links below. Points of interest are the resolution, frame rate, and audio sampling rate.

Some customers have also encountered this error while capturing from their DV devices via firewire. Some common errors that can occur to get a decoding error through firewire:

1) Make sure that the firewire card/port is OHCI compliant for data. Many cards claim to be OHCI compliant for data use, but are not. The largest offender are cards made by video companies. We have seen many problems with cards made companies like Matrox, Pinnacle and other companies that also bundle or package their software with the 1394 card. These firewire software bundles sometimes add proprietary information through the actual firewire card that can encoding/decoding errors. Sonic's customers have the best luck with Adaptec, Keyspan, and Belkin firewire cards.

2) Make sure that your firewire drivers are OHCI compliant. The most common offender for non-compliant drivers is Texas Instruments. These are usually included with Dell computers. While the t say they are OHCI compliant, they are not as Adobe has also made a statement about their non-compliance in their Premiere "read me" documentation. To make your drivers' OHCI compliant, follow the steps below:

a) Right click on "My Computer" Select "properties"

b) Click on "Hardware" tab-->Device Manager

c) IN Device Manager window, drop down "IEEE 1394 Bus Host Controller." If the driver below doesn't say "OHCI Compliant IEEE 1394 Host Controller", Right Click on that driver and select "Properties".

d) Click "Update Driver"

e) In the Hardware Wizard, click on the "install from a list or specific location." Click Next.

f) Select "Don't Search". Click Next.

g) Select "OHCI Compliant IEEE 1394 Host Controller". Click Next. Driver begins to be installed.

h) Click Finish on next window.

3) The final reason could be the actual video from the camera. Some things to check:

a) there are no major glitches in the video stream

b) The audio is 48k/16 bit stereo

c) Your are not capturing 16:9 (while we do support 16:9 video, most cameras do not add the necessary "flag" in the video stream that required by the DVD specification to ensure the aspect ration will be maintained).

Finally, this error can also happen when there is a large set of conflicting codecs on the same machine as MyDVD. These codecs are interfering with MyDVD's video filters thus MyDVD cannot read the files properly.

Remove any codecs that are not associated with MyDVD and Windows. Remove them one at a time until MyDVD works and then reinstall the codecs that previous to the offense codec.
In regard to decoders. Sonic is supposed to have the decoders in its software but I also found at least 3 patches on their site to update the 6.1 version for tivo. One is a decoder. My guess is the patches might solve the problem.

Their site is hell to negotiate for info or support but they have the patches on their site and some similar problems posted with answers about error messages.

Microsoft also has a free decoder for windows xp. I had downloaded that in advance just in case it was needed for playback of burned dvd's. It's called Windeccheck.exe but i am not sure if its only for playback or if it will help.
Just got around to installing the trail software this morning. I'm getting the same thumbnail error. Did a complete uninstall/reboot/reinstall/reboot. Didn't help.
What codecs do you have installed? Try running DECCHECK.exe.
I noticed you posted what sonic said about a problem. How did you get in touch with them for support?
I tried via the web but it keeps telling me there is no support for mydvd 6.1 which is hard to believe since the i just purchased the software from them 2 wks ago. And the site is not very user friendly for finding out if there is phone support. Can you advise? Thanks.
Grinderhand said:
I know your pain. Just got MyDVD 6.1, set up my style for the first attempt at burning a DVD, went to add a TiVo recording, it asks for the password which I provide, says it's importing media, then quickly gives me the following error message:

"Could not make a thumbnail. Make sure you have the appropriate decoder installed. -47010"

The number following the message leads me to believe it originates from WMP, but here's the kicker: when I play the TiVo recordings thru either TiVo Desktop 2.0 or TiVo2Go within MyDVD (both of which use WMP 10.0 to handle the actual playing), they play just fine, sound and video perfectly synched. ....
The way all these applications work, including WMP10 is on top of a DirectX mechanism called Directshow. You can get a pretty good idea of how it works by simply playing with graphedit- Take a look at this note and the notes it links to that points someone to Graphedit and another handy tool. Maybe you should follow instructions to load up a graph and play it before considering what I am about to tell you.

My guess is that the reason you get an error message mentioning thumbnail is that it is unable to load a scaler filter to size the video for display on your screen, and make bitmaps of the first frames. The names you will find in the directshow filters listed for your machine mention either the words "scaler/scalar", "resizer", or even "image preparator". The Sonic one Is named "Sonic Scaler".

Anyhow, the sonic scaler is probably sitting there on the graph.insert filters.directshow list, but here's the odd thing about filters. If Directshow first loads a filter incompatible with the filter you need, then the filter you need will never get loaded. Many people get a bad decoder that gives jittery, bad sync, or other problems, but the solution was to nuke or set the priority down for the module immediately upstream from the decoder- When the demuxer (oftentimes a Nero demuxer (aka "splitter) was removed, then the problem went away.

It means nothing that you cannot load up the sonic scalar filter. This happens when vendors don't like you using their modules from other applicaions like graphedit. If it is in the list, chances are that mydvd will load it if we figure out what is blocking it from being loaded

If you are following my thinking here, I would predict the blocking module to be the one immediately upstream - that is, a video decoder. So presuming this is true, llet's do this experiment:
  1. drag drop a .tivo file into graphedit
  2. You should see a graph displayed-
  3. Does the decoder say "Sonic Cinemaster decoder?
  4. If not, follow my instructions concering removing the demuxer, and just apply it to removing the decoder you found instead
  5. After unregistering, attempt drag dop of the .tivo. If you never can get Sonic Cinemaster video decoder to autoload into the graph, then tell me what splitter /demuer is being used.
  6. if you do get cinemaster decoder loaded on a drag drop, try to run MyDuD. Does it fail at the thumbnail step?
  7. if you still have failures, reregister all the filters you hacked out. Let me know the names of the filters with scaler, image or resizer in the name. Also need the list of MPeg decoders you have on your machine.

I know many of you may prefer something that works rather than try to figure out what was causing the problems. If that is the case, you can try searching for "free codecs" and experiment installing/ deinstalling these code packs until the problem goes away. Eventually, one may install either a splitter or a decoder that is compatible with MyDVD's scaler.

Good Luck.
See less See more
Upon loading a .tivo file into GraphEdit, here's an idea of the graph I get (I trust you're not interested in the audio split, so I'll present the video progression)

.tivo file -> Sonic Mpeg Splitter -> Sonic Cinemaster DS Video Decoder -> Video Renderer

This is not the original graph I was getting upon first running GraphEdit. Another splitter was being used which resulted in another decoder being used. By unregistering a few things I was able to come up with the graph above, figuring that if using the Sonic splitter did not result in the Sonic scaler being auto loaded, I didn't know what would be a better choice than that. One thing I DID notice while playing around with things here is that many if not all of the Sonic filters were NOT installed in the locations they were registered as being, probably a result of my not installing MyDVD in the location suggested by the install program (somewhere other than c:\program files\...) i.e. registered as being in c:\program files\common files\sonic shared\filename but instead located at installationlocation\Sonic MyDVD Studio Deluxe\filters\filename. Upon copying all the filter files to their registered locations, I thought this might clear up the problem, but it did not. Others with this problem may want to make certain that their filters are in the registered locations using the tools you suggest, as this may clear up the problem for them.

Here's a list of the filters you wanted to know about:

Filters with Resize, Scaler/Scalar or Image (Preparator) in the name:

9x8Resize (program files.movie maker)
ROXIO Image/Colour Source 3.0
Sonic Scaler

Mpeg Decoders:

Cyberlink Video/SP Decoder (?)
dicas MPEG-4 Video Decoder
DivX Decoder Filter (?)
DV Video Decoder (?)
Ligos MPEG Video Decoder
MainConcept (AdobeEncore) MPEG Video Decoder
Moonlight-Elecard MPEG2 Video Decoder
MPEG Video Decoder (quartz.dll)
Mpeg4 Decoder DMO
Mpeg43 Decoder DMO
Mpeg4s Decoder DMO
Nero DVD Decoder (?)
Nero Video Decoder (?)
Roxio DVD MPEG2 Decoder
Roxio MPEG2 Video Decoder
Roxio SVCD MPEG2 Decoder
Sonic Cinemaster DS Video Decoder (?)
Sonic MPEG Video Decoder
Vorbis Decoder (?)
Windows Media Video Decoder (wmvds32.ax) (?)
Windows Media Video Decoder (wmv8ds32.ax) (?)
WMVideo Advanced Decoder DMO (?)
WMVideo Decoder (?)
WST Decoder (?)
XviD MPEG-4 Video Decoder

The items followed with (?) were included because I wa not certain they were Mpeg decoders or not, but I thought for the sake of investigative work, I would include them.

Any suggestions you or anyone else can come up with will certainly be welcome. I can see where you're going with this but at this juncture am uncertain what would be the best course of action. Thanks for any further direction you can provide.
See less See more
1 - 20 of 38 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.