TiVo Community Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
This question may have already been asked, so if it was, I am sorry for the spam.

I have spent about 6 hours on this now and I am getting a little angry at that little TiVo. Here is the situation.

I have a TiVo (Series 1 Phillips, HDR218).
I have a backup image of the original drive.
I have two new drives.

In my computer I can hook up the CD-ROM and boot drive on one IDE channel and on the other IDE channel I can hook up the two new drives. My problem is, in MFS tools I cannot get the program to take the backup file off of the boot drive and put it onto one of the other drives.

Can anyone suggest any tips or a site that will give me the answer. I have read a lot of sites out there and I apparently don't understand, so be gentle :)

I am really computer savy, so you don't have to dumb down the language, I am however tivo unsavy :)

Any help would be awesome.

Thanks.
 

·
Registered
Joined
·
482 Posts
I'd suggest following hinsdales instructions. Make sure you have the drives connected as suggested and make sure that you follow all instructions. I have done this many times and the only time I get messed up is when I think I know what i'm doing and don't double check all instructions. There is also a new script called zipper that you could try.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #4 ·
My issue is when I do the mfsrestore, I don't know how to add the backup file to that command. The file is on a CD and it is on a hard drive. I was trying to get the file from the hard drive since I am using the mfstools bootable CD-Rom.
 

·
Registered
Joined
·
2,469 Posts
Mount the partition containing the backup file
- create the mount point if it does not already exist md /mnt/dos
- mount the partition mount /dev/hda1 /mnt/dos

Follow the restore to a single drive from backup directions if you are restoring to a 250G drive
- restore mfsrestore -s 127 -r 4 -zxpi /mnt/dos/filename.bak /dev/hdc

Adjust /dev/hda1, filename.bak and /dev/hdc for your system.

There are interactive directions see the first post in the sticky thread at the top of this forum WeaKnees Interactive Online TiVo Upgrade Instructions
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 ·
Thanks a bunch. I think this might work!!!

I have a couple of questions:
  1. HOw do I do this process if I have two disks? Do I just put the same image on each disk?
  2. Do I need to have the drive formatted to a specific file system before I restore it, or does the mfsrestore format the drive for me?

Thanks for all of your help.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #7 ·
So what I did was this:

Code:
mount /dev/hdb1 /mnt/c
mfsrestore -s 127 -r 4 -zxpi /mnt/c/hdr.mfs /dev/hda
mfsadd -r 4 -x /dev/hda /dev/hdb
Is that correct? I will test it at home tonight :)
 

·
Registered
Joined
·
2,469 Posts
You will need to unmount /dev/hdb before the mfsadd. umount /dev/hdb1

The new drive should be tested in the the TiVo before you wipe out the backup file when making the TiVo 'B' drive out of hdb.

You are sure the backup is on the CD and there is nothing else you want to keep on /dev/hdb.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top