TiVo Community Forum banner

Humax DVD Sluggish Remote

36529 Views 175 Replies 60 Participants Last post by  SoBelle0
Anyone have a problem with their Humax Tivo/DVD burner and a sluggish response to the remote control? I've got a regular standalone and the humax and the difference between the two is significant. The humax tivo seems to respond very sluggishly to the remote (particularly when fast forwarding) and it gets real annoying... Sometimes you hit the button once and it sends two clicks to the tivo, sometimes you can't get it to stop fast forwarding at all.. Tried replacing batteries etc... It's driving me nuts! Hoping someone else has run into this and found a solution...
1 - 20 of 176 Posts
I have essentially the same setup and not the problem. Your non-Humax remote should also work with the Humax. Give it a try and see if the other remote is any better. If so, replace the remote. If not, try getting in touch with Humax to see what they say.
I have a friend who had exactly this problem. She got a 40-hr Humax w/ DVD recorder. I helped her set it up.

When we were setting it up, the remote control worked just fine. However, somewhere after that point, it started showing the same behavior as the original post listed here. It would at times feel sluggish, and other times do a "double click".

For anyone unfamiliar, a double-click here means when you want to go up, it goes up twice, etc., not the PC kind of double-click. It's intermittent. Sometimes you get one click, sometimes two. It makes really simple things like selecting a show really bearish, and using the A-Z panel practically unusable.

The guys at the store said she couldn't just get a new remote, so she had to get a whole new box. Grrr... So she returned it in exchange for a different one.

She got the replacement and set it up. Now it's showing the same behavior. She's ready to throw it across the room (and I think "it" means both the box and the remote control). I'm afraid she's going to stick to it despite its annoying behavior when really someone ought to help her out.

I have a Humax 80-hr w/DVD and it's working fine.

We sort of suspect that the latest O/S download did something to the box. Before we go there, I'm going to see if my remote (since it's also Humax branded) will make the system behave any differently, thereby isolating whether the problem's in the remote or in the box.

Would love to hear if anyone else is having this problem and what can be done about it.
See less See more
I've had this problem intermittenly on my DRT800, but it seems to only occur when I'm in the HME apps. It happened a few weeks ago, I replaced the batteries and the problem went away. It happened again today while I was playing Same Game, but seems to work fine in all the regular menus.
Another possibility is to get a Universal Remote. The One For All 6131 seems to quite popular with Tivo owners and it relatively inexpensive especially if you can find one on sale or with a rebate.
I have noticed this too; it seems that a reboot every now and then helps speed things up on the DRT-400.
Any luck with trying the other remote?

I have exactly the same symptoms with the DRT800 I just bought.
- responded to the remote nicely during setup
- the next day, after overnight config...

Now the base unit responds very *intermittently* to remote commands

The difference was so dramatic, I thought my daughter had borrowed the batteries for her CD player, but she had not

I tried:
- new batteries, Duracell; no better
- remove the clear plastic protection on base unit;) no better
- restart; no better
- unplug and plug back in; no better

- the red light on remote emmitter responds perfectly to button presses
- the base unit responds fine to display panel knob movement and selection
- they just don't work well together after the overnight config

Any Ideas?

- base unit s/w version is: 7.2.1-elm-01-2-595
See less See more
Count me in with the same problems..

We just bought a Humax 80 hour right before Thanksgiving.. Worked fine. We did the update to 7.2.1 right before Thanksgiving, and when we got back a few days later is when we noticed the 'sluggishness' and multiple buttons pushes, so I think it's definitely related to the update.

We tried:

  • Using a Harmony remote that worked with our old Philips TiVo. Same Results.
  • Using the Philips TiVo remote. Same results.
  • Replacing the batteries in the Humax TiVo remote. Same Results.
  • Rebooting the Humax TiVo. Same Results.

My wife is very upset by this, that our Philips TiVo in the bedroom now is working great after 5 years, and this thing is having issues. Getting ready to take advantage of Costco's return policy and get my money backk.
See less See more
Hello everyone on this thread. I'm back again.

We're still having problems. Recap: my friend has the DRT400 (a replacement for the one's she first purchased that showed this problem), and shortly after initial setup, the system didn't respond immediately to remote control commands, often resulting in a "double" click, and more often not responding at all.

I lent my remote control to my friend. That is, she used the remote control that works just fine against my DRT800. She tried it out, and it made no difference.

I then went to her place, tried restarting, and it still made no difference. I did this twice.

I then switched the batteries in the remote, and still no difference.


- It's not the remote
- It's not the batteries
- Restarting does not help
- It seems likely that a later O/S version did something bad
- IT'S REALLY ANNOYING and makes the system practically unusable.

Sorry, couldn't help the all caps. It's that bad.

Please someone help!!! (Is anyone from Tivo looking at this thread?? hope hope hope)
See less See more
try this - it seems to work

System restarts (warm boot) do not seem to help.

Unplugging the unit, and plugging back in a few minutes later, did not solve the problem (tried that twice, on seperate days)

Leaving the DRT800 *unplugged overnight* and plugging back in the next day seems to have resolved the problem.

The longer story
Last night I wanted to move the DRT800 from the family room to the bedroom for some unrelated multimedia testing. So I unplugged the Tivo, carried it to the bedroom and plugged it back in. Later that evening, as I tried out the Tivo, the responsiveness of the base unit was still sluggish.

As I poked around in the Setup menu, looking for something to try, I noticed the Tivo remote setup for controlling the TV. So I did the TV setup (code 1008) and found that the Humax Tivo remote could control the TV with no hesitation, but still no luck controlling the DRT800 base unit.

As I was going to sleep, I decided that the HDD spin noise from the Tivo would take some getting used to, but decided to wait for the the scheduled update to go through at 1:06am before unplugging the base unit for the night, which I did. The scheduled update went through, it did not change the s/w version, and after the update, the base unit was still sluggish in responding to remote commands. So no luck there. Now I unplug the Tivo for the night.

FF to this morning. I plug the DRT800 back into wall, wait for it to warm up and then hit the Tivo button. I try a few more things from the remote (channel changing, menu nav, etc.) and the base unit is now responding much better to commands from the remote.

For example
- changing channels with num pad is now possible (it was impossible before)
- changing channels with +/- button works now (it is slow , but it works on each click)
- menu nav (Tivo central) is much easier.
- no missed clicks as long as I slow down and wait for the
base unit light to go out before sending the next button click

I'd love to know if this helps someone with their Humax Tivo (DRT800 or other model)

Thank you, Greg
See less See more
Grek said:
try this - it seems to work

System restarts (warm boot) do not seem to help.

Unplugging the unit, and plugging back in a few minutes later, did not solve the problem (tried that twice, on seperate days)

Leaving the DRT800 *unplugged overnight* and plugging back in the next day seems to have resolved the problem.
I have a hard time believing this would make a difference. Either turning off TiVo for 2 minutes or 2 hours or 2 days should be exactly the same to the TiVo box. The amount of time shouldn't make a difference.

Just left my DRT800 off for 10 minutes and it didn't make a difference... same issue.

Someone from TiVo really needs to take a look at this..
I agree that, for a s/w problem, any shutdown time over 1 minute should be equivalent. Still, that's what happened.

There is the outside chance that it is a hardware problem, where booting the system cold has a different behavior than booting the system warm

I'm sure overnight is overkill. Maybe just unplug it long enough for the internal temp to go down to room temp. I know it's a stretch, but if someone currently having this problem could try unplugging for at least an hour or more, and share the results, we could try and eliminate the internal temp during reboot as a cause. I will probably unplug mine and move it again soon, and the problem may come back, but for tonight I'm enjoying having my DRT800 actually respond to the remote.
Looks like it is a h/w problem.

I just found a thread about this issue on Tivo.com's Support forum:


I called Huamx last night with same problem and the customer service rep authorized a replacement unit without any major diagnosing. I don't even think she was a tech support person.
This doesn't sound good. I finally got a new 80hr DVD Humax to replace one that had been stolen and it is showing the sluggish remote problem. Since they don't make the 80hr I don't think I be able to get a replacement and I really don't want to have to send it back for repairs. I'm trying the unplugging the box for a day and I'll plug it back in when I get home tonight.

I'm not seeing any double click though, just have to press the button several times to get the unit to respond. Also it won't hold the dim setting for the clock display, when I reboot it is bright and as it boots at some point it goes to dim, but when it finishes booting it is back to bright. Anyone else see this issue?

I was hoping that getting the software upgrade might help since this box is on 5.4, but from what I've read that doesn't sound likely.

I'll keep my fingers crossed.
Did the cold boot and it does seem to make a difference. I forced a connection and am waiting to see if I get a SW update and to see if things really are better.:)
Called Humax and was told they will replace it under warranty, with 2 options:

1. they put a $499 hold on my credit card and pay shipping in both direction
2. Or, I pay to ship the defective DRT800 to them and they ship me a replacement.

Replacement is either new or refurbished, their choice from whatever stock they have on hand. I'm thinking a new one would be nice, but they likely have loads of refurbished units where hopefully they have isolated and fixed the problem.
I gave up after the problem continued. I called Humax and opted for them to send me a replacement with the CC hold. It's a pain but I figured it's not worth messing with if they can just send me one that works.
Grrr. Slightly annoying, especially since I just bought my Humax new from Costco less than a month ago.

I think I'd rather deal with returning/exchanging it at Costco than getting a refurb at Humax.
agreed - the problem started coming back on my DRT800 after being plugged in for 4 - 5 hours. I called Humax back and set up the exchange for replacement with the CC hold.

I asked about moving my Lifetime account to the replacement machine and the Humax tech on the phone didn't know anything about how to do that.

From what I read on Tivo.com, it looks like we need to go to:

Manage My Account -> Change Service Number

To move the Lifetime to the replacement machine. As long as the replacement is the same make and model of DVR. Here's the support link:
1 - 20 of 176 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.