TiVo Community Forum banner
1 - 17 of 17 Posts

·
From Alabama
Joined
·
51 Posts
Discussion Starter · #1 ·
Here is my network plan at the present:
Internet>>Cable modem>>NetgearRouter>>DLinkRouter>>TiVo1 and TiVo2

I have several questions about this plan. Hopefully someone who is much more experienced than me can help out.

The Dlink is using DHCP IP address from 192.168.0.100 to 192.168.0.110 on channel 6.

The Netgear is using DHCP IP address from 192.168.1.2 to 192.168.1.20 on channel 6.

TiVo1 is wired to the Dlink at 192.168.0.101 and works fine

TiVo2 is struggling to get a wireless connection from the Dlink, but the signal strength is so low it can not hold a connection. I am looking to purchase a gain antenna and a WAP or repeater for the DLink to boost up the signal to Tivo2


Now the questions:

Should both routers be using the same wireless channel?

Should both routers operate on the same channel?

Should I turn off DHCP on any of the routers?

Many thanks

John
 

·
Registered
Joined
·
1,601 Posts
You are asking for major trouble trying to use two routers on the same network. If you need more ports get a switch rather than a router. Routers assign IP addresses and when two are trying to do it you get erratic results.
 

·
Snow-ina-ear
Joined
·
435 Posts
I have two routers as WAPs in my network here; one "G" and one "B". The "B" is there to accommodate my son's laptop which only has a "B" card and needs 64 bit encryption. However, here is how they are hooked up.

The "G" is the main router attached to the cable modem, so it has an external IP address and is the DHCP server on 192.168.0.xxx. The "B" router is set to a fixed address on the network outside the DHCP range. I think it is 192.168.0.90. It does not do DHCP, but only acts as a WAP for the "B", 64 bit WEP access.

Not sure if this helps or not.
 

·
ECT
Joined
·
7,901 Posts
I'm surprised no one has said this yet.

No you cannot run both on the same wireless channel. You have to alternate channels to accomodate WAPs that are too close together. Move one of them to channel 1 or 11.
 

·
From Alabama
Joined
·
51 Posts
Discussion Starter · #9 ·
maharg18 said:
Why are you using 2 routers?
Trying to increase network coverage without having to purchase a repeater or WAP.

The Netgear router is on 2nd floor and must bang its sig thru a lot of walls to get to TiVo2

I positioned the Dlink Router closer to TiVo2. I am trying to use the Dlink as a WAP. The Dlink has been gathering dust, so I was hoping to use it. I guess this is a bad idea?

Gonna have to rethink ways to increase network coverage. :confused:

Many thanks for all the input.

John
 

·
ECT
Joined
·
7,901 Posts
Nope nothing wrong with what you are trying to do. Only thing I would say is make sure that the DHCP server is only enabled on one of them. Also for the one that's just being used as a WAP don't plug the network into WAN port, just plug it into one of the regular ports in the back. That way all the devices on the network should be able to see all it's neighbors.
 

·
not so "New Member"
Joined
·
75 Posts
Does the DLink support "bridge mode"? Different vendors call this different things, so you'll have to look at the documentation. If it does support bridge mode then you should be able to do what you want. Each device needs to use a seperate channel, and if you use the same SSID, you should be able to roam between locations, if you need that capability
 

·
ECT
Joined
·
7,901 Posts
I just went back up to the original post and I want to make sure of some thing...

According to your diagram the Netgear is handling your Internet connection, correct?

Also the Dlink is wired to the Netgear, correct?
 

·
ECT
Joined
·
7,901 Posts
Still sounds OK to me but to reiterate I would

Let the Netgear handle DHCP. The Dlink should allow you to turn off the DHCP service. Also make sure that once DHCP is disabled on the Dlink that you do not have any network cables plugged into the WAN port of the Dlink. Doing it this way allows you to use the Dlink as a WAP and a switch.

Also disable UPNP on the Dlink if it is enabled.

Confirm that the routers are on different channels. Only channels 1, 6, and 11 are not shared so for optimum throughput close routers/waps should be on different channels.

You can use different encryption settings on the routers, they do not have to be the same. Infact it would be better if they were different.

Are you still having problems getting this working?
 

·
Registered
Joined
·
7 Posts
Hello,

I would try to set-up MAC address filtering on the WAP you wish to the Tivo Units to communicate with. In the Set-up table on your WAP/Router only enter the MAC addresses of the units you want to grant permission to communicate with. (Don't forget to also enter the MAC address of the WAP/Router also... you don't want to filter that out). Also the idea of moving the channel to 11 is good. Another thought for the other router used by the laptop computer is to only allow B units to communicate with that router. YOu may also want to do the same for the Tivo units but only allow G units.

I hope this helps.

Rocky
 

·
From Alabama
Joined
·
51 Posts
Discussion Starter · #16 ·
SeanC said:
Still sounds OK to me but to reiterate I would

Let the Netgear handle DHCP. The Dlink should allow you to turn off the DHCP service. Also make sure that once DHCP is disabled on the Dlink that you do not have any network cables plugged into the WAN port of the Dlink. Doing it this way allows you to use the Dlink as a WAP and a switch.

Also disable UPNP on the Dlink if it is enabled.

Confirm that the routers are on different channels. Only channels 1, 6, and 11 are not shared so for optimum throughput close routers/waps should be on different channels.

You can use different encryption settings on the routers, they do not have to be the same. Infact it would be better if they were different.

Are you still having problems getting this working?
To SeanC and others in this thread:

Tnx so much for your help! Your very explicit and clear info allowed me to get this kludge up and running! :up: :up:

I still do have problems with coverage as the Dlink router just can't make it to Tivo2. I bought a gain antenna that added a slight improvement in real estate. I guess the only other option now is to relocate the Dlink a bit closer to TiVo2?

I am still trying get a bit more coverage.

After looking into the antenna store that was reccomended previously, I am impressed as to the wide variety of antennas out there.

Being a ham radio operator, most hams look to improve sig strength. Hams look their antennas first. I have a hard time believing that the 7 db gain for the ant. I bought is really accurate. I think the 7db is more of a marketing ploy than a true spec. Ohhhh....well.

Thanks to all who chipped in to get this far. I really do appreciate it. :)

John
 

·
From Alabama
Joined
·
51 Posts
Discussion Starter · #17 ·
Rocky01 said:
Hello,

I would try to set-up MAC address filtering on the WAP you wish to the Tivo Units to communicate with. In the Set-up table on your WAP/Router only enter the MAC addresses of the units you want to grant permission to communicate with. (Don't forget to also enter the MAC address of the WAP/Router also... you don't want to filter that out). Also the idea of moving the channel to 11 is good. Another thought for the other router used by the laptop computer is to only allow B units to communicate with that router. YOu may also want to do the same for the Tivo units but only allow G units.

I hope this helps.

Rocky
Yes it did!
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top