TiVo Community Forum banner

HME apps on linux not visible on TiVo

1996 Views 5 Replies 4 Participants Last post by  Albert Miller
Do any of you have HME apps running on linux? Have you ever seen the problem where they don't show up in your tivo, but if you run the HME simulator, it sees them fine?

I just set up a linux machine and and moving my hme apps from my windows box to linux. It runs fine and I can use the application from the simulator on my windows machine, but when I go to my tivo, it can't see it. It's not a firewall problem because I've added iptables logging to log all traffic from my tivo. I can see it sending packets to my linux machine and they aren't being denied. It just doesn't show up in the list. I've also used wire shark to sniff the MDNS UDP packets that are sent for app discovery. I can see my app listed in the packet, however the packet doesn't look exactly the same as when the same app runs on my windows machine (excluding the IP).

Any ideas?
1 - 6 of 6 Posts
Hrmph. I swear I've had this working but I just tried it and I have the same problem as you. I know this works; I wrestled with the TrafficCam Viewer a while back a go and got it working (for Mac, at least) with the help of some other kind folks. See:


I use Ubuntu in VMWare to test my releases, running in bridged mode, so it's a bit different. However, I now have the same problem as you: from Ubuntu, I run the app; I Ctrl+Alt back out to Windows and run the simulator, and the app shows up in the list at (which is the correct bridged mode address for the Ubuntu instance) and runs fine. However, when I pop over to the TiVo, it's not in the list. I'm pretty sure I've successfully tested it in the past on both the simulator and on TiVo, but I wouldn't bet my life on it.

I'll poke around and see if I can find anything.
See less See more
IPv6 conflict possibly? I know the Galleon docs say to disable the ipv6 stuff for Ubuntu at least. Under Ubuntu 6.10 (Edgy Eft) and 7.04 (Feisty Fawn), it's enabled by default.

For the record, I've got Galleon and several other tivo server programs running under Ubuntu 7.04, and can see them on both my 649 and 540.

/edit: Reference to setting Galleon up on 6.06 (basically the same under 7.04):
Thanks gonzotek! That was it. I had ipv6 enabled and just had to disable it and reboot. Apparently that's a restriction with all HME apps and not just galleon. Or at least the ones that use the hme sample host.

Yay! Worked for me too. Good call.
I had this same problem and disabling IPV6 stack solved the problem too.

However, I am curious why when identical HME apps are ran on my Linux machines they don’t send out IGMP group membership packets as with the window machines. On the Windows machines an “IGMP Membership Report” packet is sent when the app is started, and “IGMP Leave Group packets” is sent when the app shuts down. All MDNS packets appear from both Windows and Linux machines.
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.