TiVo Community Forum banner
41 - 57 of 57 Posts

·
Registered
Joined
·
2 Posts
I found a solution for this, I was trying with Mac PC and didn't work for me. So I installed the remote adb app on the stream and run the commands from it directly.
I put the IP addresso and click connect, getting unauthorized error on adb and tivo screen has no authorization window popup. Should I connect the tivo via usb cable to the computer ?
 

·
Registered
Joined
·
9 Posts
I plugged in my TS4K into my LG soundbar's HDMI input since my TV was fine. It worked great and TV even showed that TS4K connected through the soundbar, and it controlled the soundbar volume via CEC. However, at some point, casting to it stopped working, so I had to resort to doing a factory reset.

Sadly, once I got everything working, while POWER and INPUT work via CEC, volume no longer works. Any idea how to troubleshoot that? I unpaired and paired the bluetooth remote, but no luck.
 

·
Registered
Joined
·
9 Posts
I plugged in my TS4K into my LG soundbar's HDMI input since my TV was fine. It worked great and TV even showed that TS4K connected through the soundbar, and it controlled the soundbar volume via CEC. However, at some point, casting to it stopped working, so I had to resort to doing a factory reset.

Sadly, once I got everything working, while POWER and INPUT work via CEC, volume no longer works. Any idea how to troubleshoot that? I unpaired and paired the bluetooth remote, but no luck.
Things are working today. Weird... maybe programming took longer for some reason.
 

·
Registered
Joined
·
1 Posts
Id like to use this remote to control my Nvidia Shield. Have an LG Oled and Denon Receiver. Is this possible?

Saw the first post about putting the box in adb mode, but since im using the shield.. how would this work?

Anyone do this before? I have used this tivo remote before, and I really like it, and think it will be leaps and bounds over my current 2015 shield remote.
 

·
Registered
Joined
·
370 Posts
I really wish they would push an update to fix this. I’ve read this a few times and seems so complicated to me I’m scared to try it lol. I don’t even really need to search for a code. I’ve unpaired and repaired the remote tons of times by holding the TiVo and back buttons. Even tried the universal reset with TiVo and power button. It always does power on and off. Each time the volume and input will work for 30 seconds fine (without entering a code just the remote auto finding it) then it looses it with any button press in a few seconds. I can’t get it to stick. Frustrating


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1 Posts
Any idea is Tivo undid this fix? I followed along had success then unpair and repair remote and it controls my vizio soundbar for a few seconds then goes back to the TV volume so frustrating. I do REALLY like this device and remote I just want to throw away all my others lol
 

·
Registered
Joined
·
13 Posts
First off, it's silly that I even had to do this. But I was determined enough to figure out what was causing this, and luckily I had success after some trial and error.

To override (disable) Tivo's automatic remote programming so you can use your own code do the following:
  1. Enable Developer Mode by going to Device Preferences --> About --> Build and click it a few times until it tells you that you are a "Developer".
  2. Then go to Device Preferences --> Developer Options--> USB Debugging and enable this option.
  3. Go to Network & Internet --> Available Networks and click your connected WiFi network to see what your Stream's IP address currently is.
  4. Download and install adblink
  5. In adblink enter your Stream's IP address in the "Ad Hoc IP" field.
  6. Click "Connect". You'll be prompted to accept the connection on the Stream itself - accept it and also remember the device if prompted.
  7. Once adblink reports that you are connected click "ADB Shell"
  8. Copy and paste the following commands in the terminal window:
    Code:
    pm uninstall -k --user 0 com.uei.uas.tivo
    reboot
  9. Once the Stream has booted, put the remote back in pairing mode by holding the Tivo + Back buttons for a few seconds.
  10. Once you have done this engage in a code search via this guide on Tivo's website or enter the codes from the attached images on this post.
  11. If you find a code that works (you can also enter codes manually) press the center select button to save it if you're doing a code search. If you enter a code manually it will automatically save.
CEC Bonus Fix
You can run this command to access the CEC menu to turn off CEC entirely and prevent your Tivo from waking stuff up:
Code:
am start -n com.droidlogic.tv.settings/com.droidlogic.tv.settings.HdmiCecActivity
View attachment 49090 View attachment 49089
What can I do to reverse this and re-enable the TS4K's automatic remote programming? Does Factory reset do that?
 

·
Registered
Joined
·
455 Posts
CEC Bonus Fix
You can run this command to access the CEC menu to turn off CEC entirely and prevent your Tivo from waking stuff up:
After you run this command, do you need to do anything else to turn CEC off? It sounds like this turns something on in Settings that you then have to go do.

I have a Sony X900F and it was initially powering on and off fine, but no volume or mute. After I ran the first command, rebooted, repaired the remote, and then entered the code for volume and mute, that worked. But things are now a little wonky. The TV now sometimes switches from external speakers (Sonos Beam) to internal, and after it does that I ironically can't control the sound. You'd think it would be just the opposite. I'm wondering if the TS4K is mucking with the CEC between the TV and Sonos. The code I put in to the remote was for Sony, not Sonos. Its also misbehaving a bit now on power on/off. Before it was solid. Now it is sometimes turning on the TV, but the TS4K is asleep and requiring another button press to wake it up. It wasn't doing any of that before. For such a great remote, they really mucked this handshaking with the TV up.
 

·
Registered
Joined
·
455 Posts
To answer my own question, that command brings up the CEC menu where you can turn it off. After several days of trying to get the volume commands to work with the commands in this thread, I have given up. It would take the code and work for a few hours and then forget the code apparently and have to be reprogrammed again. So I undid the procedure here, re-enabled CEC, and repaired the remote to work with the older LG TV that it worked great with out of the box. No amount of effort now will get the volume working again with the LG TV like it was before. This remote is the perfect form factor and keys in one sense and maddening in the other because of this crap with volume control. When I have nothing else to do I guess I'll try to reset this to out of the box and start over with installing and configuring Channels and DVR and the other apps. If that doesn't getting it working again with this LG TV then I may just send it back.
 

·
Registered
Joined
·
301 Posts
Any idea is Tivo undid this fix? I followed along had success then unpair and repair remote and it controls my vizio soundbar for a few seconds then goes back to the TV volume so frustrating. I do REALLY like this device and remote I just want to throw away all my others lol
I believe a pretty big bug fix update is coming Very Very soon. Check out the tivo reddedit site- you might even be able to get it early. I would bet it would fix your remote issues :)
 

·
Registered
Joined
·
185 Posts
I believe a pretty big bug fix update is coming Very Very soon. Check out the tivo reddedit site- you might even be able to get it early. I would bet it would fix your remote issues :)
And if it doesn't, too bad, since at least one other user reports that the update breaks developer options access and therefore use of adblink.
 

·
Legend
Joined
·
380 Posts
Following today's update there are screens for setting up TV and audio receiver separately, so I just did a factory reset on a TV with a Sonos Playbase and followed the prompts to select the Playbase as the audio device. Everything is working, I temporarily changed the setup to another random brand to make sure it wasn't the remote holding the previous programming (it wasn't, it only worked once Sonos was selected)



 

·
Registered
Joined
·
1 Posts
I currently have my bose system as the audio device programmed in my remote, but after a short while after I turn off the TV, the TV volume is in control and I have to go back into the settings to change the audio back to my Bose system. Is there a way to keep the volume control on the Bose system instead of it going back to the TV audio?
 

·
Registered
Joined
·
6 Posts
Hi guys! After installing FLAUNCHER and disabling Tivo features, as is well known, some buttons stop working on the remote, so I solved the problem using the Button Remap application. My problem is that now when I have an app open (especially when my daughter is watching YT Kids) and I want to go back to Flauncher, the YT-Kids app is still running (and playing) in the background, so I'm afraid the functionality " Exit" is lost and I can't fix it. Do you know of any way to make the "Exit" button have its original behavior?
 
41 - 57 of 57 Posts
Top