TiVo Community Forum banner

GSOD on new Drive

1156 Views 9 Replies 5 Participants Last post by  mrtickle
Hi Guys,

I had a failed drive so bought a new samsung 320GB and got hold of new lba48.bak image.

ran the restore command as listed in steveconrad's awesome guide.

Installed the cachecard drivers using the lba48 bootable cd.

Re-installed the drive into the tivo.

On boot up the cachecard was recognised and loaded correctly. However I got a GSOD after the final wait a few moments splash page.

Realised I had forgotten to run copykern so back to the PC to run that.

Ran successfully

but still getting the GSOD

Where am I going wrong?

1 - 10 of 10 Posts
So I have tried to simplify the problem.

Just in case the cachecard was causing an issue I ran the restore again and the copykern but did not install the cachecard drivers.

As before it shows the grey screen followed by the GSOD and then it reboots (not sure I mentioned the reboot in the first post but the behaviour is consistent)

Any help greatly appreciated,

All i would say is get hold of Hooch from TivoHeaven.com, it solved all my problems.
It probably would.....

but, I don't want to give up this early into my problems plus I am loathed to spend money if I can help it :eek:

I am going to try the normal tivo.bak rather than the lba48 see if that makes a difference.

Give a day or two and I am sure my resolve will weaken!


I have tried a tivo.bak with a default kernel and run the copykern

All this completed successfully.

When I power on the tivo it GSOD after the Power Up and then the Wait a few moments screens. It then resets and boots again ad infinium.

So I have tried:

1. lba48 kernel with and without cachecard drivers and cache card (have the bleeding hands to prove it!)

2. default kernel without cachecard drivers but with cachecard.

I am using

restore -x -s 300 -zpi /mnt/dos/tivo/tivo.BAK /dev/hdc

I am using .BAK's sourced from 'a friend' wink wink

I am downloading them using firefox and downthemall to an XP laptop.

I am then scp'ing them to a suse share drive and restoring from that using mfstools 2.0

Any ideas

See less See more
restore -x -s 300 -zpi /mnt/dos/tivo/tivo.BAK /dev/hdc

should be

restore -x -s 300 -r4 -zpi /mnt/dos/tivo/tivo.BAK /dev/hdc

A 320gb drive restored from a 40gb backup gives a MFS data partition > 274gb which blows the MFS node-map unless you use a bigger blocksize (-r3 or -r4).
Another example of BLINDLEMON'S selfless help, he could have profited from your misfurtune but continues to prove his commitment to the ethos of helping all.

If it hadent been done a year ago I would start a 'three cheers to Blindlemon' thread.
Thank you

So simple and yet so effective !!

I was following the guide which was for a drive smaller than the 274GB threshold so it didn't alter the blocksize.

Incidentally I am sure I saw a thread that said a MFStools bug had been fixed on the blocksize effect, and that the default of 2 (k?) would work. I cannot find the thread so I may have imagined it.

3 days hard slog worth it in the end. Would have been about an 30 mins with no blood if I had got it right first time :)

Thanks again
robmcmahon said:
Incidentally I am sure I saw a thread that said a MFStools bug had been fixed on the blocksize effect, and that the default of 2 (k?) would work. I cannot find the thread so I may have imagined it.
I suspect that's the MFSLive CD. However, although it is better in a number of ways than MFSTools 2.0 it doesn't install the LBA48 kernel if you don't have it so you still need to run copykern from the LBA48 CD afterwards.
Yes it is the MFSLive CD. But it is less than a month since the bug has been fixed.

Release Note:

MFSLive Release v1.3a 08-18-2007
- Fixed mfsadd.

MFSLive Release v1.3 08-13-2007
- Added support for TiVo HD
- Fixed restore -r 2 bug. Now, you can use -r 2 on a partitiion greater than
274GB. If you are mostly recording non-HD contents, it might be better to
keep r values at 2 instead of 4. r 2 is the standard in mfstools so if you
don't specify r value, it defaults to 2.
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.