TiVo Community Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
481 Posts
Discussion Starter · #1 ·
I just received this email from TiVo: "For a limited time, BOLT users can now upgrade to TiVo EDGE for Cable for $99.99 + subscription fees. Take advantage of this amazing upgrade offer to enjoy the next generation of TiVo product and experience apps, live TV and a DVR inside one seamless way to find, watch and enjoy it all. With a 30-day money back guarantee, including free shipping and returns, it's the perfect time to upgrade to EDGE."

With tax and first month subscription ($14.99) the total is $124.23. I have a few questions for the board. Is anyone else familiar with this offer? If so, do you see any indication that a current BOLT device must be sent back to TiVo? When I see the word "Upgrade" I take that to mean I have to send them a used Bolt in order to get the discounted price for the Edge but I am not seeing that verbiage on the offer or at checkout. I'm not sure why they use the term "upgrade" if you can keep an existing Bolt.

With regard to the Edge...I've read some not very favorable comments about its quality on these boards. My intent is to replace an old Premiere with this Edge, assuming the feedback here recommends doing so.

So, bottom line...is this a good deal?

Thanks in advance.
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #7 ·
I received this as well, however I have never owned a Bolt. I really can't bring myself to do it since it seems that cable cards are all but dead in the not so distant future.
Xfinity is our cable/internet provider and everything I have read on these boards says it will be "a few years" before Xfinity stops supporting CableCards.
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #15 ·
I must be in the minority. Since the Edge was released, I've owned 4 of them, 2 cable and 2 OTA, and I've had far fewer issues with them than I've had with 3 Bolts over the years.

My two cable Edges are still working in new homes, AFAIK. My two OTA Edges have been trouble free for over a year.

Hope I haven't jinxed myself now! :)
Well, this is good news. And yeah, I hope you haven't jinxed us! The Edge arrives this Thursday. Fingers crossed. Hopefully, the CableCard transfer/pairing goes well.
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #16 ·
One way or another you will need to get the CableCARD paired to the new unit, be that via web or phone with Xfinity.
I'm just not sure if I have to have Xfinity unpair it from the Premiere first or if I can just pair it to the new Edge and Xfinity will see that it's already paired with another device and walk me through the unpairing-repairing process. Or, if I have to get a new card for the Edge.
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #18 ·
Don't call them for the unpair, it will just confuse them, move it to the new unit and make sure they ask you for ALL THREE sets of data, if they only ask for 2 it will fail.
Thanks Diane. Just so I am clear on what the steps are. Move the card from the Premiere and then call them to have it paired with the Edge? And I should get it paired before powering up the Edge, is that correct?
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #20 ·
It's not hugely important, but generally it's power up the new unit sans card, go through setup and say " I'll install a CableCARD later" to make sure it works, let it run for a day or so, then if you're happy, power down both units, swap the card into the Edge, boot it up, call Xfinity's CableCARD line and have it paired, make sure they ask for all three sets of ID numbers, if they tell you they don't need them all, it won't work and they don't know what they're doing.
Got it. Thanks again.
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #28 ·
My new Edge arrived earlier today as promised. The setup went without issue. And thennnnnnnnnn it was time to activate the CableCard that I moved from the now retired Premiere to the Edge. I tried to do it online but they couldn't find my account and I was instructed to contact a CableCard expert and an 877 number was provided. My call was answered by a female with a heavy accent (Philippines?) who kept calling me Meesta Yo. When I told her I was calling to have a CableCard activated, it was obvious she needed some time to refer to a script so she asked me how my day was, blah blah blah. Long story short, she could not find the reference she was looking for to assist me and I finally asked to talk with a supervisor. Her exact reply: Oh, I so sawwy you want supavyza. Yes, unfortunately, all supavyza busy with a utter stuff now. If I unnastan you cowectly, you need help with a cablecard, that's a c-a-b-l-e c-o-r-d. Eez that cowect meesta yo?" I said "No. I need help activating a cable CARD. That's c-A-r-d. Cable CARD" She actually giggled and said she was sorry for the mistake. I looked at my phone timer and it read 12:26. So for more than 12 minutes this person who is supposed to be a CableCard expert thought I was calling for help with a cable CORD. The good news is, she did ask for all three pieces of required data and my cableCARD was activated within a minute or two_Oh, and I took your advice Diane and said nothing about the card initially being in a different device. So, thank you again for that.

Anyway, all good for now. I've been playing around with it for a few hours and, so far anyway, I'm not seeing any difference in performance between this Edge and either of our Bolts. Thanks again everyone for the great feedback and advice.
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #33 ·
A couple hiccups in just the three days since I've had the Edge. I can't get it to accept transfers from either of our Bolts (there is a thread in the Edge forum initiated by a user with the same problem and he gave up trying). The shows (10 episodes of Last Man Standing) are showing in the Edge To Do List but are not transferring to My Shows. I've tried x3 thus far without success. Also, I am very displeased with the extremely dim status lights on the front of the Edge. The red "recording" indicator isn't visible unless the device is in a completely pitch black room. Not a huge deal but...
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #36 ·
Code does not work, says not available. Note to the deal mentioned by OregonRider. You won't get a new Edge for $99 I'd think unless you had a situation like I had. I had a Bolt Vox that died in less than 3 years, and I was offered a new one for $99 (not refurbished, a new one).
That was the code I was emailed a week or so ago and it worked for me. Maybe it was specific to my email address. Regardless, I did receive a new Edge for $99. With taxes and the first month subscription fee it was around $120.
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #38 ·
I got the deal email, and the code is QW68DZFWN00R. They require you pay about $250 no matter what deal is made.

In this promotion, the box is $99 and the annual service plan for me would be $149 annual plan. So total $250. When 2 weeks ago I got just the Edge box upgrade to replace my dead Bolt box, my deal was to pay $250. They gave me a free transfer of my service from the dead Bolt box.

What I found out is that the $99 deal for the Edge requires the purchase of a service plan, they will not transfer the service plan you paid for and have with the Bolt you are upgrading from. So, I guess you have a good Bolt and a good Edge, each with their own plan.
You are 80% correct. You are correct bout the specifics of the offer and that I have a good Bolt (actually I have two good Bolts). The 20% you are incorrect about is having a good Edge. In the five days or so I have been trying out the Edge, I have run into a few hiccups. I am returning the edge and have bought a Roamio Plus with a Lifelong membership from an eBay seller.
 
1 - 16 of 16 Posts
Top