TiVo Community Forum banner
1901 - 1920 of 2630 Posts

·
TiVoholic by the bay
Joined
·
14,640 Posts
It usually can happen when PyTivo or other programs try accessing the Tivo too soon after a download finished. You may need to see if you can set a delay between downloads.

You should also avoid using multiple programs at the same time that access Tivo.
 

·
Registered
Joined
·
113 Posts
I'll see what I can do. Don't think anything else is accessing, kmttg isn't running and TiVo Desktop is just sitting. My observation is that after I reboot everything and get a list of recordings again, whatever was sitting in the queue when it was stuck, is missing from the TiVo. I assumed the recording was being deleted by the TiVo due to space requirements, or save only 5, or something.

=aw
 

·
TiVoholic by the bay
Joined
·
14,640 Posts
For example, KMTTG has a delay setting between downloads and if set to 0-10 seconds, the Tivo server "within" may not close out the last transfer quick enough and wait for the next, and then this server crashes when trying to start the next transfer.

I have mine set for 30 seconds to allow for such "reset server" time.
 

·
Go Terps!
Joined
·
702 Posts
I just installed PyTivo Desktop. I have a TivoHD and a (non-Hydra) Bolt.

PyTivo can see both Tivos
TivoHD can see Bolt and PyTivo share
Bolt can see TivoHD, but NOT PyTivo share

Does anybody have any idea why the Bolt can't see PyTivo? I'd like to be able to transfer files to the Bolt. (Yes, I restarted it). Thanks!
 

·
Super Moderator
Joined
·
59,935 Posts
Discussion Starter · #1,906 ·
Thanks. I just tried that, exited pyTivo then launched pyTivo then launched pyTivo Desktop. PTD said Finding TiVos then opened the Settings window to the TTG tab. The MAK is correct, the recordings folder is on my C:\ drive (I move manually to external after). I have Transfer format set to "per-recording" though earlier it was working with "always TS". No TiVos listed.

I changed back to "always TS" and hit Save. pyTivo is restarting... and Settings pops up.

Where does TiVo Desktop fit into this app? I think I have to have it running (for decryption?) and I do, though if I try to get a list of recordings on TiVo it identifies how many there are but the "can't open [some] file". It's been like that all along, both when PTD was working and when it wasn't.

[added: somehow I had changed zeroconf to Off, I changed it back to Auto and I got a list of recordings from the TiVo. So now my concern is how to avoid having PTD fail so badly when a recording gets removed from the TiVo. I guess I could download 1 at a time and refresh the recordings list each time (which doesn't guarantee a recording won't be deleted but at least reduces the window). But that means no batch transfers overnight.]

=aw
That settings dialog pops up when the TiVo rejects the connection pyTivo is attempting to make. It pops up the settings because it assumes the MAK is not entered or incorrect. But if you're sure the MAK is right, then the problem is on the TiVo side and the only way to fix it is to reboot it.
 

·
Super Moderator
Joined
·
59,935 Posts
Discussion Starter · #1,907 ·
I just installed PyTivo Desktop. I have a TivoHD and a (non-Hydra) Bolt.

PyTivo can see both Tivos
TivoHD can see Bolt and PyTivo share
Bolt can see TivoHD, but NOT PyTivo share

Does anybody have any idea why the Bolt can't see PyTivo? I'd like to be able to transfer files to the Bolt. (Yes, I restarted it). Thanks!
Is Bolt running Hydra? If so then it'll never see the pyTivo share because TiVo omitted this functionality from the new Hydra UI.
 

·
Registered
Joined
·
325 Posts
I just installed PyTivo Desktop. I have a TivoHD and a (non-Hydra) Bolt.

PyTivo can see both Tivos
TivoHD can see Bolt and PyTivo share
Bolt can see TivoHD, but NOT PyTivo share

Does anybody have any idea why the Bolt can't see PyTivo? I'd like to be able to transfer files to the Bolt. (Yes, I restarted it). Thanks!
Well, you answered all the questions I would have asked, and I agree it seems like the Bolt should see the PyTivo share. By any chance is are some devices wired and others wireless? There can be some funkyness because discovery uses zeroconf which uses ethernet broadcast and some routers don't (or require config changes anyway) to actually forward broadcasts to all connected devices.

That's a wild guess, but all I could come up with.
 

·
Go Terps!
Joined
·
702 Posts
Well, you answered all the questions I would have asked, and I agree it seems like the Bolt should see the PyTivo share. By any chance is are some devices wired and others wireless? There can be some funkyness because discovery uses zeroconf which uses ethernet broadcast and some routers don't (or require config changes anyway) to actually forward broadcasts to all connected devices.

That's a wild guess, but all I could come up with.
Nope, all wired.
 

·
Unknown Member
Joined
·
5,069 Posts
Nope, all wired.
I toggle my Bolts between static and hdcp when this happens every once in awhile and they pop right back. I'd like to find out why but I'm always in a hurry when it happens so I just do the voodoo.

EDIT: Actions that work on the much rarer incidents with Tivo s3s, HDs and Roamios: power cycling, quitting and re-running pyTivo, etc, usually do not work for me with the Bolts.
 

·
Premium Member
Joined
·
443 Posts
Nope, all wired.
Over the years I've had similar issues with my TiVos occasionally not seeing pyTivo.

Two tricks that I've used with success:
  1. Restart pyTivo. I think this rebroadcasts pyTivo's existence to your TiVos?
  2. Physically unplug the Ethernet cable from the back of your TiVo for 5 seconds and plug it back in. Not sure why this works ... maybe it "reboots" the Tivo's network interface?
 

·
Well-Known Member
Joined
·
2,342 Posts
Over the years I've had similar issues with my TiVos occasionally not seeing pyTivo.

Two tricks that I've used with success:
  1. Restart pyTivo. I think this rebroadcasts pyTivo's existence to your TiVos?
  2. Physically unplug the Ethernet cable from the back of your TiVo for 5 seconds and plug it back in. Not sure why this works ... maybe it "reboots" the Tivo's network interface?
Restarting pyTivo at PC always works for me.
 

·
Old !*#$% Tinkerer!
Joined
·
1,554 Posts
On my Tivo, to resolve network issues, I press thumbs down, thumbs up, play, play from the Tivo Home screen. It seems to reset the UI and networking without rebooting Tivo.
I learned about the "HDGUI Reset" [ :thumbsdown::thumbsup: PLAY PLAY ] when I was attempting to get two instances of StreamBaby running (desktop and laptop). TiVo warm boots (restart), cold boots (power cycle) and StreamBaby stop / start had no effect but the HDGUI Reset was consistently successful. I usually combine it with a warm boot just to cover more bases.
 
1901 - 1920 of 2630 Posts
Top