TiVo Community Forum banner
121 - 140 of 2640 Posts

·
Registered
Joined
·
1,875 Posts
It doesn't seem to want to let me uncheck (transfer using MPEG-TS format) and check (Decrypt with tivodecode), when I select save, it is automatically rechecking (transfer using MPEG-TS format) and causing tivodecode to crash
 

·
Super Moderator
Joined
·
55,350 Posts
Discussion Starter · #123 ·
It doesn't seem to want to let me uncheck (transfer using MPEG-TS format) and check (Decrypt with tivodecode), when I select save, it is automatically rechecking (transfer using MPEG-TS format) and causing tivodecode to crash
I see the error in the UI, but it's just a display error. If you uncheck TS and save then it does save to the conf file so it shouldn't cause a crash. If it's crashing there may be something else wrong. I'm going to fix the display error right now though.
 

·
Super Moderator
Joined
·
55,350 Posts
Discussion Starter · #124 ·
OK I've uploads a minor bug fix. It fixes the UI issue with the TS option, it also fixes an issue where the conf file would fail to save if the default folder didn't exist. It will now create the folder if it doesn't exist before saving the conf file.

Edit: I also tested the decrypt option on my end and it does seem to work. Although since TS doesn't work with decrypt unless you have a special version of tivodecode I should probably either include that version with the package, or disable the decrypt option if TS is checked. I'll have to think about which one of those I want to do.
 

·
Super Moderator
Joined
·
55,350 Posts
Discussion Starter · #128 ·
Having trouble setting up. Pytivo searches for brings up the settings menu, I enter my MAK and recordings folder. When I save I get Error saving settings. ?it looks like it does not find my Tivo.
Did you download the 1.5.1 version I just posted? That had a fix specifically for this issue.
 

·
Super Moderator
Joined
·
55,350 Posts
Discussion Starter · #131 ·
I had a similar issue. After restarting my laptop it found my Tivo. But now after selecting a video it will not start to transfer.
Are you clear on how the UI works? You have to click the little download icon next to the show to start the download. After that it's added to the queue, which appears as an icon in the upper right. If you want to monitor the status of the download, or cancel something you've added to the queue, you click that icon and a dialog appears with the queue list and current progress.

One thing of note is that pyTivo has a separate queue for each TiVo, so if you start transfers from multiple TiVos they will be transferred simultaneously. Depending on your network setup this could be a good or a bad thing. I didn't want to change the core pyTivo functionality so I left that intact.
 

·
Super Moderator
Joined
·
55,350 Posts
Discussion Starter · #133 ·
Yes downloaded the update. No longer getting error on saving the settings, but still not finding the Tivo

Sent from my iPad using Tapatalk
Try stopping pyTivo from the tray icon and then restarting. It seems that sometimes the zeroncof feature in pyTivo doesn't always work, and doing a soft restart doesn't always fix it. Doing a hard stop/start usually does though.
 

·
Super Moderator
Joined
·
55,350 Posts
Discussion Starter · #138 ·
Stopped and restarted as you instructed. After restart I had to add the queue was empty so I had to restart the download. Still doesn't work.
Hmmm... not sure what would cause that. Do me a favor... open a browser and go to http://localhost:9032. This will bring up pyTivo's built in web interface. Try using it to download the same show. Does it work?
 
121 - 140 of 2640 Posts
Top