TiVo Community Forum banner
921 - 940 of 2640 Posts

· Super Moderator
Joined
·
55,680 Posts
Discussion Starter · #924 · (Edited)
Anyone want to try a new beta build of pyTivo?

Beta download for Windows

3 new features....

1) Option to prompt for VRD post process settings for each download

2) Free space indicator in Settings dialog under output folder and new check that will alert you if you attempt to download and there isn't enough space.

3) Beta option on Misc tab that will check for beta versions before they are put out as general releases

From now on I will be updating the beta version first, maybe accumulating several new builds before combining them into a single general purpose release. I hope this will help me avoid the big bugs I've had in the last two releases. So if you want to always have the latest and greatest go to the Misc tab in the options dialog and check the Get notified of beta builds option. If you don't then it defaults to off and you can ignore it.
 

· Registered
Joined
·
3 Posts
Could use some help for installation. Installed on Win 7 64 bit close to new machine. Version 1.6.10. Selected all three options available on installation. No errors or problems on the install. On first run of desktop got a window “Error connecting to pyTivo! Verify pyTivo is running and try again”

Notification tray says pyTiVo is running. Two items related to pyTiVo appear in Task Manager-Services. Restarted system—no change in results. The PC does NOT appear on TiVo Roamio. Stopped pyTiVo Service from the notification tray and restarted—same results on startup of pyTiVo Desktop.

TiVo Desktop Plus was previously on this machine (not working consistently, thus trying pyTiVo) but was uninstalled (also used the TiVo Desktop Cleaner) prior to install of pyTiVoDesktop. Only other thing I can find of note: at the time of startup of the system, Windows Event viewer reports a Warning: Event #7039 Service Control Manager. A service process other than the one launched by the Service Control Manager connected when starting the pyTiVo service. The Service Control Manager launched process 4380 and process 6084 connected instead. Note that if this service is configured to start under a debugger, this behavior is expected”. The process numbers change on each startup of the system but the warning is persistent on each startup of the system.

What to try next?? (Computer novice here so be somewhat specific with your response please).
 

· Old !*#$% Tinkerer!
Joined
·
1,408 Posts
Could use some help for installation. Installed on Win 7 64 bit close to new machine. Version 1.6.10. Selected all three options available on installation. No errors or problems on the install. On first run of desktop got a window "Error connecting to pyTivo! Verify pyTivo is running and try again"

Notification tray says pyTiVo is running. Two items related to pyTiVo appear in Task Manager-Services...
---SNIP---
...Only other thing I can find of note: at the time of startup of the system, Windows Event viewer reports a Warning: Event #7039 Service Control Manager. A service process other than the one launched by the Service Control Manager connected when starting the pyTiVo service. The Service Control Manager launched process 4380 and process 6084 connected instead. Note that if this service is configured to start under a debugger, this behavior is expected"...
A few ideas until @Dan203 can reply (referring to RED QUOTEs above):
  • I'm running on Vista so PyTiVo Desktop doesn't work the same for me as others and now I just run things sort of manually via IDLE. I don't remember what the "three options" were, but I'd begin troubleshooting by uninstalling v1.6.10 and then re-installing without the service and see if that works.
    Refresh my memory - what are the "three options"?
    .
  • If that doesn't work, I'd uninstall v1.6.10 and install v1.6.4 (I'm using v1.6.2 so I know how that works, but that's not CLICKable). Installing and uninstalling PyTiVo Desktop is a piece of cake so selecting fewer options and / or an earlier version will be a quick way to see what works for you. When troubleshooting, I like to call it "Divide and Conquer" - pick a place halfway between the beginning and where you are now and start there. If that doesn't work, go back 25% more. If it does work, go forward 25% more.
Good Luck! :)
 

· Super Moderator
Joined
·
55,680 Posts
Discussion Starter · #934 ·
Could use some help for installation. Installed on Win 7 64 bit close to new machine. Version 1.6.10. Selected all three options available on installation. No errors or problems on the install. On first run of desktop got a window "Error connecting to pyTivo! Verify pyTivo is running and try again"

Notification tray says pyTiVo is running. Two items related to pyTiVo appear in Task Manager-Services. Restarted system-no change in results. The PC does NOT appear on TiVo Roamio. Stopped pyTiVo Service from the notification tray and restarted-same results on startup of pyTiVo Desktop.

TiVo Desktop Plus was previously on this machine (not working consistently, thus trying pyTiVo) but was uninstalled (also used the TiVo Desktop Cleaner) prior to install of pyTiVoDesktop. Only other thing I can find of note: at the time of startup of the system, Windows Event viewer reports a Warning: Event #7039 Service Control Manager. A service process other than the one launched by the Service Control Manager connected when starting the pyTiVo service. The Service Control Manager launched process 4380 and process 6084 connected instead. Note that if this service is configured to start under a debugger, this behavior is expected". The process numbers change on each startup of the system but the warning is persistent on each startup of the system.

What to try next?? (Computer novice here so be somewhat specific with your response please).
Sounds like your system has some issue with the service. Could be a permissions thing. Just as a test try reinstalling, but uncheck the service option.
 

· Old !*#$% Tinkerer!
Joined
·
1,408 Posts
A few ideas until @Dan203 can reply (referring to RED QUOTEs above):
  • I'm running on Vista so PyTiVo Desktop doesn't work the same for me as others and now I just run things sort of manually via IDLE. I don't remember what the "three options" were, but I'd begin troubleshooting by uninstalling v1.6.10 and then re-installing without the service and see if that works.
    Refresh my memory - what are the "three options"?
Sounds like your system has some issue with the service. Could be a permissions thing. Just as a test try reinstalling, but uncheck the service option.
Didn't I say the same thing a few hours earlier? ;)
 

· Old !*#$% Tinkerer!
Joined
·
1,408 Posts
@Dan203 ,

I have a request, when you get a chance:

Do you know if PyTiVo Desktop will preserve the contents of "contentId" in a roundtrip TiVo-to-PC-to-TiVo transfer?

I recently discovered that AutoSkip / 'Skip' is NOT available when one transfers a file TiVo-to-PC via PS / 'Slow' Format transfer (I'm assuming TS / 'Fast' Format transfers too) via kmttg and then returns it PC-to-TiVo, either via pyTiVo or PyTiVo Desktop. @moyekj replied (in his main kmttg thread) that .tivo files DO NOT save "contentId" and told me to decrypt it to .mpg and also save the .mpg.txt file. That worked.

If not currently, might it be possible for PyTiVo Desktop to preserve "contentId" in a .tivo file so that the transfer back can properly access the TiVo servers for the commercial skip points? Up until this point, I had always believed that a .tivo file was a mirror image of what was originally on the TiVo unit. Imagine my surprise - ~3TB of off loaded shows WITHOUT 'Skip'! :mad:

Thanks! :)
 

· Nick of Time
Joined
·
164 Posts
Could use some help for installation. Installed on Win 7 64 bit close to new machine. Version 1.6.10. Selected all three options available on installation. No errors or problems on the install. On first run of desktop got a window "Error connecting to pyTivo! Verify pyTivo is running and try again"

Notification tray says pyTiVo is running. Two items related to pyTiVo appear in Task Manager-Services. Restarted system-no change in results. The PC does NOT appear on TiVo Roamio. Stopped pyTiVo Service from the notification tray and restarted-same results on startup of pyTiVo Desktop.
I have this problem too on the PCs. Both on a Win7x64 and a Win10x64 machine. The error will just keep popping up until I quit the app.
 

· Well-Known Member
Joined
·
2,371 Posts
Dan-

Your pytivo improvements have greatly enhanced my TiVo viewing habits.

Wish TV episodes would consistently load to the same folder - it's a TiVo server issue. SeriesId/ProgramId issues. Would like to put all movies in one folder too...
 

· Registered
Joined
·
325 Posts
@Dan203 ,

I have a request, when you get a chance:

Do you know if PyTiVo Desktop will preserve the contents of "contentId" in a roundtrip TiVo-to-PC-to-TiVo transfer?

I recently discovered that AutoSkip / 'Skip' is NOT available when one transfers a file TiVo-to-PC via PS / 'Slow' Format transfer (I'm assuming TS / 'Fast' Format transfers too) via kmttg and then returns it PC-to-TiVo, either via pyTiVo or PyTiVo Desktop. @moyekj replied (in his main kmttg thread) that .tivo files DO NOT save "contentId" and told me to decrypt it to .mpg and also save the .mpg.txt file. That worked.

If not currently, might it be possible for PyTiVo Desktop to preserve "contentId" in a .tivo file so that the transfer back can properly access the TiVo servers for the commercial skip points? Up until this point, I had always believed that a .tivo file was a mirror image of what was originally on the TiVo unit. Imagine my surprise - ~3TB of off loaded shows WITHOUT 'Skip'! :mad:

Thanks! :)
What/where is this contentId? I've been digging into pyTivo (I've converted it to Python 3, and integrated many of Dan's improvements, and I'm working on a few of my own). I haven't seen anything with that name being served up by the TiVo. Nor do I see it saved in the .txt metadata file that kmttg creates when it downloads a recording.
 
921 - 940 of 2640 Posts
Top