TiVo Community Forum banner
41 - 60 of 2627 Posts

·
Super Moderator
Joined
·
59,666 Posts
Discussion Starter · #41 ·
sorry Dan, I appreciate your help but I was looking for a simple tivo desktop replacement. I'll make do with 2.8.3
I understand. The whole point was to make it easy. I'm sorry it wasn't. If you can please run that console window test I mentioned above and then screen shot the output and post it here for me. I'd like to see why it's failing to see if maybe it's something I can fix.
 

·
Super Moderator
Joined
·
59,666 Posts
Discussion Starter · #42 ·
Hi Dan,

Does an older version of pytivo and python need to be uninstalled first. Old version works fine for my purposes but I'm interested in this new and improved version. Can you summarize the improvements?

Thanks,
S
There are no improvements other then the UI and installer. The purpose was to make it easier to install and use. If you've got the old version running there is really no reason to upgrade.
 

·
Super Moderator
Joined
·
59,666 Posts
Discussion Starter · #43 ·
I do have one question, Dan. Is it normal to see 2 instances running?

View attachment 27906
Yeah that seems to be something to do with the way the pyinstaller thing works. One of them is the part that decompresses the package and the other is the one that runs. There is an option to not package everything into a single exe, and instead create a folder with a bunch of files, and it doesn't do this. But I liked the cleanliness of having a single exe better.
 

·
Registered
Joined
·
1,521 Posts
One thing you can do...

1) Open explorer and go to PyTivo install directory
2) Shift+right click the pyTivo.exe and pick copy path
3) Open a command prompt
4) Right click in cmd window to paste the path of pyTivo.exe
5) Press enter

That will show the command output of the main pyTivo program and may give you a clue why it's not running
ok here you go

imagehost
 

·
Super Moderator
Joined
·
59,666 Posts
Discussion Starter · #45 ·
Hmm... looks like it's a problem with the config file. You've never had pyTiVo before right? Can you do a search on your pc for "pytivo.conf" and let me know if it actualy finds one anywhere? (I appreciate your help)
 

·
Registered
Joined
·
1,521 Posts
Hmm... looks like it's a problem with the config file. You've never had pyTiVo before right? Can you do a search on your pc for "pytivo.conf" and let me know if it actualy finds one anywhere? (I appreciate your help)
Windows 10 machine, this thread is the first time I ever installed pyTivo but I have uninstalled and reinstalled your .exe file several times now

searching my C drive for pytivo.conf brings up 2 results

c:\program files (x86)\pytivo

and c:users\myname\app data\local\virtual store\program files (x86)\pytivo
 

·
Super Moderator
Joined
·
59,666 Posts
Discussion Starter · #49 ·
Are you adding shares via the interface? If so what are the names/paths to the shares. Maybe there is some parsing error in my UI when trying to parse the names or path names. (thanks again for the help)
 

·
Registered
Joined
·
1,521 Posts
Are you adding shares via the interface? If so what are the names/paths to the shares. Maybe there is some parsing error in my UI when trying to parse the names or path names. (thanks again for the help)
I have no experience with pytivo. pytivo starts after installation. In the systray icon I clicked "edit shares", then , video, then add, then browsed to folders containing video clips on my PC, then Ok, ok
clicking "edit shares" kills pytivo. pytivo stops every time I go in to add shares and never restarts
an example of one of my shares c:\music\itunes\itunes music\podcasts\All CNET Video podcasts
again, I drilling down using browse, not typing in a command line

should I be using another interface? if so, where is it?

edit:
ok, I just discovered "show web UI". I guess that is how I should be adding shares???
 

·
Registered
Joined
·
1,521 Posts
Are you entering a share name? Or just picking a folder?
I used the web UI to add a section called "Myname Video Files"
In this section, I manually entered the path to my podcasts c:\music\itunes\itunes music\podcasts\All CNET Video podcasts ( a pain by the way, a browse would be much easier)"

edit, never mind, i just discovered "copy path" that works fine

that is a folder that will contain .mp4 podcasts as CNET populates my itunes podcasts

should this work? at least the server stays on, and I see "myname video files" in my Tivo so I am making nice progress :)
is there a way to push these podcasts to my tivo automatically like tivo desktop used to do?
 

·
Registered
Joined
·
1,521 Posts
a few issues: after I add a section using the web UI and copied the path to the folder that contains the .mp4 files I notice when I go back into the web ui the path is blank, even though the new section is still listed.
I added two video sections, same issue on both.
and even though my tivo "sees" my two pytivo sections, my first added section called "CNET podcasts"when clicked on the tivo says
"the CNET podcasts PCs now playing list could not be displayed because it is unavailable. press left to return to the my shows list"

same thing with the other section


I will try PC and Tivo reboots

reboots did not solve
 

·
Super Moderator
Joined
·
59,666 Posts
Discussion Starter · #58 ·
Could be a firewall issue. Are you using the Windows firewall? When you launched the program the first time it should have prompted you to allow pyTivo to connect to the network. Did you accept that?
 

·
Registered
Joined
·
1,521 Posts
Could be a firewall issue. Are you using the Windows firewall? When you launched the program the first time it should have prompted you to allow pyTivo to connect to the network. Did you accept that?
I got a firewall message when I rebooted earlier and clicked "allow". is there a particular item that needs to be allowed access? my firewall is controlled through Norton security and pytivo is still set to allow in it

should those "paths" in the new sections be blank?

I added my MAK to global settings but that did not fix. does anything else need added to global settings?
 

·
Super Moderator
Joined
·
59,666 Posts
Discussion Starter · #60 ·
MAK only matters for the download form TiVo to PC part, which you can only do via the web UI for now.

Can you post the full text of your config file so I can see what it looks like. Maybe that will give me a clue as to what's going on.
 
41 - 60 of 2627 Posts
Top