TiVo Community Forum banner

Channel Is Not Authorized - Who's At Fault?

2470 Views 10 Replies 5 Participants Last post by  bgiles
I'm having the "channel is not authorized" problem, but mine seems more severe than any other reports I've seen. I have two TiVo Premieres, with cablecards from Comcast, and it's happening on both of them, at least a dozen times a day. But it DOESN'T happen simultaneously. Frequently, one TiVo is working just fine, when the other isn't. Sometimes it's only a few channels that become not authorized; sometimes it's all non-local channels. It affects both SD and HD channels.

The second interesting factor is that the problem often (but not always) happens exactly on the hour, even though there hasn't been an automatic channel change (say, to record something on my schedule). I'll be watching a two-hour movie that started at 9:00, for instance, and suddenly, just as the clock changes from 9:59 to 10:00, without warning, the screen freezes and the "not authorized" message pops up. Other times, however, the problem DOES occur just as I'm changing a channel.

The third interesting factor is that when the problem occurs, I can fix it EVERY TIME, without fail, by simply going to the cablecard menu in the Settings section and choosing the Test Channels function. The channel may or may not appear correctly during the test function, but as soon as I exit the test and press the LiveTV button, it's back -- until the next time it happens, which may be only a few minutes later.

The fourth interesting factor is that this seems to have started right about the same time as I upgraded my Comcast service to add some additional channels several weeks ago.

I've called Comcast when the problem happens, and they've tried resetting the cards, but this does not help. They've offered to let me have new cablecards, which I'll probably try, but I'd really like to know if this is a problem with the cablecards, with the TiVos, or with errant signals being sent out by Comcast that somehow disable the cards temporarily. I tend to think it's not the latter, since I'm able to fix the problem without contacting Comcast via the Test Channel menu as described above.

This is really driving me nuts, since any of my programs aren't being recorded that happen to be not authorized at the time of the recording. Any ideas/suggestions? Until I really know where the problem lies, I'm afraid it's going to stay a finger-pointing game between Comcast and TiVo.
See less See more
1 - 11 of 11 Posts
Your cablecards need to be paired to your TiVos. Sure, the Cablecards will mostly work after being activated, but you will have issues like you are reporting.

Continue to call Comcast until you get a CSR that knows how to pair a TiVo, or can get you to someone who can. They will need numbers off of the CableCard diagnostic screen on the TiVo to do this correctly.
Honestly, you can spend hours upon hours calling Comcast until you get the right person. What I did was call them, the CSR will try to fix the problem and when they cannot, ask for a truck roll. They will only charge for a truck roll if something is wrong with your Tivos. When the tech comes, have him call his special number to pair the cards in both Tivos. Most likely that will solve the problem. If not have them swap the cards. Honestly I'd go with the free truck roll than waste a lot of time with the morons who answer the phones.
My guess is the channels you are having trouble with are where CCI byte is not 0x0. Encrypted channels with CCI != 0x0 require properly paired cablecards in order to tune. On the other hand encrypted or non-encrypted channels with CCI = 0x0 will tune fine. If you have a Motorola cablecard you should check the CableCard "Conditional Access" screen on your TiVo and look to see if it's properly paired. A properly paired card will have a "V" after Val: field as in the following example:
Con: Yes EBCP: Yes Val: V 0x0E

I recently had this problem and that screen showed a question mark "?" instead of "V" indicating it was not properly paired even though on Cox end they claimed it was. I had Cox erase the pairing information and enter it again and that fixed the problem.
I'm having all the issues mentioned previously, plus one more (actually two more). First, in addition to the previously mentioned "unauthorized access" freeze ups, what also happens to mine (because this ONLY happens when one or more of the four tuners is trying to record) is that those programs that are recording will only be partially recorded, usually for a minute or two, but also a two hour recording will stop recording fifteen minutes early, or thirty minutes early, or whatever. The other problem I'm having is almost every program I record and then download to my computer is corrupted, or, at least, VideoReDo, which I have used without problem for years and years now, will no longer quick stream fix or allow me to edit them. It just locks up. I don't know. It just seems like the premiere and Cox cable are on two VERY DIFFERENT wave lengths. I have changed cards. I have checked all four tuners in conditional access and all four have a VAL code of V 0X0D. I am stumped and very frustrated. Maybe it is encrypted channels causing the problem (and by encrypted I mean those channels I can't transfer programs from like HBO or SyFY but it will cause partial program recordings on any channel, especially (and most irritatingly) the channels I record sports on like ESPN and FOX, neither of which have ever caused me encryption problems. This is beginning to look like a colossal waste of money. On the other hand, I am having digital breakup on certain channels on some of my older Tivo models too. Maybe it is just something as simple as an insufficient signal. ???
See less See more
For the VideoRedo problem it's most likely because the video contains different resolutions in it. To solve that in Quick Stream Fix dialog you should turn on "Enable Filters" and set Video Dimension Filter to the appropriate primary resolution of the video and then Start QS Fix.

Also, if you are downloading with TiVo Desktop with "Fastest Method" (which uses Transport Stream instead of Program Stream) you will need a very recent beta version of VRD which supports that. Otherwise you should disable that setting in TiVo Desktop.
Thanks. It's not a problem with different resolutions. I've been using that feature in QSF for years. I think the problem is related to the "fastest method" issue because I am definitely transferring TS and not PS and was not aware of a new beta. I will look for that. Thanks.
I have VRD v 629D, which is the most recent beta version I can find. Is there some setting I have to change in VRD to make it function in combination with Tivo Desktop "fastest method?"
I have VRD v 629D, which is the most recent beta version I can find. Is there some setting I have to change in VRD to make it function in combination with Tivo Desktop "fastest method?"
Make sure you are using TD 2.8.2. VRD simply uses the TiVoDirectShowFilter.dll that TD installs for decrypting .TiVo files, so make sure you have most up to date TD.
Thanks, moyekj. Can you please guide me on how I can check to see which TD VRD is using? Where do I look/what do I look for? Thank you.
Thanks everyone. After numerous additional calls, two truck rolls, and at least SIX different cable cards (might have been even more -- I'm not entirely sure), the problem appears to be fixed. I'm still not sure exactly what the problem was, and I never did get a straight answer out of Comcast, but either it was numerous bad cablecards, or numerous bad pairings, or perhaps both. It was definitely NOT the TiVo's fault.

Along the way, I discovered that a co-worker was a former cable installer for Comcast in this area. According to him, Comcast never even bothered to test hardware when customers or installers reported it to be defective. They (Comcast) simply put it back on the shelf, and it would get re-issued to the next unsuspecting customer. That sounds absurd, but based on my experience, I have to say I believe him.

It was only when I insisted on brand-new factory-sealed-in-the-box cable cards that the problem was finally fixed. Up until that point, Comcast was claiming everything was correctly paired and working properly on their end. It's been about a month now, and I've had no further problems, so I'm declaring this one resolved.
See less See more
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.