TiVo Community Forum banner
1 - 20 of 289 Posts

·
Weeeeeeeeeeee
Joined
·
570 Posts
Discussion Starter · #1 ·
Hi Gang,

We've put up a Public Trial Pre-Release of AudioFaucet for all of you to Enjoy while we work on the finishing touches.

AudioFaucet Homepage

If you run into any issues or have questions about AudioFaucet that you don't want to ask here, please take a moment to email us at [email protected] instead of Private Messaging me here. It makes it much easier to respond to your issue.

Please feel free to kick the tires. However this version will expire once the retail version of the product is ready for release. We'll have more details on that in the coming weeks.

About AudioFaucet:
"AudioFaucet" is an innovative TiVo HME application that allows you to effortlessly control the flow of music within your household.

If you have iTunes installed we allow you to completely control playback of iTunes via Apple Airport Express, Computer Speakers or stream iTunes MP3 Audio to your TiVo directly.

It works with iTunes on both the Windows and Mac platforms, provides a slick interface which allows you to navigate your music collection while displaying the album art on your TV.

It overcomes a fundamental limitation of the Airport Express (no display) and allows users to be able to control the playing of music from the iTunes Music Store (which would otherwise be unstreamable due to DRM) with the help of AirTunes Express Units.

Don't have iTunes? No Problem. We also have the ability to browse and stream MP3's from any folder on your system.

Features Include:
User customizable display settings (Backgrounds/Themes)
Full iTunes Library Browsing by Playlist, Artist, Album, Genre, Podcasts
File System MP3 Browser Support. (if you don't have iTunes)
Apple AirTunes Detection and iTunes audio stream control
Stream MP3 Audio Direct to TiVo
Cover Art display (if none exist it will fetch from Amazon)
Full Song information display
Duration/current play position display/control
Next/Previous song control
Star rating display/control (not available for non-iTunes users)
Playlist shuffle toggle
Music Library Shuffle display/control
Host computer name display (run it on as many systems in your home as you want)
iTunes operation via host computer triggers display/control updates
Alerts users that newer versions are available
 

·
Registered
Joined
·
7 Posts
The feature set is impressive. I am so glad you finally added streaming to the application. I will be testing this out as soon as I get home.

Now, if only we could stream -- stream, not copy -- video to a TiVo, it would make a very cheap and effective media center.
 

·
Electrocuted by TiVo
Joined
·
5,201 Posts
budsharpe said:
The feature set is impressive. I am so glad you finally added streaming to the application. I will be testing this out as soon as I get home.

Now, if only we could stream -- stream, not copy -- video to a TiVo, it would make a very cheap and effective media center.
I think I'll stick to Galleon. Has most of the same features and I don't use itunes anyway.
 

·
Registered
Joined
·
7 Posts
I just appreciate that there is a Mac-native version of the application. I have played with Galleon and never gotten it to work consistently on my Mac.

To the developer: do you have any plans to make a companion app that works with iPhoto or a directory of photos? I would love to skip the standard TiVo Desktop since I find it lacking.
 

·
Tivoholic
Joined
·
227 Posts
Galleon's ok, but I prefer this interface.

That said, I have had several bugs since installing this. Do you want us to post them here? Would that be useful to you?


P.S. One thing I'd REALLY like to see is the ability to make this program minimize to the Windows task tray. Otherwise, when it's open, it's kind of in the way of my workspace.
 

·
Registered
Joined
·
12 Posts
Well, I am assuming I am in the minority here, but I can't even get this to work.

On My PC:
windows xp pro sp 2
tried with no firewall or virus scan

Problems - can't get it to recognize that I have iTunes at all (4.9 version) and when I select my itunes folder as the mp3 folder it can start, but the tivo just won't connect to it at all. gives me an h-t-t-p connection error: 0x50005 All of my other HME apps work just fine on this PC.

(sorry about the h-t-t-p but I can't type that word since my post count is under 5)

On my Mac:
Tiger 10.4.2
also no firewall when tried

Problems - it recognizes iTunes and does in fact start on the tivo, however, my artists, genre and everything else except for pod casts appear empty on the tivo. When I try to play a podcast, it plays the first second then crashes the tivo with a "an error occured while running the application. The application closed during a read (0x50006)"

Running 7.2.0-oth-01-2-264 on a Toshiba SDH-400 with no hacks, hard drive replacements or anything.
 

·
Weeeeeeeeeeee
Joined
·
570 Posts
Discussion Starter · #7 ·
Stormspace said:
I think I'll stick to Galleon. Has most of the same features and I don't use itunes anyway.
FWIW it doesn't require iTunes to work... but to each his own. :) Glad you chimed in anyways.

KC
 

·
Weeeeeeeeeeee
Joined
·
570 Posts
Discussion Starter · #8 ·
budsharpe said:
I just appreciate that there is a Mac-native version of the application. I have played with Galleon and never gotten it to work consistently on my Mac.

To the developer: do you have any plans to make a companion app that works with iPhoto or a directory of photos? I would love to skip the standard TiVo Desktop since I find it lacking.
It would be a natural progression for us to look at iPhoto as well, and we have in the past looked into doing something with it. However, right now there is enough for us to still focus on with AudioFaucet :) But perhaps someday.

We're glad you like it.

Cheers,
KC
 

·
Weeeeeeeeeeee
Joined
·
570 Posts
Discussion Starter · #10 ·
JuryDuty said:
Galleon's ok, but I prefer this interface.

That said, I have had several bugs since installing this. Do you want us to post them here? Would that be useful to you?

P.S. One thing I'd REALLY like to see is the ability to make this program minimize to the Windows task tray. Otherwise, when it's open, it's kind of in the way of my workspace.
Would love to hear about any problems that you are having with it. As it says in the release notes and on our webpage please feel free to email [email protected] with all the details you can.

We are working on the packaging for windows still (As well as the splash screen) and hope very much to have minimize to tray at some point in the near future. Unfortunately for Java applications, these things don't come easy.

We did however make this version a Native Windows exe and also took the time to create an installer. Hopefully that helps make the process more smooth for Windows users in general.
 

·
Weeeeeeeeeeee
Joined
·
570 Posts
Discussion Starter · #11 ·
dmbfan36 said:
AudioFaucet requires at least iTunes 5.0 on both mac and windows -- what version are you running on the mac?
And While John is posting here.. Might as well add that DMBFan36 is the other guy behind AudioFaucet. He's a quiet little lad, so don't scare him :)

Welcome to the forums John,

Cheers,
KC
 

·
Weeeeeeeeeeee
Joined
·
570 Posts
Discussion Starter · #12 ·
eleazar said:
Well, I am assuming I am in the minority here, but I can't even get this to work.
We would like to think so :) We did quite a bit of QA before launching this version due to its complexity and deeper intergration with the TiVo and the host PC. That doesn't however mean that something might not be going horribly wrong for you.

On My PC:
windows xp pro sp 2
tried with no firewall or virus scan

Problems - can't get it to recognize that I have iTunes at all (4.9 version) and when I select my itunes folder as the mp3 folder it can start, but the tivo just won't connect to it at all. gives me an h-t-t-p connection error: 0x50005 All of my other HME apps work just fine on this PC.

(sorry about the h-t-t-p but I can't type that word since my post count is under 5)
The minimum version of iTunes we support is iTunes 5.0. (5.0.1 is out now) So the splash screen should dim that option out so you can't use it untill you install iTunes 5.0 or later.

Usually the connection error has alot to do with the HME on the TiVo not being able to talk to the advertised application, as you guessed usually caused by a firewall issue, or perhaps we're not getting along with another app.

I'd love to work thorugh this more with you if you have the time fire off an email to [email protected] or look me up on AIM: SafariKC

On my Mac:
Tiger 10.4.2
also no firewall when tried

Problems - it recognizes iTunes and does in fact start on the tivo, however, my artists, genre and everything else except for pod casts appear empty on the tivo. When I try to play a podcast, it plays the first second then crashes the tivo with a "an error occured while running the application. The application closed during a read (0x50006)"
You can see iTunes because System Update probably has you on iTunes 5.0.1 :) (if it does not please do a system update and get to iTunes 5.0 or higher)

Curious about the failure to use the app however. Which mode is AudioFaucet in when you do this? Can you list which Audio Output settings you choose (if at all)? Have you tried switching from one audio output to another?

Again, I'd love to work thorugh this more with you if you have the time fire off an email to [email protected] or look me up on AIM: SafariKC

Running 7.2.0-oth-01-2-264 on a Toshiba SDH-400 with no hacks, hard drive replacements or anything.
That should be fine :)
 

·
Resident Nihilist
Joined
·
91 Posts
I installed it, and like the applications for Galleon, it makes the Tivo respond very slowly. I tried to go into some of the settings and it froze the tivo up so I had to push the Tivo button to back out to the main menu. I started audiofaucet up again and went to play a song and got a error message.

I have a Tosiba RS-TX60 completely stock, no hacks or upgrades, running 7.2 and i'm NOT running iTunes, just pointed it toward a folder on my PC that has all my songs from my Ipod for backing up purposes.
 

·
Registered
Joined
·
3 Posts
FrancesTheMute said:
I installed it, and like the applications for Galleon, it makes the Tivo respond very slowly. I tried to go into some of the settings and it froze the tivo up so I had to push the Tivo button to back out to the main menu. I started audiofaucet up again and went to play a song and got a error message.
Are these settings in AudioFaucet that locked up or Galleon? If AudioFaucet, which settings were you attempting to access?

Also, are you running AudioFaucet using only mp3 directories, or does it also have access to iTunes? (On the splash screen when starting the application, there are checkboxes to select which modes you wish to enable).

I have a Tosiba RS-TX60 completely stock, no hacks or upgrades, running 7.2 and i'm NOT running iTunes, just pointed it toward a folder on my PC that has all my songs from my Ipod for backing up purposes.
FYI, AudioFaucet can only stream mp3 files at the present time, so if there aren't any MP3's in there, then that could be cause for difficulty.
 

·
Resident Nihilist
Joined
·
91 Posts
I do not have itunes installed on my computer. as for the settings, i clicked on the settings button and on the next screen it just sat there and i couldn't choose any settings to try out. it sat frozen up for a minute or so until i hit the tivo button to bring me back out to the main menu. I also don't have galleon installed on my computer anymore, but when i did, the results were very similar.... i.e. very slow responding Tivo.

All of my music is encoded in mp3 format. I despise wma and apple aac encoding and i use EAC and LAME to encode all of my songs. I just pointed the audiofaucet program to the folder that contains all of my songs. I successfully got the list of all the songs, but when i went to actually play one, it gave me an error.
 

·
Weeeeeeeeeeee
Joined
·
570 Posts
Discussion Starter · #16 ·
FrancesTheMute said:
I installed it, and like the applications for Galleon, it makes the Tivo respond very slowly. I tried to go into some of the settings and it froze the tivo up so I had to push the Tivo button to back out to the main menu. I started audiofaucet up again and went to play a song and got a error message.

I have a Tosiba RS-TX60 completely stock, no hacks or upgrades, running 7.2 and i'm NOT running iTunes, just pointed it toward a folder on my PC that has all my songs from my Ipod for backing up purposes.
Have a few questions to ask:

First, What do you mean by making your tivo respond slowly? Inside the app the screens draw slowly? Or even after you run it the tivo responds slowly in general (this could be a bug in the TiVo software on that box)... If it is only while you are in the app that the TiVo seems sluggish, It could also be caused by your network.

What type of network do you have? How is the TiVo Connected to that network? If it is Wireless.. what kind of signal strength are you getting at the TiVo (it's in the network settings on the TiVo)

Sorry you are seeing issues.

Thanks
KC
 

·
Resident Nihilist
Joined
·
91 Posts
it's just the audiofaucet app that responds slowly. or sometimes doesn't respond at all. I went back and tried again, and it seemed to respond a bit better. it's more of a hanging than anything else. i scroll through the list of artists and it hangs up for about 15 seconds and then seems fine. I'm using the Linksys USB200 hooked into a Linksys wireless bridge, so I can't check to see what the signal strength is. I have no way of hooking the Tivo up to the wired network as the Tivo is downstairs and the cable modem/router are upstairs.

The slowly responding tivo I can live with, my real concern is that i wasn't even able to play a song. There was an error message as soon as I hit the play button, and this has happened twice now:

"An Error occured while running the application. The application closed during a read (0x50006)"
 

·
Weeeeeeeeeeee
Joined
·
570 Posts
Discussion Starter · #18 ·
FrancesTheMute said:
it's just the audiofaucet app that responds slowly. or sometimes doesn't respond at all. I went back and tried again, and it seemed to respond a bit better. it's more of a hanging than anything else. i scroll through the list of artists and it hangs up for about 15 seconds and then seems fine.
Ahh.. in MP3 mode, we read the entire file tree ahead of time every time you start the application on the TiVo or the Audio Setting is changed, once it's done reading that tree it should be relativly quick. Which might explain why you saw a difference between the times. We currently in MP3 mode do not give feedback that we are indexing your music although in our testing of 1700 songs it indexes in a few seconds and we never see a problem. So if you have a large tree, it could just be that that is making life slow. How big is your MP3 library? Can you try letting it sit open for a few minutes and see if the Browser works faster after that?

I'm using the Linksys USB200 hooked into a Linksys wireless bridge, so I can't check to see what the signal strength is. I have no way of hooking the Tivo up to the wired network as the Tivo is downstairs and the cable modem/router are upstairs.
*nod* I can see how that might make it difficult to get signal strength. How long does it usually take you to transfer a show? (and in what quality?)

What is the specs of the host computer you are running this on?

The slowly responding tivo I can live with, my real concern is that i wasn't even able to play a song. There was an error message as soon as I hit the play button, and this has happened twice now:

"An Error occured while running the application. The application closed during a read (0x50006)"
We think we duplicated the issue here.. can you do me a favor? Can you please run the app again, and this time when the error happens could you please go to your Windows Program Files / AudioFaucet directory and email us the error log. Please email that to [email protected] along with a brief description letting us know who you are and what the issue is (so we can tie it to this issue in our bug system)

Thanks,
KC
 

·
Resident Nihilist
Joined
·
91 Posts
i've been scouring the forums here learning about transfer speeds and such. It takes freaking forever to transfer a show for me. I'm talking somewhere in the neighborhood of 3-4 hours for a 1 hr program on "high" quality. I'm a bit disappointed because Tivo touts the whole transferring of shows to other tivos and your computer but conveniently forgets to mention how slow it is. Anyway, my computer is an AMD64 3500+ with 2GB of DDR400, 2x WD Raptors in RAID 0.

I can also see why i was having hanging issues now that I know how your program works. i have 3509 songs in that mp3 folder, which would definitely account for a delay!!!!
 

·
Electrocuted by TiVo
Joined
·
5,201 Posts
SafariKC said:
FWIW it doesn't require iTunes to work... but to each his own. :) Glad you chimed in anyways.

KC
dmbfan36 said:
AudioFaucet requires at least iTunes 5.0 on both mac and windows -- what version are you running on the mac?
OK. So which is it. :)

I'm partial to open source and all that means. It does seem though that you have a market with Mac users. Good luck with that!
 
1 - 20 of 289 Posts
Top