Yet another "TiVo won't use the network" thread...

Discussion in 'TiVo Series 1 - UK' started by mutant_matt2, Jun 7, 2011.

  1. Jun 7, 2011 #1 of 57
    mutant_matt2

    mutant_matt2 New Member

    105
    0
    Dec 16, 2008
    OK,

    So, apologies for yet another one of these threads, but I'm at wits end. I have been trying for some time, to get TiVo getting it's updates via the Turbonet card, rather than dial up. Last time, a few years back, I gave up, because I just couldn't get it working. Now, I need/want to get it working, so I can switch the the altEPG. So, facts:

    1. It's a Turbonet, which I can telnet/ftp/tivoweb to.
    2. I can ping any internet facing server I try from the TiVo (or any internal network device for that matter!)
    3. I have tried lcsneil's exact, roundabout method which is supposed to be foolproof ;)
    4. TiVo always attempts to dial, and fails on NO CARRIER, when the phone line isn't plugged in (even after following lcsneil's method).
    5. It's the only TiVo on the network, there are no IP address clashes, and all other network tools work perfectly (and always have).

    rc.net (I don't have an rc.net.turbonet) (perhaps I should try to copy rc.net to rc.net.turbonet? (though as I don't have one, and this clearly is correctly setting up networking, I suspect I don't need one!)):

    #
    #!/bin/sh
    #

    if /sbin/insmod -f /lib/modules/turbonet.o macaddr=00:0B:AD:5D:D5:D3 timing=3 ; then
    export DYNAMIC_NET_DEV=eth0
    /sbin/ifconfig eth0 192.168.123.160 netmask 255.255.255.0 up
    /sbin/route.tivo add default gw 192.168.123.254 netmask 0.0.0.0
    fi


    This was created with nic_config_tivo (following lcsneil's exact instructions here: http://www.tivoland.com/forum/viewtopic.php?f=16&t=480&start=150#p4377 )

    route.tivo -n
    route_info, afname=inet, options=37
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.123.0 0.0.0.0 255.255.255.0 U 32767 0 0 eth0
    0.0.0.0 192.168.123.254 0.0.0.0 UG 0 0 0 eth0


    ifconfig -a
    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Bcast:127.255.255.255 Mask:255.0.0.0
    BROADCAST LOOPBACK MTU:3584 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 coll:0

    eth0 Link encap:Ethernet HWaddr 00:0B:AD:5D:D5:D3
    inet addr:192.168.123.160 Bcast:192.168.123.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:1303 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1580 errors:0 dropped:0 overruns:0 carrier:0 coll:0
    Interrupt:29


    I note when I am on dial-up proper (i.e. I mean to use it), I also have ppp0 listed in ifconfig -a.

    I have just endpad, tserver and tivoweb (all properly backgrounded ( & )), but even hashing/rem'ing these out, doesn't help.

    I have posted tclient, but it will show it's dialling, and getting NO CARRIER (I have the cable removed, as per lcsneil's method), however, is there *anything* in tclient log which might help? There is a lot of stuff in it that is beyond me. Of course if I plug the phone line back in, it dials and downloads fine.

    I am a techie, and only run Linux in the house, but this has me stumped.
    Any help, greatly appreciated! (have I missed anything?)

    Cheers,

    Matt.

    tclient (just in case):
    06/07:20:10:37: /tvbin/TClient: inside TClient
    06/07:20:10:38: /tvbin/TClient: No previously downloaded files remain in /var/packages
    06/07:20:10:38: /tvbin/TClient: TClient: invoking init w/argv=-t -backup
    06/07:20:10:38: /tvbin/TClient: writing In Progress to LastCallStatus
    06/07:20:10:39: /tvbin/TClient: TClient init: 0
    06/07:20:10:39: /tvbin/TClient: dial config code: () found
    06/07:20:10:39: /tvbin/TClient: no line matches code =
    06/07:20:10:39: /tvbin/TClient: Using default TiVo Service params
    06/07:20:10:39: /tvbin/TClient: updateStatus: In Progress EX| 29 48
    06/07:20:10:39: /tvbin/TClient: writing In Progress to LastCallStatus
    06/07:20:10:40: /tvbin/TClient: SendDialupEvent 30 9 EX|29
    06/07:20:10:40: /tvbin/TClient: curPhNum is (), tollFreeAuth is (3)
    06/07:20:10:40: /tvbin/TClient: allowing Def TFN use based on TFA
    06/07:20:10:40: /tvbin/TClient: Host = 204.176.49.3
    06/07:20:10:40: /tvbin/TClient: Port = 80
    06/07:20:10:40: /tvbin/TClient: Phone = 08081050005
    06/07:20:10:40: /tvbin/TClient: updateStatus: In Progress EX| 29 8
    06/07:20:10:40: /tvbin/TClient: SendDialupEvent 30 9 EX|29
    06/07:20:10:41: /tvbin/TClient: DataSets may not be enabled, could not find ShowcaseVersion: DataSet ShowcaseVersion does not exist.
    06/07:20:10:42: /tvbin/TClient: mrsigtype=3 mrconnector=7...
    06/07:20:10:42: /tvbin/TClient: mrsigtype=1 mrconnector=1...
    06/07:20:10:43: /tvbin/TClient: Found 2.5.5-01-1 running
    06/07:20:10:43: /tvbin/TClient:
    06/07:20:10:43: /tvbin/TClient: Start Ident =====================
    06/07:20:10:43: /tvbin/TClient: version: 3
    06/07:20:10:43: /tvbin/TClient: centerID: 02300006020ED2A
    06/07:20:10:43: /tvbin/TClient: reasonCode: 4
    06/07:20:10:43: /tvbin/TClient: softwareDesc: NONE
    06/07:20:10:43: /tvbin/TClient: locationID: NONE
    06/07:20:10:43: /tvbin/TClient: sequenceCookie: NONE
    06/07:20:10:43: /tvbin/TClient: headendID: NONE
    06/07:20:10:43: /tvbin/TClient: showcaseDesc: NONE
    06/07:20:10:43: /tvbin/TClient: inventoryFile: 0001172-15124|CM23Ant-15124-t2|ids:uk
    06/07:20:10:43: /tvbin/TClient: waitingCount: 0
    06/07:20:10:43: /tvbin/TClient: dialConfig:
    06/07:20:10:43: /tvbin/TClient: confInfo:
    06/07:20:10:43: /tvbin/TClient: messageDesc:
    06/07:20:10:43: /tvbin/TClient: irdbVersion: 317
    06/07:20:10:43: /tvbin/TClient: genreVersion: 46
    06/07:20:10:43: /tvbin/TClient: logoVersion: 24
    06/07:20:10:43: /tvbin/TClient: affiliationVersion: 8
    06/07:20:10:43: /tvbin/TClient: showcaseVersion:
    06/07:20:10:43: /tvbin/TClient: swVerName: 2.5.5-01-1-023
    06/07:20:10:43: /tvbin/TClient: configParameterList: zip=CM23,dar=,rcq=,tz=7,as=,tun=,suc=7
    06/07:20:10:43: /tvbin/TClient: sourceParameterList: st=3,con=7,drm=2,ekr=,ccn=20016,brn=GRUNDIG,lin=17,irs=150;st=1,con=1,drm=,ekr=,ccn=,brn=,lin=16,irs=
    06/07:20:10:43: /tvbin/TClient: apgOnly:
    06/07:20:10:43: /tvbin/TClient: useChksums: TRUE
    06/07:20:10:43: /tvbin/TClient: premiumShowcases:
    06/07:20:10:43: /tvbin/TClient: captureRequests:
    06/07:20:10:43: /tvbin/TClient: menuItems:
    06/07:20:10:43: /tvbin/TClient: otherDataSets: HDGenre-4|MS_ServiceChange-12|MS_ServiceChange_pmi-12|MS_UpdatedServiceAgreement1-6|MS_UpdatedServiceAgreement1_pmi-6|MS_VMPromo01-6|MS_VMPromo01_pmi-6|MS_VMPromo02-6|MS_VMPromo02_pmi-6|MS_VMPromo02b-6|MS_VMPromo02b_pmi-6|MS_VMPromo02c-4|MS_VMPromo02c_pmi-4|MS_VMPromo03-4|MS_VMPromo04-4|MS_VMPromo04_pmi-4|MS_VMPromo05-5|MS_VMPromo05_pmi-5|MS_VMPromo06-4|MS_VMPromo06_pmi-4|MS_VMPromo07-4|MS_VMPromo07_pmi-4|MS_VMPromo08-4|MS_VMPromo08_pmi-4|MS_VMPromo09-4|MS_VMPromo09_pmi-4|MS_VMPromo10-4|MS_VMPromo10_pmi-4|MS_VMPromo11-4|MS_VMPromo11_pmi-4|MS_VMPromo3_pmi-4|RM_cleanTvShow-|
    06/07:20:10:43: /tvbin/TClient: rbBackgrounds:
    06/07:20:10:43: /tvbin/TClient: dataGroupList: CR_Standard|DG_standard|MI_Standard|SF_SerialLogging|SW_released
    06/07:20:10:43: /tvbin/TClient: lstAvalancheDnload: 0,0 0,0
    06/07:20:10:43: /tvbin/TClient: userInitiated: 1
    06/07:20:10:43: /tvbin/TClient: End Ident =====================
    06/07:20:10:43: /tvbin/TClient:
    06/07:20:10:43: /tvbin/TClient: Logging camid.
    06/07:20:10:43: /tvbin/TClient: CAM_ID not found.
    06/07:20:10:43: /tvbin/TClient: Ird Id.
    06/07:20:10:43: /tvbin/TClient: toneOrPulse = 0
    06/07:20:10:43: /tvbin/TClient: dialPrefix = {}
    06/07:20:10:43: /tvbin/TClient: callWaitingPrefix == {}
    06/07:20:10:43: /tvbin/TClient: phoneNumber = 08081050005
    06/07:20:10:43: /tvbin/TClient: phoneAvailableDetection = 1
    06/07:20:10:43: /tvbin/TClient: dialToneDetection = 1
    06/07:20:10:43: /tvbin/TClient: Starting dial.expect with:
    06/07:20:10:43: /tvbin/TClient: toneOrPulse = T
    06/07:20:10:43: /tvbin/TClient: dialPrefix = {}
    06/07:20:10:43: /tvbin/TClient: callWaitingPrefix = {}
    06/07:20:10:43: /tvbin/TClient: phoneNumber = 08081050005
    06/07:20:10:43: /tvbin/TClient: phoneAvailableDetection = 0
    06/07:20:10:43: /tvbin/TClient: dialToneDetection = 0
    06/07:20:10:43: /tvbin/TClient: useV34 = 0
    06/07:20:10:43: /tvbin/TClient: updateStatus: In Progress CL| 30 24
    06/07:20:10:43: /tvbin/TClient: SendDialupEvent 30 9 CL|30
    06/07:20:10:52: /tvbin/TClient: Whole result is spawn /tvbin/modemtest -expect
    ATZ
    ATZ

    OKChecking for modem type...

    ATI3

    P2109-V90

    OK
    Modem type is 2109
    *****NEW***** modem
    ATQ0

    OK
    ATS0=0

    OK
    AT+GCI=B4

    OK
    AT-STE=2

    OK
    ATW2S6=8S7=50S11=100%C0&D2+MS=V34

    OK
    ATW1X4

    OK
    ATX3

    OK
    AT-TTE=1500,200,500

    OK
    Current line voltage (in volts, of course!):
    AT-TRV

    1.40
    OK
    new modem...line status interrupt disabled
    ATDT08081050005

    NO CARRIER
    Modem dialup failure. Reason follows:
    ATS86?

    025

    OK
    Extention went offhook
    dialcode is:12
    06/07:20:10:52: /tvbin/TClient: PPP has failed, we've warned the user, set status to Failed
    06/07:20:10:57: /tvbin/TClient: updateStatus: Failed CL| 30 24
    06/07:20:10:57: /tvbin/TClient: writing Failed to LastCallStatus
    06/07:20:10:57: /tvbin/TClient: SendDialupEvent 30 9 EX|12
    06/07:20:10:58: /tvbin/TClient: TClient login: 1
    06/07:20:10:58: /tvbin/TClient: TClient backhaulDone: 0
     
  2. Jun 7, 2011 #2 of 57
    alek

    alek New Member

    157
    0
    May 22, 2008
    I didn't read all your post because it's mostly greek to me.

    I apologise if I missed something I should have seen.

    BUT you don't need to worry cause all the drivers you need are built into the altepg image.

    So when you boot it up while connected to your router it's all set to connect and download the epg.


    simples


    Alek
     
  3. Jun 7, 2011 #3 of 57
    mutant_matt2

    mutant_matt2 New Member

    105
    0
    Dec 16, 2008
    Perhaps I should have said, I'm on the original (but hacked) TiVo image, not the altEPG image (too many recordings to switch), and it connects to my router fine (I can ping it, anything connected to it/on my internal network, and anything it routes out onto the internet).

    Thanks anyway :)
     
  4. Jun 7, 2011 #4 of 57
    Automan

    Automan Ex TiVo User

    4,184
    0
    Oct 29, 2000
    South...
    Have you tried the classic of running nic_config_tivo and set to dialup?

    Then restart tivo

    nic_config_tivo and change back to network

    restart and see if it is okay?

    Automan.
     
  5. Jun 7, 2011 #5 of 57
    Trinitron

    Trinitron New Member

    411
    0
    Jan 20, 2003
    North West
    Are you using the original turbonet drivers? I can't see anything obvious from the logs you have posted, but my sketchy memory says you do need rc.net.turbonet, there was an error in the original installation scripts that set this up as rc.net but never called it.

    I would try copying your rc.net to rc.net turbonet then go through the reset procedure again as just posted by Automan (but with test calls after each restart).

    Just double check as well when running nic_config_tivo that the gateway and IP addresses are ok. If you do make changes, pressing 0 (apply & exit) after each change is good practice.

    If that still fails, the only other thought off the top of my head is to change the timing in rc.net(.turbonet) to 16 and see if that works.
     
  6. Jun 7, 2011 #6 of 57
    worm

    worm Damn The Man!

    159
    0
    Feb 10, 2005
    Coldstream...
    the only thing I can think of to suggest (from experience) is to check that the gateway address is right.

    The fact that you can't ping any network devices suggests that something fairly fundamental is wrong.
     
  7. Jun 8, 2011 #7 of 57
    mutant_matt2

    mutant_matt2 New Member

    105
    0
    Dec 16, 2008
    Thanks guys.

    Automan, yes, lcsneil's method involves doing that, and I tried that, twice (which took some time! ;) :) ).

    I am using the turbonet drivers that came from a file called nic_install_pc_20050218.zip, and the files in that are dated 2005-02-18, turbonet.o at 10:32:12 and 11756 bytes. From what I can make out (as the module is called turbonet.o (not turbonet2.o that I see in some people's threads), the rc.net is working (it must be), as I have full, proper network access (as I said, I *can* ping the default gateway, anything on my network, and anything out on the internet (including the tivo servers, the altEPG servers, OpenDNS and a few others I've tried)).

    In the install zip file, I can also see airnet drivers (airnet.o), cachecard drivers (cachecard.o) and also turbonet2.o. Does anybody know the difference between turbonet.o and turbonet2.o? (they have the same time/date stamp in my zip file, so one doesn't look "newer" than the other).

    I have also checked, and the presumably latest drivers, are the same as mine, downloaded from here: http://forum.technicalpeak.com/viewtopic.php?f=3&t=13&sid=b05f0fcc8c2c2864d1ebac63f78d744b


    The route.tivo -n shows the default gateway is correct, backup up by the success of being able to ping.

    Here's a question, does the nic_config_tivo, *only* create the rc.net (or rc.net.turbonet), or does it make any other changes anywhere else in the system, does anybody know? I ask because, all the fiddling around with nic_config_tivo, if it only creates the rc.net file (or rc.net.turbonet), is irrelevant, surely, if the rc.net file looks correct? I also can't figure out/find, what calls the rc.net/rc.net.turbonet?

    If the TiVo has a working eth0 (it does), it can route to the internet, it has the environment variable DYNAMIC_NET_DEV=eth0 set (and also _=eth0 too), does/should, anything else matter? There must be something more?

    Again, any help, most gratefully appreicated! :)

    Cheers,

    Matt.
     
  8. Jun 8, 2011 #8 of 57
    tivotrebor

    tivotrebor Essex man

    37
    0
    Oct 2, 2002
    Essex
    Hi Matt,

    Whatever you do not set the test option with nic_config_tivo as this will criple the ethernet interface.

    I have the same problem as you can see my thread Help in getting my tivo to use the network.

    I cannot progress mine moment as my DVD drive/burner has died and I am waiting for a new one to come

    TiVoTrebor
     
  9. Jun 8, 2011 #9 of 57
    TCM2007

    TCM2007 New Member

    3,947
    0
    Dec 25, 2006
    If eth0 exists, that usually means it's making calls via the net; IIRC it comes up as eth1 is it is still dialling.
     
  10. mutant_matt2

    mutant_matt2 New Member

    105
    0
    Dec 16, 2008
    If I set nic_config_tivo back to dialup, it changes the rc.net to eth1, and removes the eth0 environment varible, and the route to the default gateway. Then, when it dials, it creates the ppp0 interface as well. Dial up always works, regardless of what settings I have, as long as the cable is connected.

    Tivotribor, I was following your thread (and you see I posted on it), well I've now caught up with you, and seem to have almost the same problem. I am hoping someone clever and experienced, sees my last post and can help explain/answer my questions, if not make a very clever suggestion! :(

    However, I didn't think to look in the kernel log (duh!), seeing yours in your thread, and this is what I get, when the test call is attempted (in the kernel log):

    Jun 7 20:11:27 (none) kernel: rc.sysinit is complete
    Jun 7 20:11:30 (none) kernel: turbonet driver version 20050218
    Jun 7 20:11:30 (none) kernel: turbonet: updated tlb entry 2 to 1M
    Jun 7 20:11:30 (none) kernel: turbonet: using MAC address 00:0B:AD:5D:D5:D3
    Jun 7 20:11:30 (none) kernel: turbonet: driver installed
    Jun 7 20:11:31 (none) kernel: IP struct was not filled in!
    Jun 7 20:11:31 (none) kernel: sa is: 0x20000 0xc0a87ba0 0x7ffffcd4 0x7ffffcf0
    Jun 7 20:11:31 (none) kernel: sa.sin_addr = 0x7ffffc38 a sockaddr is 16 bytes
    Jun 7 20:12:13 (none) kernel: turbonet: call log: unexpected tx protocol 1
    Jun 7 20:12:13 (none) kernel: turbonet: call log: unexpected rx protocol 1
    Jun 7 20:12:14 (none) kernel: turbonet: call log: unexpected tx protocol 1
    Jun 7 20:12:14 (none) kernel: turbonet: call log: unexpected rx protocol 1
    Jun 7 20:12:15 (none) kernel: turbonet: call log: unexpected tx protocol 1
    Jun 7 20:12:15 (none) kernel: turbonet: call log: unexpected rx protocol 1

    If there was a problem with the turbonet driver itself, or anything to do with the IP config, I wouldn't be able to ftp/telnet/tivoweb/ping!!??

    I am also curious how some people have turbonet2.o on theirs, when I have the same driver in the zip file that my nic_install came from, yet it seemed to install turbonet.o.

    Also, I just noticed, that I stupidly chopped out the section of tclient which shows it attempting to pick up the phone, due to not thinking about what I was using grep for properly, so that has been restored now in my original post...

    Anyone? :)

    Cheers,

    Matt.
     
  11. spitfires

    spitfires wassock

    724
    0
    Dec 19, 2006
    South Coast, UK
    Do you have a file called /var/tmp/pppaddr ? If so try disabling it (actually it should be safe to delete it - it's ephemeral) & then trying DC via network.

    .
     
  12. mutant_matt2

    mutant_matt2 New Member

    105
    0
    Dec 16, 2008
    Not at the moment (so probably, not when I last tried to connect over the network (test call), last night). What's in /var/tmp/pppaddr?

    I also have now done a test http_get, to get a file off my server, so I know I can grab stuff on port 80 from the internet, via my Tivo (which would rule out any transparent proxy type issues?)

    Cheers,

    Matt.
     
  13. TCM2007

    TCM2007 New Member

    3,947
    0
    Dec 25, 2006
  14. Wonk

    Wonk New Member

    10
    0
    Jan 22, 2006
    I've tried, half heartedly, a couple of times in the past few years to get the daily call working over the net (I've a populated cachecard). Being in the large% outside a chaste cable region, I've been thinking about trying to have another go at getting this working.

    Grasping at straws, but I note that your IP setup, mine and that of tivotrebor in the other thread referenced here aren't in the network drivers default 192.168.[0 or 1, can't remember which].x address range (I run 192.168.88.0, you use 123 from what's posted above, and tivotrebor is in the 10.whatever range).

    Now, my modest knowledge of these things suggests this shouldn't make a difference, but in the back of my mind I've always wondered if my home net was in the 'default' range the tivo net drivers expect, would that make the difference?
     
  15. spitfires

    spitfires wassock

    724
    0
    Dec 19, 2006
    South Coast, UK
    @Wonk
    Good spot. Yes it shouldn't make a difference of course but who knows what has been coded into the TiVo core software - it doesn't take much to imagine something like:

    {pseudo-code}
    if IP address of network = 192.168.1.0/24 or = 192.168.0.0/24 then
    ...use network
    else
    ...use dial-up
    endif
    {/pseudocode}

    You have to remember the programmers weren't expecting ethernet to be used in UK TiVos (that only became standard in v3) so it's possible they coded in something just for testing/engineer use rather than allowing for all IP subnets. (That's pure conjecture of course!)

    If I had time I could test this by tempo changing my router (from 192.168.1.x) but I can't right now.

    Does anyone have the Daily Call working on a subnet of other than 192.168.1.x (or 192.168.0.x ?) ?

    .
     
  16. Maclynn

    Maclynn New Member

    136
    0
    Oct 6, 2000
    Birmingham...
    Alt EPG does have a dial up option for normal operation if you dont need the online extras.
     
  17. Ian_m

    Ian_m Active Member

    1,518
    0
    Jan 9, 2001
    Southampton,...
    Mines on 192.168.10.x and works fine on Cachecard. Had to change from 192.168.1.x many years ago when I got VPN to my work and clashed with works IP ranges.
     
  18. spitfires

    spitfires wassock

    724
    0
    Dec 19, 2006
    South Coast, UK
    ^ Cool, thx for the info. Back to the drawing board then! :(
     
  19. Automan

    Automan Ex TiVo User

    4,184
    0
    Oct 29, 2000
    South...
    My Tivo is on 192.168.178.40 with GW of 192.168.178.1

    It does seem to be a very odd issue which only effects some users....

    But what do they all have in common?

    The effected boxes are able to ping the Tivo servers or altepg servers from a telnet session but the program on the Tivo that calls for data selects the dialup route.

    Does any option exist to tell Tivo that the dial-up modem does not exist?

    Automan.
     
  20. Wonk

    Wonk New Member

    10
    0
    Jan 22, 2006
    Ah well, thought it was a long shot. VPN is exactly the reason I moved my range too.

    Another oddity I've noticed in the past - if I add a default gateway to my TiVo so it can get out to the wilds of the net, the daily call via dialup fails.
     

Share This Page