XL4 extremely slow

Discussion in 'TiVo Premiere DVRs' started by don911, Mar 16, 2015.

  1. don911

    don911 New Member

    22
    3
    May 7, 2014
    I've had a Premiere XL4 for a couple of months and have now received the 20.4.6 update. Everything is now very slow. Opening a folder in "My Shows" takes 20s. When doing a search, I get the spinning ball when I choose a show. It's also slow to get back. Furthermore, most of the time if I want to set up a OnePass, I wait for a minute or so, then nothing happens. Then I click again and sometimes the OnePass window comes up, other times nothing again. And when I finally manage to get into the "set OnePass" screen, after a long wait, I'm out and the OnePass did not get set. Sometimes it works and sometimes it does't.

    I had the same problem with my Mini before the update. If I changed a season pass on my mini, the changes would not go through on the Premiere. After the update they sometimes do and sometimes don't.

    I can't say for sure that all this is happened after the 20.4.6 update, because I had issues with speed before that as well. But things have definitely gotten much worse. I just spent 10 minutes trying to set a OnePass three times only to have it not go through in the end. However, if I switch to SD menus I will be able to set the Season pass.

    Also, just now I tried to delete a OnePass and it wouldn't delete it either. However, that worked yesterday.

    Does anyone know what's going on here? I have rebooted several times.

    I also want to mention that I have 90 Season passes. Is that a lot? On my Old HD XL changing order in the Season Pass manager took forever. I was pleased that the Premiere was so much faster. At least in the beginning. Now it takes more that 10 minutes on the XL4 and I don't know when that started.
     
  2. Teeps

    Teeps Well-Known Member

    2,112
    81
    Aug 16, 2001
    Torrance,Cal...
    Did you try a hard reboot?
     
  3. don911

    don911 New Member

    22
    3
    May 7, 2014
    Do you mean pulling the power cord for 30s? If so, yes.
     
  4. telemark

    telemark Active Member

    1,544
    4
    Nov 12, 2013
    Shot in the dark, What's the hard dive in the XL4?
     
  5. NorthAlabama

    NorthAlabama tabasco rules

    10,688
    2,605
    Apr 19, 2012
    sweet home, al
  6. Teeps

    Teeps Well-Known Member

    2,112
    81
    Aug 16, 2001
    Torrance,Cal...
    Yes, that is what I meant.

    Mine was slow too, as you described above.
    My XL4 TiVo received the 20.4 update over the weekend. That's when I first noticed the sloth like operation.
    But, as of this morning seems more responsive.

    Also had a problem yesterday when deleting programs from my shows folder.
    Gray X was displayed but no deletion. That too has since fixed itself(?).
     
  7. don911

    don911 New Member

    22
    3
    May 7, 2014
    Thanks! I'm having the same issues. I will try the following tomorrow:

    settings & messages > help > restart or reset > clear thumb ratings & suggestions
    settings & messages > help > restart or reset > clear program info & to do list

    This seems to have helped a lot of people.
     
  8. don911

    don911 New Member

    22
    3
    May 7, 2014
    Today I cleared thumb ratings & suggestions as well as all program info & the to do list. Now everything works fine! No more spinnings wheels. Everything is almost instant. Even exiting the OnePass Manager after re-arrange the order of my 90 passes, is instant!

    Thanks to NorthAlabama for the suggestions. And weird that Tivo wanted me to send it in for a free warranty replacement when I called them a couple of days ago! They should probably improve their tech support. They just saved a lot of money.

    I also want to add that clearing the above things did not delete anything other than the thumb ratings. Everything else was rebuilt. Including the wish list searches and their auto-recordings.
     
  9. NorthAlabama

    NorthAlabama tabasco rules

    10,688
    2,605
    Apr 19, 2012
    sweet home, al
    glad it worked! :up:
     

Share This Page