Xfinity on demand

Discussion in 'TiVo Premiere DVRs' started by caddyroger, Oct 3, 2012.

  1. Oct 6, 2012 #21 of 451
    mickpetey

    mickpetey New Member

    21
    0
    Aug 2, 2012
    I just started to play around with the interface,.......very smooth interface jumping around menus compared to previous Comcast dvr. I love having dating on demand back so I can watch the drunk confessionals. Such a riot!
     
  2. Oct 6, 2012 #22 of 451
    robertne

    robertne New Member

    18
    0
    Aug 2, 2012
    Yea I am kind of getting pissed at comcast and tivo. I want my on demand!
     
  3. Oct 7, 2012 #23 of 451
    h2oskierc

    h2oskierc I'm a 2-Tuner

    281
    0
    Dec 16, 2010
    Minnesnowta
    I have it Andover as well, so you can possibly add Anoka county to the list.
     
  4. Oct 8, 2012 #24 of 451
    Sirroke

    Sirroke New Member

    3
    0
    Oct 8, 2012
    Yes! I live in Chehalis, WA and had the same exact problem. I spent 3 hours on the phone with Comcast but after 12 different people they were still unable to help. I've given up.

    If anyone finds a solution to this problem please let us know!
     
  5. Oct 9, 2012 #25 of 451
    drebbe

    drebbe Carbon Blob

    141
    0
    Apr 11, 2012
    Sector 7G
  6. Oct 9, 2012 #26 of 451
    buscuitboy

    buscuitboy Member

    755
    2
    Aug 8, 2005
    Atlanta area
    Well, at least its FINALLY arrived to the east coast region/area. :up:
     
  7. Oct 9, 2012 #27 of 451
    jrtroo

    jrtroo Chill- its just TV

    5,073
    300
    Feb 4, 2008
    Chicagoland
    Boston was not on the east coast? weird.
     
  8. Oct 9, 2012 #28 of 451
    Soapm

    Soapm Active Member

    1,662
    8
    May 9, 2007
    Aurora, CO
    I am in the mile high city of Denver Colorado, the home of the losing Denver Broncos and I have it. That for the 411...
     
  9. Oct 10, 2012 #29 of 451
    Chris Grant

    Chris Grant New Member

    18
    0
    Oct 3, 2001
    Bellevue, WA
    Is this problem unique to Washington state? I'm having the same problem in Bellevue, WA. The menus work fine but the picture freezes after 1-2 seconds, although the running time indicator moves forward like it's playing!
     
  10. Oct 10, 2012 #30 of 451
    buscuitboy

    buscuitboy Member

    755
    2
    Aug 8, 2005
    Atlanta area
    Well, at least you have it. I'm in the #1 worst sports city of HOTlanta & no signs of it here yet. So, not only do all our sports teams stink (except for the Falcons this year), but we'll probably be last to get this Xfinity for our TiVos too. :p
     
  11. Oct 10, 2012 #31 of 451
    rws6620

    rws6620 New Member

    2
    0
    Feb 9, 2005
    I'm having the exact same problem. If anyone hears or knows of the solution...
     
  12. Oct 10, 2012 #32 of 451
    JandS

    JandS Well-Known Member TCF Club

    1,440
    346
    Oct 1, 2010
    East of Seattle
    No problem for us in north-eastern edge of Woodinville WA.

    Our setup is an XL4 purchased about May/2012, with new-to-us Comcast "multi" cable card.

    I don't recall the circumstances now but with our previous XL2 we did have to exchange the multi-card, no flack or questions at the Comcast office, simple phone activation later.
     
  13. Oct 10, 2012 #33 of 451
    Jayadub

    Jayadub New Member

    5
    0
    Sep 20, 2006
    Lynnwood, WA
    I'm having the freezing issue here in Lynnwood on a Premiere XL4 and also am not able to access any Premium content. It all says "Subscription Required" though of course one already exists. M Card appears to be paired correctly and have not had a single problem with it since installing initially.

    I posted in the Comcast Direct area on dslreports.com and am waiting for them to get back to me. I figured there was no point in calling Comcast. This has just rolled out, no CSR will be able to help.
     
  14. Oct 10, 2012 #34 of 451
    tazzmission

    tazzmission Active Member

    697
    45
    Oct 15, 2002
    North...
    I'm in Pittsburgh, no Xfinity on demand on my 3 Premieres. The site says its available in my zip code. How do I get it?
     
  15. Oct 10, 2012 #35 of 451
    Soapm

    Soapm Active Member

    1,662
    8
    May 9, 2007
    Aurora, CO
    Freezing might be signal level problem. You might want to have your cable provider come out and check the levels at your box.
     
  16. Oct 11, 2012 #36 of 451
    drebbe

    drebbe Carbon Blob

    141
    0
    Apr 11, 2012
    Sector 7G
    Northern New Jersey added.
     
  17. Oct 11, 2012 #37 of 451
    MICHAELSD

    MICHAELSD New Member

    33
    0
    Sep 29, 2010
    When they say Northern NJ, they do very well mean Northern since it's a no dice situation for it in Ocean County (Central Jersey) :(
     
  18. Oct 11, 2012 #38 of 451
    sbiller

    sbiller Active Member

    1,917
    0
    May 10, 2002
    Tampa, FL
    It now says New Jersey (i.e., they removed the Northern word).
     
  19. Oct 11, 2012 #39 of 451
    morac

    morac Cat God

    11,613
    678
    Mar 14, 2003
    NJ
    It's not in the Southern part yet. Usually NJ is treated as one market though so I'm hoping it will be soon. I'd like to turn in my HD cable box, though I don't think Comcast will lower my bill since the box is included. I'm hoping it will dump the HD tech fee though.

    Also I think Ocean county would be considered more South than central. It's in Mercer, which is what I consider more central.
     
  20. Oct 11, 2012 #40 of 451
    jayfest

    jayfest Not-so-New Member

    337
    0
    Mar 25, 2003
    New Jersey
    I'm getting a $2.50 credit on my Comcast bill in South Jersey for every box I'm NOT using, calling it "Customer-owned equipment"
     

Share This Page