Wrong Channel Icon (Logo) When Channel Changes

Discussion in 'TiVo Premiere DVRs' started by species8472jj, Oct 18, 2011.

  1. species8472jj

    species8472jj Member

    61
    0
    Dec 23, 2009
    I have a Tivo Premier XL.

    At the top of the banner, there is the channel icon next to the channel number. The issue I am running into is when the channel changes, the logo does not seem to change with it.

    For example, Channel 205 used to be HD Theater, and they recently changed to Velocity. Even though the channel name changed, the logo on the right hand side, still shows the HD Theater logo.

    I was wondering if anyone has experienced this?

    Thank you.
     
  2. rainwater

    rainwater Active Member

    7,066
    5
    Sep 21, 2004
    TiVo rarely updates channel logos. My guess is they may change the Velocity logo in a few more months. To be fair, only the display name changed. The channel id didn't change. This is why no season passes were affected.
     
  3. LoREvanescence

    LoREvanescence Always Autocorrected

    10,204
    2,378
    Jun 19, 2007
    Salem, MA
    The same is going on with History 2, which used to be History International.

    I believe TiVo only updates channel logos during software updates but I might be incorrect. In any event, we are lucky if they update them once a year or so.
     
  4. rainwater

    rainwater Active Member

    7,066
    5
    Sep 21, 2004
    Sometimes they seem to push logo updates with software updates, but they can update logos without a software update.
     
  5. species8472jj

    species8472jj Member

    61
    0
    Dec 23, 2009
    H2 is indeed another one that is wrong.

    I found others as well as channels where the logos are missing.

    I contacted support, and they had me erase my program guide and reload it (this hosed part of my season passes as well). I still don't know why. That did not work.

    They then asked me to repeat the guided set up and that didn't work.

    Finally, they asked me me to go through the guided set up twice.

    1) First, put in a zip code for a different area, so a different line up is entered (i.e. do the guilded set up for the alternative zip code)

    2) Go through the guided set up again putting my zip code in, so I get the correct line up.

    None of these things worked. Just thought I'd share.

    I actually gave them an entire list of what was wrong - incorrect logos and missing logos.
     
  6. rainwater

    rainwater Active Member

    7,066
    5
    Sep 21, 2004
    There was no need to contact support. It isn't a software issue. Most of these channels are national channels so it will not matter what lineup you use. TiVo seemingly does a buch of logo updates about once a year. So I wouldn't expect an update anytime soon. And yes, they are missing a lot of channels. In fact, there are more logos now than 2 years ago when there were hardly any so it is a slight improvement.
     

Share This Page