WinMFS / Powering Up after restore/expand

Discussion in 'TiVo Upgrade Center' started by Mike Farrington, Jun 25, 2011.

  1. Mike Farrington

    Mike Farrington Lost Member

    3,786
    4
    Nov 16, 2000
    My S3 has been in a reboot loop for the past week or so, without occasional bouts of working properly. I'm figuring it's the HD. SpinRite gave it a clean bill of health, but I think there's just a logical problem.

    So, I bought a new 2TB HD and dusted off the original S3 image backup I took using WinMFS (when I bought the S3 a few years back). This is the same backup I used against the 1TB disk that is now having issues.

    At first I was having problems restoring the backup, getting "error writing media inode 1". But quickly figured I'd better use DiskPart to wipe out the NTFS partition I had temporarily put on this new 2TB HD. After that, WinMFS had no problems restoring my image and asking if I wished to expand (which I did).

    However, after putting this new drive into my S3, I'm stuck at "Welcome! Powering Up...". It's been stuck there for a good 30 minutes now, so that makes me think it was definitely the HD and not the Power Supply.

    Does anyone have any pointers?
     
  2. ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,689
    922
    Apr 6, 2000
    SF Bay Area
    Western Digital drives has an auto head parking feature that is not compatible with Tivos. To counteract this, run WDIDLE /D.

    Note: this program will not harm data on the drive, so its safe to perform any time.
     
  3. Mike Farrington

    Mike Farrington Lost Member

    3,786
    4
    Nov 16, 2000
    I ran WDIDLE3, and now it goes into the same reboot loop (no longer just stuck at "Welcome! Powering Up...".

    It seems I haven't been paying attention to HD news... The S3 only supports up to 1TB internally? While the Premiere supports 2TB internally? I just figured it could support 2TB and that the only reason I had a 1TB was that it was all that was available at the time of original upgrade.

    I re-applied my backup to my 1TB drive (after wiping its partitions). I figured since SpinRite said it was OK, I'd give it a try. But that still suffers the reboot loop. Though, before it got to "Almost There", but now with the new image it does not.

    While SpinRite said the drive was ok, for some reason my SATA connections on my motherboard apparently do not pass on SMART details.

    Oh well. My wife is going to kill me. True Blood season premier is tomorrow night, and we have no TiVo. Time to throw one of those CableCARDs into the TV and watch, gasp, live TV.
     
  4. dwit

    dwit Active Member

    1,660
    0
    May 4, 2004
    Atlanta, GA
    Don't suppose you have been able to get either drive to run "kickstarts"?

    What about the original S3 hard drive?

    Anyway, as of right now, you have a possible 1 TB HD which has failed(as far as the Tivo is concerned) and a 2 TB drive which it does not support.

    Maybe try exchanging the new hard drive for another new, smaller one.
    Keep us abreast.
     
  5. Mike Farrington

    Mike Farrington Lost Member

    3,786
    4
    Nov 16, 2000
    I'm looking at the kickstart stuff now and will give some of them a try, thanks.

    I eventually re-purposed the S3's original HD after it had sat around for years, so it's now unavailable. Unless the kickstart works, I don't think we'll be recording True Blood tonight (unless I go buy a HD at retail, which I loathe to do).
     
  6. Mike Farrington

    Mike Farrington Lost Member

    3,786
    4
    Nov 16, 2000
    The kickstart stuff never worked on my existing drive. So I went ahead and bought a new 1TB from Staples (after checking compatibility on various tivo forums). My WinMFS restore didn't work on this drive either. So then I let it sit for about 10 days because I was sick of dealing with it.

    I had removed one of the CableCARDs to use in my television for the TrueBlood premiere, only to remember that I cheaped out when buying my TV and got one without a CableCARD slot. D'oh.

    So, I set things aside for about ten days. In the interim, I downloaded a 2GB virgin image from Supafly's torrent. I figured I had a bad backup causing all my issues.

    Well, after dorking around with linux boot discs today, I finally got that 2GB image restored. And guess what? It still had the reboot loop, without any ability to Kickstart.

    I was just about to give up again, when I figured I'd pop that other CableCARD out to see if it made a difference. Right away it came back to life and booted right up.

    What a pain in the ass. I'm guessing now it is either a hardware failure in the CableCARD, or a bad firmware pushed by Comcast. They recent did a major addition of channels in my area (and likely a bunch of them are SDV).

    All I know at the moment is that one of the CableCARDs was causing an instant reboot. Once I get through guided setup and upgrading the box up to the latest version of the TiVo software, I'll stick that other CableCARD in (the one I had removed to put into my TV) and see if that one causes a reboot as well. They're different brands, and one was an M-Card one and S-Card, so hopefully whatever was wrong with their firmware only affected one of them.
     

Share This Page