WiFi issues

Discussion in 'TiVo Help Center' started by imreolajos, Jan 15, 2012.

  1. imreolajos

    imreolajos Member

    32
    0
    Jan 27, 2005
    Eden...
    Hi all!

    First, my network setup:

    TiVo Series 2 dual-tuner - Ethernet connected
    TiVo Series 3 - Wireless G adapter
    PC - Ethernet connected, TiVo desktop installed
    Android smartphone - Wireless N connected
    iPhone - Wireless N connected

    Until recently I had a Wireless G router and everything worked just fine. Then I replaced it with a Wireless N router (Medialink MWN-APR150N). Still most everything works fine - except for my Series 3.

    My new router is setup up in 11b/g/n mixed mode, channel is autoselect, DHCP is enabled. Nothing fancy.

    When I changed the network settings on my Series 3 for the new router, it seemed to connect to the network, everything worked fine. Then after an hour or so it dropped off - I couldn't even ping it any more, but strangely enough, the Series 3 itself could still connect to the TiVo servers. However, my TiVos no longer saw each other, and my TiVo Desktop no longer saw my Series 3, either. So then, I went through the network setup on the Series 3 again - it connected, then it dropped off again after some time.

    I have been playing this game for that past couple of weeks now. Sometimes it keeps being connected for a day, sometimes for less than an hour.

    There's another strange thing going on. Even when my Series 3 is connected correctly, my router shows the list of connected devices as follows:

    Code:
    +------------------------------------------------------------------+
    | Host Name            | IP Address    | MAC Address       | Lease |
    +------------------------------------------------------------------+
    | Office               | 192.168.0.100 | 00:00:00:00:00:00 | 00:00:00
    +------------------------------------------------------------------+
    |                      | 192.168.0.101 | <something>:A5:7B | 6days 21:57:10
    +------------------------------------------------------------------+
    | TIVO-<service number>| 192.168.0.102 | <something>:3C:95 | 6days 20:21:08
    +------------------------------------------------------------------+
    | WhiteDell            | 192.168.0.103 | <something>:C6:D3 | 6days 20:21:06
    +------------------------------------------------------------------+
    | iPhone               | 192.168.0.104 | <something>:1E:22 | 6days 23:55:55
    +------------------------------------------------------------------+
    
    The "TiVo-<service number>" is my Ethernet connected Series 2. The one with the empty hostname is my Android phone. The IP address of the one listed with the "Office" hostname corresponds to my Series 3 TiVo. As you can clearly see it's listed with an invalid MAC address.

    This fact that even when everything seems to be working correctly, my Series 3 is still reporting itself incorrectly to the WiFi network is really bothering me. On the Series 3 itself it is showing its own MAC address as a proper series of hex numbers. However, even when I can ping it, it may or may not show my Series 2 TiVo on the "Now Playing" screen, it's pretty much a hit or miss.

    I think what it boils down to is that my Series 3 WiFi connection seems to be unstable. The fact that I didn't have this problem before I changed routers seem to be pointing to the router as the culprit. However, my Wireless N smartphones never disappear from my home network once they're connected. Maybe it's a Wireless G specific bug?

    Before I resort to the somewhat expensive solution of replacing the Wireless G adapter on my Series 3 with a Wireless N adapter, can anybody tell me what might be going on here?

    Thanks, and apologies for the long-winded post.
     
  2. ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,706
    926
    Apr 6, 2000
    SF Bay Area
    It sounds like interference on your wireless channel. Try changing it. Try channel 1, 6, or 11.

    Don't forget to keep 2.4 GHz enabled and not 5 GHz only.
     
  3. 84lion

    84lion Member

    62
    2
    Jan 22, 2009
    I haven't checked the wireless router connections, but what happens to me is that our two Tivo HDs lose connection with each other and the household computers. The HDs can still "phone home" and get their data and whatnot, but the HDs won't "see" each other and the computers can't see the HDs.

    The "solution" I've come to is to log onto the Tivo.com service and change my settings to de-enable video sharing (and whatever the other setting is that's with it, can't remember what it is), save that, and then re-enable, save that, and then force both Tivos to connect to the Tivo service. That usually fixes the problem. On rare occasions I've had to reboot the HDs as well. I have one Tivo that is connected (hardwired) with Ethernet to a computer, and that exhibits the same problem, IOW, to get it to "talk" to the computer, I have to change the settings on Tivo.com.

    It seems to me that the problem is software-related, where the Tivos for some reason "forget" that video sharing is enabled and must be "reminded." I really don't think it's a wireless problem or the Tivo wouldn't be able to "phone home." It's utterly weird and very frustrating, as the "Chinese fire drill" of going to Tivo.com and then forcing a connection and all that can take a good 15 minutes. And I agree, the video sharing may last a day or it may last hours.
     
  4. Speed Daemon

    Speed Daemon New Member

    78
    0
    Jan 15, 2012
    That MAC field of all-zeroes is a clue that your router's ARP (address resolution protocol, maps MAC address to IP address) table is having problems. This could be a firmware issue with the router, or a reception problem. Make sure that your router has the latest firmware update on a regular basis.

    The routers that keep host information like name and address(es) usually store old entries long after they've left the network. They also allow me to delete entries, which can let them refresh. I'd try this first and see what happens. To save time, you might want to run an Ethernet cable to the problematic TiVo first, to aid in troubleshooting. If the ARP table works fine on Ethernet, but fails with Wi-Fi, you know where to look next.

    Personally I'd make the effort to run Ethernet if at all possible. Now that everybody has a Wi-Fi transmitter running 24x7 on a narrow, unlicensed band, it's more trouble than it's worth (at least for me). But if you must, make sure that the problem TiVo isn't assigned to a DMZ IP address, and that multicast and Zeroconf (a.k.a. "Bonjour" :rolleyes:) aren't disabled. If there are any firewall rules to block UDP port 5353 on the LAN, remove them.

    Good luck!
     
  5. lillevig

    lillevig Cold in East Iowa

    1,778
    1
    Dec 6, 2010
    Marion, Iowa
    If the S3 is set up to get an address via DHCP, then I suggest using a fixed IP address. I had a problem with my S3HD where it just refused to get a DHCP address but purrs along nicely with a fixed IP address. As Unitron recommends, if a device is not mobile, then give it a fixed IP address.
     
  6. unitron

    unitron Well-Known Member

    16,576
    41
    Apr 28, 2006
    semi-coastal NC
    And as I further say, "Can't hurt, might help".:)
     
  7. imreolajos

    imreolajos Member

    32
    0
    Jan 27, 2005
    Eden...
    I see no option in my router to switch to 5 GHz, all 13 channels that are available are on 2.4 GHz. It is set to auto-select the channels, so maybe I'll try to fix the channel (frequency), hopefully on one that doesn't get interference.

    Thanks!
     
  8. imreolajos

    imreolajos Member

    32
    0
    Jan 27, 2005
    Eden...
    It does, I checked that.

    Due to the location of my router and my Series 3, running an Ethernet cable is not an option for me, they're too far away from each other. And I'd rather keep my router close to my PC for wired Ethernet connection (and the Series 2 happens to be in the same room, so that's wired, too).

    But if push comes to shove, I might run a really, really long Ethernet cable to it for testing purposes.
     
  9. imreolajos

    imreolajos Member

    32
    0
    Jan 27, 2005
    Eden...
    Thanks, I just did that, I put all of my devices (wireless or not) on a fixed IP address, it does make a ton of sense. After setting this up on the router, I turned everything off and I turned them on one at a time.

    The Series 3's connection now seems more stable, but I still saw it completely disappear from the network once. Then it popped back up somehow, right now it's still working fine.

    Thanks for everybody's help, these are great suggestions! I think I'm getting closer to a stable solution. :)
     
  10. ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    11,706
    926
    Apr 6, 2000
    SF Bay Area
    I have my Tivos set on wireless G, fixed IP, DNS and gateway on my router's IP (192.168.1.1). The gateway and DNS setting is to reduce or stop Error Nxx, those that are related to DNS or gateway errors.
     
  11. imreolajos

    imreolajos Member

    32
    0
    Jan 27, 2005
    Eden...
    So, right now I have another weird state: my wired Series 2 can see my WiFi Series 3, it can browse its recorded programs. My Series 3 is reporting an 88-90% signal strength, but I cannot ping it from my wired PC, also, the Series 3 is not seeing the Series 2 (it's not showing up in its Now Playing list). Pretty weird!

    You'd think that if the Series 3 drops off the network completely that would make it invisible to the Series 2, too, but that doesn't seem to be the case here.
     
  12. imreolajos

    imreolajos Member

    32
    0
    Jan 27, 2005
    Eden...
    A quick update: I switched my router from auto-assigned channels to a fixed channel number and so far no problems with the Series 3's WiFi. I'll let everybody know tomorrow if it stays connected.
     
  13. imreolajos

    imreolajos Member

    32
    0
    Jan 27, 2005
    Eden...
    Based on my experiments of the past few days, I think the TiVo software is also doing some network caching: even though my wireless Series 3 completely disappeared from the network (I couldn't even ping it), it still showed up on my wired Series 2, I could even browse its recorded programs. However, after my Series 3 has been offline for some time, eventually it also disappeared from the Series 2.

    So, when TiVos go on and off the network, you need to be a bit patient, as the TiVo's cache might make it appear like your network is fine when it's actually not (and vice versa).

    I think your problem could be similar to mine: your network (and/or your router) is experiencing occasional packet loss (maybe due to wireless interference, maybe due to a faulty Ethernet cable), so all the handshaking and discovery that is taking place between your TiVos and the TiVo Desktop on your PC becomes unreliable.

    In my case I am somewhat lucky: my problem is localized to a single wireless connection between my Series 3 and my router. In your case the problem could be an aging router or a bad cable or wireless interference or all of the above.

    I'd recommend debugging your network one piece at a time: bring up your router and your PC, turn everything else off. Ensure this works fine. Then boot up your wired TiVo. Ensure this works fine (exercise patience, as it might take a couple of hours for your problem to surface, so give it time). If that's not working already, try replacing the Ethernet cable. When you're confident your wired TiVo is working fine, boot up your wireless TiVo.

    It took me a day and a half to try various settings and then reboot everything, then wait to see if it still works after a couple of hours, then changing more settings, then rebooting everything again, etc., so it's a time consuming process, but I think in the end it will be well worth it.
     
  14. Speed Daemon

    Speed Daemon New Member

    78
    0
    Jan 15, 2012
    That looks like a good idea. Although it's well-intentioned, having your wireless access point switching channels at will is going to break all wireless connections to it from time to time. And some wireless clients don't recover as well as others when this happens.

    If you're experiencing overcrowding of Wi-Fi APs in your area, IMHO you're better off choosing your own channel assignment and sticking with it.

    I agree with ThAbtO about using static IP. DHCP is handy for people who don't want to know anything, and for itinerant devices like laptops and other things that you use outside the home. But for a small home network it's not a lot of work to assign a static IP address so you always know the IP address of a device you're trying to access. So if name resolution and/or DHCP has problems, you can be certain that the IP is still the one you want.

    BTW, I was poking around in my wireless router and found an "Enable Bonjour" setting. You'll want that set to "yes" if you have a TiVo!
     
  15. imreolajos

    imreolajos Member

    32
    0
    Jan 27, 2005
    Eden...
    So, I'm sad to report this didn't work, either. When I came home from work today, I couldn't ping my WiFi connected Series 3 at all. The Series 3 didn't see my other TiVo, either. But interestingly enough it reported the wireless signal strength as 100% and still showed the fixed IP address it acquired from the router. So, it's not like the wireless adapter failed.

    I'm at a loss now. All my devices are on fixed IP addresses, the fixed wireless channel I chose is apparently good (still showing 100% signal strength, versus some other channels that show "only" 70-80%).

    As soon as I switched the wireless channel, I could ping the Series 3 again.

    The only thing I can think of is that my router doesn't like the wireless G adapter of my Series 3.

    I am going to run a REALLY long Ethernet cable to my Series 3 now and see if that works.
     
  16. lrhorer

    lrhorer Active Member

    6,933
    10
    Aug 31, 2003
    San...
    If the router is too far away for a wired connecton, then it is almost surely too far away for wireless, unless you are using high powered APs and / or directional antennas.

    What's "really, really long"? The limit for Ethernet over copper is 100 meters, or about 330 feet.
     
  17. imreolajos

    imreolajos Member

    32
    0
    Jan 27, 2005
    Eden...
    Okay, it's not THAT far, but my router is upstairs and the TiVo is downstairs. I was able to run a ~30ft cable straight down, and it worked flawlessly. However, this is not a permanent solution for me.

    With WiFi my TiVo is usually reporting a 90-100% signal strength, so that should be plenty.
     
  18. imreolajos

    imreolajos Member

    32
    0
    Jan 27, 2005
    Eden...
    I am not sure how that would solve the interference. There are about 5 other WiFi APs around me. If all those APs are set to auto-select channels (even if only once a day), then it doesn't matter which channel I fix on my AP, eventually it is bound to get interfered by one of my neighbors' APs. I would have to have an agreement with my neighbors about who uses what channel, right? :confused:
     
  19. Speed Daemon

    Speed Daemon New Member

    78
    0
    Jan 15, 2012
    I wouldn't be so quick to assume that many (if any at all) of your neighbors have this channel-switching "feature" and are using it.

    I've done quite a few Wi-Fi site surveys for commercial clients, and I rarely see an AP change channels. In fact, most people now know to select another of the three clear channels instead of leaving their AP on Ch.6 with the name "linksys".

    If you only have five APs in your area, you don't have a problem. Where I live, I have a dozen or more on each of the clear channels (1, 6 and 11), with another half-dozen squeezed in between. It's clear that they're more knowledgeable than the average home Wi-Fi user just a few years ago.

    As I mentioned before, it looks like channel switching is not compatible with your TiVo's Wi-Fi radio. That's the reason to stay on one channel.
     
  20. imreolajos

    imreolajos Member

    32
    0
    Jan 27, 2005
    Eden...
    My Medialink router came with the "Channel" set to "Auto-select" out-of-the-box, so it wasn't a big leap for me to assume other routers come with the same preset. But, you have a lot more experience in this than I do, so I take your word for it.

    At this point I am not even sure my router is switching channels with the setting on "Auto-select" - it may select a random channel once and stick with it.

    But it doesn't matter, because even after I switched it to use a fixed channel, my TiVo still keeps dropping off after a few hours. I am now totally convinced that it's a bug in the way my router is handling the Wireless G signal of my TiVo. Neither of our Wireless N smartphones connected to the same router ever experience any dropoff.
     

Share This Page