Welcome! Starting up..

Discussion in 'TiVo Premiere DVRs' started by pmolan, Jul 3, 2020.

  1. pmolan

    pmolan New Member

    2
    0
    Jul 2, 2020

    Advertisements

    Hi,
    I have a TiVo Premiere that was stuck on "Welcome! Starting up..". After a little research, it seems that replacing the hard drive is the first step. I obtained an image and wrote it to the "new" drive. I get it booted up and I go through the guided setup. It then tells me that it needs to do an update. I proceed with the update and now it is back to being stuck at Welcome! Starting up..
    I wrote the image to two different hard drives and tried this twice. Where should I go from here? Is this some sort of bomb like Sony did with the Dash?

    tivo1.PNG

    tivo2.PNG
     
  2. ThAbtO

    ThAbtO TiVoholic by the bay TCF Club

    12,907
    1,210
    Apr 6, 2000
    SF Bay Area
    Updates can take an hour or more. It may look like its stuck at that starting up, but you need to give it time. It can take a few self-reboots and appear to freeze following updates, but it may not be even bricked, just yet. Give it time.
     
  3. kpeters59

    kpeters59 Well-Known Member

    3,221
    670
    Jun 19, 2007
    Houston, Texas
    Kickstart 57 has been known to get a Premiere booted up when it's stuck.

    -KP
     
  4. pmolan

    pmolan New Member

    2
    0
    Jul 2, 2020
    PS gave out on me last night. I suppose that it wasn't giving the hard drive enough power to work properly. Thanks for the help.
     

Share This Page

spam firewall

Advertisements