Weird network problem - can't ping Tivo from wireless laptop

Discussion in 'TiVo Underground' started by gardavis, Jul 27, 2007.

  1. gardavis

    gardavis Member

    140
    0
    Nov 24, 2001
    Deerfield...
    This has me stumped. My home network is 192.168.0.x with x=1 for the Dlink 524 router, .2 for my always-on server (including Yac for callerid), x=8 for my Tivo and x=21 for my wireless laptop. All but the laptop are wired. There are a handful of other wired and wireless PCs.

    The problem is I can't get to TivoWeb (or ping) from my laptop or any of my wireless PCs (or PocketPC). I can get to Tivo from the wired PCs. The errors from ping are a few timeouts.

    I tried an experiment by Telneting into the Tivo and running ping to the laptop. Surprisingly, this worked! I then tried again ping from laptop to Tivo and now it worked!

    Very weird. Does this sound like an issue with the wireless router (since the wired PCs don't need to get to the router first)?

    Thanks,
    Gary Davis

    Laptop: WinXP; PCs: Vista; Server: WinServer 2003; Tivo: Sony SVR 2000 S1
     
  2. ciper

    ciper Active Member

    2,011
    1
    Nov 4, 2004
    Off hand it sounds like an ARP issue. Are the wired/wireless machines both receiving DHCP from the same place?
     
  3. gardavis

    gardavis Member

    140
    0
    Nov 24, 2001
    Deerfield...
    The wireless router hands out DHCP based on the mac addresses for the Tivo and one of the laptops. The other laptop gets a random IP from DHCP and exhibits the same behavior where ping fails but if pinged from the Tivo, it's pings back to the Tivo start working.

    I tried arp -a on the laptop while the pings failed and it showed the Tivo's ip and its mac address. I then did a -d to delete the entries followed by a ping attempt and the next arp -a showed the Tivo's IP and mac address again.

    On this laptop, I have a Virtual PC running Win Server 2003 with its own IP and it also failed the ping. After the Tivo-to-laptop ping (the real PC's IP, not the VPC) it fixed both the PC and VPC to-Tivo pings! Not sure if that is a clue.

    Thanks,
    Gary
     
  4. gardavis

    gardavis Member

    140
    0
    Nov 24, 2001
    Deerfield...
    On the laptop that is able to ping after the Tivo-to-laptop ping, hibernate and resume disables it so the ping stops working.

    Like I said...weird.

    Gary
     
  5. ciper

    ciper Active Member

    2,011
    1
    Nov 4, 2004
    Very strange...

    Would you be against installing ethereal?
     
  6. gardavis

    gardavis Member

    140
    0
    Nov 24, 2001
    Deerfield...
    This is an interesting program (now called WireShark at http://www.wireshark.org/). I installed it and it will require a bit of a learning curve. Thanks for the pointer.

    Gary
     

Share This Page