Weaknees interactive upgrade - "No CD-ROM found"

Discussion in 'TiVo Upgrade Center' started by jonesgeek, Jan 6, 2006.

  1. jonesgeek

    jonesgeek New Member

    Jan 6, 2006


    Hi, I spent the last two nights trying to add a 200GB HD to my TiVo 540040, and wanted to share a pitfall that I spent a good deal of time looking for an answer to. I'll apologize in advance in case this has been discussed before, I could find a couple of posts with the same problem, but nothing that addressed the problem.

    After I booted up with the weaknees_lba_boot_cd (It successfully booted from the CD), It searched for my CD-ROM drive 5 times, then stated "No CD-ROM found". This left me with a VERY limited shell. I couldn't ls or anything, and there were like only 2 devices in /dev (I had to get a directory listing by utilizing the auto complete function: tab twice)

    What I discovered: the first ide device was starting at hde instead of hda. This was because I had an onboard promise RAID controller, and that is getting loaded before my primary IDE controller. I spent alot of time trying to disable the RAID controller in vain, because my first IDE device was still showing up as hde after I had the RAID controller disabled (not sure why).

    Anyways, I did a little more research to try to understand the problem more, and I stumbled across the kernel parameter "ide=reverse" which will swich the primary and secondary ide channels. I decided to give it a go, and it worked perfectly!

    I think that the "mount-cdrom" script in the cdrom only checks the first four ide devices, so I am not sure if weaknees wants to address this, or add a little commentary in their documents to explain how to get around this.

    At the lilo boot prompt (where it tells you to hit enter), I had to type:
    linux ide=reverse
    then follow the weaknees interactive upgrade instructions

    I hope this is helpful to at least one other person.
  2. TechDreamer

    TechDreamer New Member

    Jan 26, 2002
    Torrance, CA
    I have a computer that does the same thing as yours, but the CD detection issue was hit or miss for me. I just kept rebooting and sometimes it would recognize the CD, but I still had to remember to start lettering all the drives at e instead of c. This swap trick will help me in the future. Thanks.
  3. DevilDogs

    DevilDogs Steeler Fan

    Dec 29, 2002
    Des Moines,...
    Wow, that really helped out a lot. I have a motherboard that has SATA and regular IDE. I tried disabling SATA, with no luck. Glad I found this. Maybe this should be put in for others to use? Raid and SATA are getting more popular. I suspect there will be others that have this same issue.

Share This Page

spam firewall