Voice not working on Roamio Pro - "Sorry, voice is not available right now. (D402)"

Discussion in 'TiVo Coffee House - TiVo Discussion' started by modnar, Nov 6, 2017.

  1. Nov 6, 2017 #1 of 68
    modnar

    modnar Active Member

    1,969
    19
    Oct 15, 2000
    Arkansas, USA
    I posted this within another thread but thought it may warrant its own thread.

    Is anyone else having issues with the voice service? I got my VOX remote today for my Roamio Pro but only get the "Sorry, voice is not available right now. (D402)" errorv when I try to use the Voice button. I'm not having network issues, and all the TiVo ports are working. A service connection worked fine. I tried restarting the TiVo twice as well.
     
  2. Nov 7, 2017 #2 of 68
    ajwees41

    ajwees41 Well-Known Member

    2,974
    142
    May 7, 2006
    Omaha,NE
    did you plug the usb dongle in?
     
  3. Nov 7, 2017 #3 of 68
    modnar

    modnar Active Member

    1,969
    19
    Oct 15, 2000
    Arkansas, USA
    Yes. The remote works fine. The voice button on the remote is what triggers the error.
     
  4. Nov 7, 2017 #4 of 68
    ajwees41

    ajwees41 Well-Known Member

    2,974
    142
    May 7, 2006
    Omaha,NE
    try new batteries did you try pairing the remote again?
     
  5. Nov 7, 2017 #5 of 68
    modnar

    modnar Active Member

    1,969
    19
    Oct 15, 2000
    Arkansas, USA
    The remote is paired fine and triggers the voice feature fine (just gets an error rather than actually getting voice data to/from TiVo).
     
  6. Nov 7, 2017 #6 of 68
    ajwees41

    ajwees41 Well-Known Member

    2,974
    142
    May 7, 2006
    Omaha,NE
    have tried calling tivo it sounds like a hardware(remote) or software issue?
     
  7. Nov 7, 2017 #7 of 68
    modnar

    modnar Active Member

    1,969
    19
    Oct 15, 2000
    Arkansas, USA
    Not yet, but I will whenever I can be in front of the TiVo at the same time they're taking calls. :)
     
  8. Nov 7, 2017 #8 of 68
    geekmedic

    geekmedic TiVo Fanatic TCF Club

    678
    48
    Apr 4, 2003
    Atlanta, GA USA
    This sounds similar to the problem being experienced by the Minis.
     
  9. Nov 7, 2017 #9 of 68
    modnar

    modnar Active Member

    1,969
    19
    Oct 15, 2000
    Arkansas, USA
    Yeah, except it's not fixed by a reboot or UI restart.
     
  10. smarthur

    smarthur New Member

    8
    0
    Apr 15, 2012
    San Jose, CA
  11. modnar

    modnar Active Member

    1,969
    19
    Oct 15, 2000
    Arkansas, USA
    I tried a reset and confirmed the remote was connected via Bluetooth. If it wasn't connected via Bluetooth, it wouldn't even some the microphone icon.
     
  12. modnar

    modnar Active Member

    1,969
    19
    Oct 15, 2000
    Arkansas, USA
    I called TiVo support. They confirmed much of what I've already tried and had me force another service connection. The issue was still there, so the tech said they would give it high prioritization for someone to look at tomorrow. I think. They also kept saying the case would be set as "waiting for customer" and for me to call back in 24 hours if the issue persisted. I indicated that they shouldn't be waiting on me for anything, and I think the tech was saying the case would still get attention tomorrow.

    The tech also seemed to indicate this was a known issue being researched, but I'm not sure if they meant that my issue was known since I have now called or if it is a wider issue.

    Hopefully someone at TiVo will still be looking at this tomorrow.
     
  13. modnar

    modnar Active Member

    1,969
    19
    Oct 15, 2000
    Arkansas, USA
    I'm still not able to use Voice. I called support a couple days ago and haven't heard anything after the initial, basic troubleshooting.
     
  14. Diana Collins

    Diana Collins Well-Known Member TCF Club

    3,328
    794
    Aug 21, 2002
    New York...
    There are issues pairing a Vox Remote with a A92 Mini, but I have voice control working with one of our Roamios. The D402 error when you press the Voice button means your TiVo has not attached to voice processing server (voice commands are not processed locally, they go to a cloud server for processing, like Siri or Alexa). That can happen because of an authorization issue for that feature on your TiVo or a network issue that is preventing the login to the voice server. My bet is on the former. I'd call back and let them know it is still not working. This had been reported early in the roll-out but I had heard it had been resolved.
     
    ClearToLand likes this.
  15. modnar

    modnar Active Member

    1,969
    19
    Oct 15, 2000
    Arkansas, USA
    Thanks. My uneducated hunch was leaning to an authorization issue as well since I don't have any network issues (ports all test fine on TiVo, etc.).

    I haven't been able to call back while I'm in front of the TiVo during TiVo support hours yet but will probably call tomorrow. I'm really hoping the right person will see this and be able to get the details to someone who can resolve it. I kind of dread having to go through support's scripts.
     
    Last edited: Nov 9, 2017
  16. steelersruleman

    steelersruleman Member

    47
    11
    Aug 29, 2014
    NW Pennsylvania
    My remote paired correctly to my tivo roamio(used it on a Tivo Mini first). The VOICE Commandworked just fine for 24 hours, then simply stopped working about 1 hour ago.

    Definitely a TIVO issue, as the remote is still paired correctly with my main Roamio(light flashing yellow, and VOICE MICROPHONE symbol comes up when pressed, just does not work.).

    And D402 Error comes up now, stating it does not work right now. Have put Roamio in Standby, and turned back on, but VOICE does not work. Hopefully this will be fixed by TIVO soon. Ridiculous.
     
  17. Tanic

    Tanic Member

    30
    0
    Jun 22, 2004
    My Vox remote was working fine with Roamio until today. Now getting D402 error.
     
  18. kbelloun

    kbelloun New Member

    1
    0
    Apr 18, 2016
    Same here with my Bolt... worked last night, getting voice is unavailable d402 today
     
  19. modnar

    modnar Active Member

    1,969
    19
    Oct 15, 2000
    Arkansas, USA
    Perhaps there's a bigger outage today with the voice service.
     
  20. TIVO_GUY_HERE

    TIVO_GUY_HERE I miss the ocean

    7,128
    288
    Jul 10, 2000
    Dallas Texas
    Just adding same with my Bolt. Had some friends over wanting to show the new voice commands (They are thinking of getting it). It didn't go over well. :) I told em it was a fluke, and usually works pretty good
     

Share This Page