Video glitching

Discussion in 'TiVo Stream 4K' started by pldoolittle, Jul 15, 2020.

  1. pldoolittle

    pldoolittle Tivo'ing since 2001

    301
    45
    May 2, 2002

    Advertisements

    Anyone else having random video glitches? Horizontal lines. Bottom Half the screen flashing a solid color? The latter is most common and alternates between beige and black.
     
  2. WOT Time

    WOT Time New Member

    7
    1
    Jun 6, 2020
    I get occasional glitches where the screen image just flicks "off" and back on again almost instantly - no colours or sections, the whole screen.
     
  3. BillyClyde

    BillyClyde Active Member

    375
    183
    Mar 3, 2017
    Sounds like your HDMI Cable isn’t up to snuff. The TS4K outputs 4K HDR all the time so needs a certified high bandwidth cable. It has to carry like 18Gbps and poor cables can cause what you are seeing. Is your Stream connected directly or thru a receiver or soundbar?
     
  4. pldoolittle

    pldoolittle Tivo'ing since 2001

    301
    45
    May 2, 2002
    The stream is plugged into an HDMI switchbox. But so is the TiVo and firestick no issues. And I've had this setup for months, no issues. I'll swap ports and see if it moves.
     
  5. BillyClyde

    BillyClyde Active Member

    375
    183
    Mar 3, 2017

    Advertisements

    Is the TiVo or Firestick that’s plugged in using 4K at 60p, like the Stream 4K does?

    I would try plugging the Stream directly into your display and see what happens.
     
  6. Gavroche

    Gavroche Member

    422
    5
    May 26, 2007
    State of...
    That's really odd... I had the video flashing on/off problem frequently when I had the Tivo Stream plugged in directly to my Samsung TV, but once I moved it to my Pioneer Receiver the issue went away. Weird... I eventually moved it to my TCL TV (Plugged directly in) and didn't see the issue there at all. I'm not sure why my Samsung TV didn't like it.
     

Share This Page

spam firewall

Advertisements