VC-1 playback? Not listed in specs

Discussion in 'TiVo Stream 4K' started by cybergrimes, May 9, 2020.

Tags:
  1. cybergrimes

    cybergrimes Legend

    367
    101
    Jun 14, 2015
    Minnesota
    Hey, could anyone who uses Emby, Plex or Kodi for disc rips check if VC-1 is working? I only just now noticed it's not included in the video decoding section on the product page. Someone on Reddit had speculated this was using the S905Y2 chipset, which afaik should be capable of decoding. If anyone can check that would be great.

    Thanks
     
  2. cybergrimes

    cybergrimes Legend

    367
    101
    Jun 14, 2015
    Minnesota
    Replying to myself in case anyone else wants to know. VC-1 codec playback is not supported. Video output is garbage.
     
    Last edited: May 11, 2020
    foghorn2 likes this.
  3. aaronwt

    aaronwt UHD Addict

    23,138
    1,095
    Jan 31, 2002
    Northern...
    If it doesn't work it's probably because the Amlogic S905Y2 SoC, the STream 4K uses, doesn't support it.
     
  4. aaronwt

    aaronwt UHD Addict

    23,138
    1,095
    Jan 31, 2002
    Northern...
    I just tried my 2K MKV of 10,000 BC which uses VC-1. The native Plex is direct playing it back but it's having issues stating up again once you stop playback.

    I just tried Plex inside of Kodi. That is playing it back but it's skipping a bunch of frames. So it seems like it's decoding the VC-1 in software, which would cause those issues.
    But VC-1 is an old codec. Is it even used with anything any more? But that would explain if it's not supported in the hardware. Like HEVC is.
     
  5. cybergrimes

    cybergrimes Legend

    367
    101
    Jun 14, 2015
    Minnesota
    Thanks for the info. Now that it's on secondary TV I'm fine with a transcode from the server on the chance I watch a VC-1 movie.
    Again, spoiled by the Shield
     

Share This Page