Using the 3.0 (Un)support for broadband

Discussion in 'TiVo Underground' started by gleffler, Jun 1, 2002.

  1. Knouse

    Knouse New Member

    64
    0
    Jun 20, 2001
    Tomball, TX

    Advertisements

    My setup: An unmodified TiVo Series routing through a Windows XP Pro box routing through a Linksys 4-port Cable/DSL Router (BEFSR41) running firmware 1.42.6. XP gets it's IP address via DHCP from the router.

    I followed Geffler's and Otto's instructions with these exceptions:

    I used the TiVo Null Modem cable sold by 9th Tee <http://9thtee.com/tivoupgrades.htm>. No gender changers or null modem adapters are needed as the cable the right connectors -- a 1/8 inch stero plug for my TiVo and a D9 jack for my XP box's serial port.

    TIVONMCABLE TiVo Null Modem Serial Cable - 10' Long $7.95
    TIVONMCABLE20 TiVo Null Modem Serial Cable - 20' Long $9.95

    Like Spire I had to allow VPN connections, but I didn't have to turn on SPI Didn't have to open any ports.

    I did several test calls and every other succeeded/failed. I'd just had a modem call before adding the PPP connection so haven't been through a regular call yet.
     
  2. jonb

    jonb New Member

    39
    0
    Jun 1, 2001
    I am confused. Why do you need BOTH ethernet(which the turbonet/BEFSR41 uses AND serial(null modem cable)? Can't you do everything much easier and more reliably with ONLY the turbonet/BEFSR41 setup?
     
  3. c3

    c3 TiVoholic

    3,070
    0
    Sep 8, 2000
    Silicon...
    I don't think that person has a TurboNet, just using serial.
     
  4. Knouse

    Knouse New Member

    64
    0
    Jun 20, 2001
    Tomball, TX
    My TiVo is unmodified. It does not have a TurboNET Ethernet adapter. Hence the need to run serial to an XP box which routes me to my home intranet. Here's the configuration:

    TiVo serial port -- serial cable -- XP box serial port / XP box Ethernet port -- Ethernet cable -- Linksys router

    If I'd added a TurboNET card I would be able to go directly to the router, skipping the XP box. This would be the configuration:

    TiVo TurboNET port -- Ethernet cable -- Linksys router -- Ethernet cable -- Cable modem

    The cool thing about 3.0, and Geffler's instructions, is it allows me download program info via my cable modem rather than the phone and I don't have to buy an TurboNET card or open my TiVo. I do have to leave my XP box on but that stays on all the time anyway.
     
  5. ksv666

    ksv666 New Member

    29
    0
    Jun 22, 2002
    San Jose,...

    Advertisements

    Hi,

    I've been reading through a lot of posts on Tivonet, and I want to make sure that i have all the correct data. Here's what I have and what I have/have done:

    Upgraded stand alone Tivo
    Upgraded and blessed drives (2 - 120GB drives)
    v3.0 (newly upgraded)
    Tivonet
    I used MFS tools to back up my machine originally
    I installed the "kazymyr" suite (boot disk to enable Tivonet and ran the tivonet script :-( )
    TivoWeb (this is really awesome)

    So, I can telnet to my Tivo, browse it, but I can't dial out. It reports back a failure when it tries to dial. I inserted the ",#401" (no quotes) in the prefix, but it still fails. Do i really have to go in and edit the "/etc/rc.d/rc.arch" file? Should I copy over the files that this other post listed--> see: "tivonet does not work after using Kazymyr's Bootable Utility CD on 3.0"

    Any guidance would be appreciated.

    -Kirk
     
  6. rchaynesjr

    rchaynesjr New Member

    1
    0
    Jun 23, 2002
    So yesterday I spent a few hours connecting my TiVo to my computer using the null modem option. Eventually I got it to work, although it is a tad unreliable. But it's still better than lugging the TiVo to my parents' house once a week.

    This morning my roommate turned on the TV, and just as I was about to tell him that he couldn't use the TiVo remote to change the channels on the cable box (serial sitting unplugged next to the TV and haven't had a chance to hook up the IR yet), he entered the channel number he wanted. LO AND BEHOLD THE TIVO CHANGED THE CHANNEL ANYWAY!!!! I couldn't believe what I was seeing. I grabbed the remote from him and began changing channel after channel. All that is going from my cable box to the TiVo is the three RCA cables. And I'm sure that the remote isn't changing the cable box directly, as there is still the standard pause between the time that the TiVo registers the numbers and the channel changes on the cable box. I'm thrilled beyond words, but am confused as all hell. Anybody know what's up here?

    Rob
     
  7. c3

    c3 TiVoholic

    3,070
    0
    Sep 8, 2000
    Silicon...
    I don't use it myself, but I believe the TiVo is transmitting infrared signal to the cable box, through the "eye" on the front panel.
     
  8. Otto

    Otto New Member

    1,028
    0
    Mar 25, 2000
    Yeah, behind the "eye" is a built in, front facing, IR blaster. It sends the signal which rebounds off your furniture and gets seen by the cable box. It's highly unreliable. Hook up the little wired IR blaster and it'll work more reliably.

    Oh, and unless you have a newer cable box that can grok the serial connection, you've been using it all the time anyway. Most cable boxes don't do serial channel changing. The few that do are very new-ish.
     
  9. draHeiD

    draHeiD New Member

    1
    0
    Jun 24, 2002
    I have searched this thread looking for an answer to this, but have not seen anyone address it yet.

    I have installed TurboNet and configured it with the ,#401 and everything works great.

    One of the things I remember reading on my notice that the 800 service was going to be terminated, was that there will be changes to how the data is delivered in an effort to reduce the length of calls.

    My question (confusion, perhaps) is this:

    Do I need to change the Dial-In number from 'TiVo's 800 Number' to a local/direct number in for the new features to work?

    Thanks for the great thread and forums in general.
     
  10. gleffler

    gleffler This one goes to 11

    567
    0
    Dec 28, 2000
    No, what the dial-up number is doesn't matter.

    /gleffler
     
  11. bonscott87

    bonscott87 Done.

    3,105
    126
    Oct 3, 2000
    I don't post much in the Underground so hello everyone! It looks like soon I will finally be able to say goodbye to my phone line now with 3.0. Here is my plan, tell me if you think it won't work.

    I have a cable modem connection with Netgear router and 2 computers currently. I plan to purchase a new laptop soon with Win 2k (perferred) or XP. I'll be putting in a wireless access point on my router to use the WiFi connection of the laptop.

    What I've thought about doing is setting up the laptop for the Serial PPP connection. Once a week I take the laptop to the Tivo. I connect up the serial cable of my stand alone to the null modem cable into the laptop. Change the dialing prefix and let it dial out using the laptops wireless connection. After it's done it's thing, I can reconnect the serial cable to the DirecTv receiver.

    Once I get 3.0 on my DirecTivo, I can do the same thing once a month or so.

    Sound reasonable?
     
  12. FlippedBit

    FlippedBit New Member

    176
    0
    Dec 25, 2001
    Mountain...
    Got it working! I had a Netgear EA101 USB adapter lying around but unfortunately it didn't work with my AT&Tivo. Not that it should have worked since it wasn't on the compatibility list. So I order the 3COM 3C460B from tigerdirect and bingo!
     
  13. tarkus42

    tarkus42 New Member

    1
    0
    Jun 25, 2002
    I just tried setting up ppp over serial for the first time on Windows XP Proffesional following Otto's instructions and I'm experiencing a problem that I don't think has been addressed. I tried the troubleshooting method described by Otto using HyperTerminal. The serial connection tests OK but when I try a test call with the Tivo, on the third step the message "Failed. Service not answering" is returned. Is this a problem on my end or theirs?

    Also, it should be noted that I live in an area that requires an area code to be dialed for all calls. I previously had my area code set as the dialing prefix. This was replaced by the ",#211" prefix. Could this have anything to do with the problem or is the dial-in number irrelevant?

    Setup: Serial port connected to PC running Windows XP Proffesional> Linksys BEFSR41 ver.2 Router> Motorola Surfboard Cable Modem

    Any suggestions would be appreciated. Thank you.
     
  14. Knouse

    Knouse New Member

    64
    0
    Jun 20, 2001
    Tomball, TX
    When I first set up the PPP link from my unmodified Series I every other call would fail. After a week it wouldn't connect at all. I didn't try rebooting the XP machine servicing the connection. Guess I ought to try that but since the modem works ok and it's never been a bother making telephone calls I didn't bother.

    I think I'll probably get a TurboNet board to play around with when I get back from vacation in late July.
     
  15. jakegrove

    jakegrove New Member

    5
    0
    Jun 30, 2002
    With Tivo 2.5:
    SA series 1 Phillips tivo
    Windows2000
    Lynksys 4 port router
    TurboNET
    Installed perfectly: had ping, telnet, ftp, and call-in through internet
    Installed WebTivo with little problems.

    With Tivo 3.0
    Changed the dialing prefix to ",#401" and now have the call-in.

    NO Ping, telnet, ftp

    I tried to use "Tivo¬ô 3.0 SCRIPT FOR ENABLING TELNET ACCESS" @ http://www.jsprod.net/tivo30script.htm

    It installed fine, but after putting the drive back in still no ping etc.

    I assume that the router is okay; it was working with the Tivo before. I set the password on the router when I bought it a year ago and forgot it the next day. So I can't 'browse' the settings first hand.

    With the Tivo doing it's test-call without a problem, I have to assume it's making it through the router without a problem.

    This is driving me nuts! I was just about to install some other software when I discovered I was "Upgraded"

    I just had a thought:
    When I installed the TurboNET with the software from 9thTee, the software asked for an IP address I wanted the Tivo to be. I set the IP address to 192.168.1.200, and that is the address I'm trying to Ping to. Because of the upgrade and the new driver, I'm guessing that my set IP is no longer valid. Am I right?

    I'm going to crack open the case again and see if there's an IP written on the card, and then try pinging to it.

    Thanks for any help or suggestions.

    Jake Grove:confused:
     
  16. Robs67

    Robs67 New Member

    196
    0
    Dec 26, 2001
    Templeton, MA
    Hopefully someone can help me.

    I wanted to try out the Ethernet "stuff" and have had no luck.

    My setup:
    ATTiVo running 3.0
    Linksys USBTX100
    Linksys BEFSR41 Router

    I have DHCP enabled on the router. The router indicates a connection to the TiVo with its little lights. Put ,#401 as a dialing prefix. Rebooted both TiVo and router a few different times. The test call always fails upon trying to connect.

    Thanks for any help.

    -Robert
     
  17. Jul 1, 2002 #157 of 375
    gardavis

    gardavis Member

    144
    1
    Nov 24, 2001
    Deerfield...
    I recently upgraded my A drive from 30 to 120 and my TurboNet stopped working. The link light on the Tivo was solid instead of slowly blinking.

    I started moving the cable around, maybe a loose connection and the network started working again.

    Actually, it was not a loose connection. I had pushed the cable bertween the 2 hard drives (snug fit) and it did not seem to like that location. I pulled it out and just let it drape over the components and the link light started blinking again. The ping command on my PC (that I left running) started getting responses and all was back to normal.
     
  18. Jul 1, 2002 #158 of 375
    jakegrove

    jakegrove New Member

    5
    0
    Jun 30, 2002
    ----------------------------------------------------------------------------------------
    I just had a thought:
    When I installed the TurboNET with the software from 9thTee, the software asked for an IP address I wanted the Tivo to be. I set the IP address to 192.168.1.200, and that is the address I'm trying to Ping to. Because of the upgrade and the new driver, I'm guessing that my set IP is no longer valid. Am I right?
    ----------------------------------------------------------------------------------------

    FYI to anyone that's reading this: I was right. I read this in another thread. The old (2.5) IP is gone. The IP for the Tivo is dynamic now; assigned by the DHCP, weather it comes from the router or other.

    My problem was that I lost the password I assigned to my linksys, and couldn't check to see what IP was assigned to the Tivo.

    I went to the Linksys website (again) and finally found out how to change the password. Just hold the reset button in for 5 seconds. ALL the settings will reset to the default.

    I got in and found the IP for the Tivo. I have a BASH prompt now!

    I have ping, and telnet. BUT no ftp. I looked in the bin folder and found that the ftp proggy was gone.

    Anyone know how I can get ftp working again? Linix hurts my head. I've been able to figure out just about every other OS I've come across over the last 20 years, but I just want to put my head through the screen after about ten hours of working with it.

    BTW: for some reason telnet is real flaky now: lots of dropped characters.
     
  19. Jul 1, 2002 #159 of 375
    jakegrove

    jakegrove New Member

    5
    0
    Jun 30, 2002
    Update:

    I have FTP now!

    I downloaded NetTerm and telnet works great now. I found a copy of tivoftpd in the old Tivo-bin folder and "cp /tivo-bin/tivoftpd /bin/tivoftpd" (I don't know if I had to do this)

    I then set r/W "mount -o rw,remount /"

    then "chmod +x tivoftpd" to add execute permissions

    Then ran it with "tivoftpd"

    And I was in.


    I have no ideal how much of this I had to do. but the ftp is working now.

    I guess I have to add "/bin/tivoftpd" to the end of my rc.sysinit. is this right?

    Thx, Jake
     
  20. Jul 2, 2002 #160 of 375
    MAP

    MAP New Member

    2
    0
    Jul 2, 2002
    Vermont, USA
    Any suggestions on recovering from this mistake? After my SA TiVo
    updated itself, I didn't notice for a while, until I got the notice that
    it hadn't gotten new data in a while. Unfortunately that was late at
    night, and I didn't pay enough attention to realize that I might not
    want to just do the same thing I've done a dozen times before.

    Oops. :( So, what do I do now to recover?

    This is a stand alone Philips unit with the TiVoNet from 9thTee. It does
    still have the older software on the other partition, which would talk
    over the net, but one note I saw suggested that going back was not
    a good idea. I can telnet into it over the net, and I also have
    a serial console connected. It just won't make "phone calls" using
    The net.
     

Share This Page

spam firewall

Advertisements