Using the 3.0 (Un)support for broadband

Discussion in 'TiVo Underground' started by gleffler, Jun 1, 2002.

  1. stormsweeper

    stormsweeper How *you* doin'?

    424
    0
    Nov 27, 2001
    NYC, USA

    Advertisements

    Possibly. But this is a fresh install of Win2k Pro, updated w/ SP2. The hardware isn't even all that flaky - Celeron 466 on a 440ZX Intel mobo.

    The route command that bombs is

    Code:
    route add 192.168.251.102 mask 255.255.255.255 192.168.251.101
    
    which should make the route, correct? but it chokes on the netmask. I've tried specifying the interface, too, but that gives a different error.

    my Linksys router shows the leases for .101 and .102, and ipconfig shows the windows side of the ppp connection as having .101

    It only seems to happen the first time the tivo connects to the win2k box after a Win2k boot. *shrug*
     
  2. stormsweeper

    stormsweeper How *you* doin'?

    424
    0
    Nov 27, 2001
    NYC, USA
    http://www.cnet.com/Resources/Info/Glossary/Terms/baud.html

    So even my pedantry is incorrect, as a serial line won't use baud at all.
     
  3. gleffler

    gleffler This one goes to 11

    567
    0
    Dec 28, 2000
    baud != bps

    /gleffler
     
  4. Saturn

    Saturn Lord of the Rings

    12,725
    181
    Apr 10, 2001
    Your route command looks ok to me. ::shrugs::

    Maybe it is something quirky with Win2k's PPP. I only use NT 4.0's, but I've done a lot of route manipulation with my 2k box (cuz the cable co sticks the different computers on different subnets, despite being connected to the same switch and cable modem).
     
  5. Kevin

    Kevin New Member

    8
    0
    Apr 23, 2002
    Central Florida

    Advertisements

    I understand that you can get your daily calls on a Series 2 to go over broadband. I'm wondering if I can get the initial setup call to go over broadband as well?

    I'm not an owner (YET) of a TiVO box and I have no phone line at home. Can I get a new Series 2, bring it home, set it up with my DSL Hub/Switch, configure the calls to go out with ,401 and make the setup call over the broadband?

    Thanks in advance for your help.
    Kevin
     
  6. baadpuppy

    baadpuppy New Member

    24
    0
    Dec 9, 2001
    Those with the "proxy problem" might want to check out this thread:

    http://www.tivocommunity.com/tivo-vb/showthread.php?s=&threadid=62830

    That thread references the original thread where we could modify the tcl doing the http posts to "work around" the problem. However, with 3.0 having the tcl gone, there's no easy solution yet. Wish TiVo had managed to get that one tiny tiny change into their new code.
     
  7. stormsweeper

    stormsweeper How *you* doin'?

    424
    0
    Nov 27, 2001
    NYC, USA
    Probably not, for now. It will likely be awhile before Series2 units ship w/ the 3.0 software.
     
  8. bwiley

    bwiley New Member

    6
    0
    May 15, 2002
    I recently received the 3.0 update and my serial communications have ceased as expected.

    I have tried to us the (un)supported ppp feature ,#219 to have the Tivo communicate over the serial port with limited (very limited) success.

    When I tell the Tivo to test this setting, my null modem adapter does indicate it is trying to communicate ("answering") but then it just hangs up again.

    Part of my modem log says:

    Interpreted response: connect
    Answering the call
    Send: Hello
    Conection established @ 19200bps
    Error Control Off-Unknown
    Data Compression Off-Unknown
    Hanging up Modem
    Hardware hangup-lowering DTR
    Session Statistics:
    Reads: 396 bytes
    Writes: 48 bytes
    Modem closed

    How can I get the Tivo to realize it is connected and start communicating or get my Windows 98 null modem to realize Tivo is connected and start communicating?
     
  9. stormsweeper

    stormsweeper How *you* doin'?

    424
    0
    Nov 27, 2001
    NYC, USA
    Try forcing a full call. That looks about right for a test call.
     
  10. bwiley

    bwiley New Member

    6
    0
    May 15, 2002
    I would like to continue and try forcing a call, but it does not let me go past this screen because when I test the connection, it says service unavailable and will not allow me to go past this point.

    The only way it allows me to get off this screen is to remove the updates that were just entered.
     
  11. TxPres

    TxPres Member

    53
    0
    Nov 29, 2001
    Central Texas
    I have been using tivnet for some time. Worked great. Got the 3.0 on Monday. Added the dialing prefix and the unit made test call fine. Made successful daily call Tuesday and downloaded guide data.

    Then, failed Wednesday daily call. (Not sure what the message was).

    Tried test call. Successful !!!

    Forced daily call.
    First time failed getting Accout Status.

    Second time got past that and begin downloading. After 3 min of downloading failed due to Call interupted.

    Have tried several times. Always fails. Sometimes fails getting Account Status and somtimes shows Call Interupted.

    I can look at the logs using the backdoor code but not sure which log to look at or what to look for. I think the unit is connecting to the TiVo servers but not sure why it is having problems.

    Anyone have any ideas what is going on?

    TxPres
     
  12. timbck2

    timbck2 New Member

    8
    0
    Mar 1, 2000
    Santa Fe, NM
    I have an upgraded Philips Series 1 SA with a dead modem. I had PPP over serial working reliably at 115200 with 2.5.1. After getting the 3.0 update (and of course losing my telnet ability) and putting ,#211 in the dialing prefix, I was able to get TiVo to "dial" out twice -- first a successful test call, then a successful daily call. But since that first daily call about a week ago I've only had one other successful call (in process as I type now after several tries and restarting my TiVo) -- most attempts fail with "Service unavailable".

    Any idea what's going on? Should I try a slower speed (such as 57600), or is that a red herring? And if I do, am I correct in saying I should change the dialing prefix to ,#257?

    Thanks.

    p.s. In case it matters, my "host" machine is RedHat Linux 7.2, which is running NAT and getting its broadband from a Win2K box with a cable modem (ICS is running on that box). Yeah, I know it's pretty convoluted, but it was working before!
     
  13. Otto

    Otto New Member

    1,028
    0
    Mar 25, 2000
    timbck2: Yeah, I'd try a lower port speed. And ,#257 is correct.
     
  14. bwiley

    bwiley New Member

    6
    0
    May 15, 2002
    Does #3 add a username and password somewhere along the line? Or is it that #2 is just a direct serial connect right out of the gate and #3 does some form of script first?

    If #3 does a script, is there any way to edit that script and add a username/password?
     
  15. tsawyer

    tsawyer New Member

    3
    0
    Feb 22, 2002
    I've had mine fail on Getting Acct Status as well last night. It took four tries in a row, but on the fourth try, the entire call was successful. Nothing changed between each try.

    (This is with hdr112, v3.0, turbonet)
     
  16. richtuck

    richtuck New Member

    2
    0
    Jun 13, 2002
    I am seeing the same problems that TxPres and tsawyer have seen.

    I use a TurboNet that worked great before v3.0 came out. Since then I have changed the dialing prefix and the test call works fine.

    But then, everytime I tried a daily call for the first few hours I got the "call interupted" message. The last few times that I tired I started getting the "failed getting account status message."

    I have the daily call at least 10 times now and cannot get it to complete.

    Could the server be extremeley busy due to the v3.0 rollout? Has anyone else seen this problem 'fix itself' like tsawyer has seen?

    Thanks in advance.
    Rich
     
  17. gleffler

    gleffler This one goes to 11

    567
    0
    Dec 28, 2000
  18. Spire

    Spire Fallen

    5,031
    6
    Jun 6, 2001
    Everywhere...
    OK, so I've managed to get PPP-over-serial working under 3.0 in conjunction with my Windows XP box. DHCP wasn't working reliably for me, so it's set up with a fixed IP address (forced range 192.168.1.105 to .106). The unit is able to call in over the serial cable with no problems.

    Now that there is a new beta version of TiVoWeb that kinda works with 3.0, I figured I'd try to get that working to see what it's all about. I've never installed TiVoWeb before, so this is all new to me.

    I downloaded and installed the TiVoWeb package, put a line to start it in rc.sysinit, and crossed my fingers.

    The results: TiVoWeb works if I point my Web browser to http:/192.168.1.106, (not .105 - why?), but only while the unit is making a Test Call or Daily Call. As soon as the call ends, the Web connection dies.

    OK, this makes sense, I figure, since the PPP connection is enabled only during calls. Question is, how do I change this behavior and make the PPP connection permanent? I tried reading up on various FAQs on the subject, but they are all written for pre-3.0 versions of the TiVo software, and I don't want to risk breaking anything by installing something that might interfere with the nifty ",#211" support in 3.0.

    Would some kind soul be willing to post simple step-by-step instructions for the best way to make 3.0's PPP connection permanent, so that TiVoWeb can run at any time, and ",#211" will still work? I suspect that as the 3.0-compatible TiVoWeb package matures, demand for these instructions will increase dramatically.
     
  19. Laserfan

    Laserfan Member

    440
    4
    Apr 25, 2000
    USA
    Bought a fully assembled TivoNet card when it first came out, then sat on it (what's it been, a year?). Since I was upgraded to 3.0 this week, thought I'd finally give it a try:
    - Set-up my Linksys router to give out 1 dhcp address.
    - Install the TivoNet board(s), plug in the Tivo.
    - Route the network cable.
    - Plug into Linky and get a green Link light.
    - Run Angry IP Scanner. No joy. No can find a Tivo at the IP I chose.
    - Try ,#401 and find Tivo wants to test the change; no connection yet!
    - Restart the Tivo.
    - Run Angry Scanner again; hello IP! Pings beautifully.
    - Open Hosts file and enter 'Tivo' so its name appears in Angry.
    - Try ,#401 again; Test Call following is good! "Resetting clock"!
    - Try a Daily Call; get the usual prompts except:
    - While downloading sez "Phone not in use"
    - Pick-up telephone; modem not active nor is amber LED lit. This is Good.
    - Downloading, downloading,downloading geez this is taking a long time.
    - Screen finally goes into LiveTV but I'm eating dinner.
    - Ended w/"Call interrupted"; not successful.
    - Tivo tries again on its own a few minutes later, this time it works!

    Amazing. I have a networked Tivo without taking my drive(s) out. Very happy here!
     
  20. Otto

    Otto New Member

    1,028
    0
    Mar 25, 2000
    Spire: basically, you setup PPP the same as previous to 3.0, then edit rc.arch to have the call use ppp0 instead of eth0. Then you use ,#401 to make the call. You can't do always on ppp with ,#2xx.
     

Share This Page

spam firewall

Advertisements