USB C - what works and what doesn't

Discussion in 'TiVo Stream 4K' started by pbb_memphis, May 13, 2020.

  1. XRaiderV17

    XRaiderV17 expert wingnut

    31
    2
    Jan 15, 2021
    ..I'm lost...

    Advertisements

    what power supply works best with the usb hub?
     
  2. Ernie Salazar

    Ernie Salazar New Member

    17
    1
    Jun 6, 2020
    My $0.02.

    My setup is a little different. I have all my gear in a "Media" closet (really, top shelf of a coat closet) including the T4KS. It is connected to an 8x8 HDMI matrix switch so it can be watched in any room in the house. So, I want to control the Tivo with all of the URC Remotes (Complete Control Automation | URC Automation), one in each room.

    I have all kinds of adapters, connections, hubs, etc. so I tried many different combinations. The goal was to use an IR Emitter to control the T4KS and Ethernet so I can avoid WiFi.

    I ended up using these:

    Trendnet USB Ethernet: https://www.amazon.com/gp/product/B00FFJ0RKE/
    GZZ USB C Hub: https://www.amazon.com/gp/product/B07GQ9GR41/
    FLIRC IR Receiver: Flirc USB (they sell it on Ebay with a "Make Offer" option if you want to save a few bucks)

    The T4KS is plugged into one of the inputs in the HDMI Switch. The GZZ is plugged into the USB C Port of the Tivo. The FLIRC and Trendnet plug into the GZZ hub. For power, I am using a power strip that has 2.4 amp usb ports built in connected via the Micro USB on the T4KS. With that, I have the T4KS on Ethernet and controllable via my RF-To-IR remotes. Any room in the house can watch and control it.

    One thing I could not get to work with any of the three hubs I have was USB C Power Delivery (PD). I could power the Tivo via a USB C power supply if it was directly plugged in to its port. But I could not plug into a hub's PD input and then plug the hub into the Tivo for power. Guess it simply will not pass it.

    Also, two of the usb c hubs I have have built in ethernet but neither were recognized.

    So, a little messy with all of the wires but everything works very well.

    Ernie
     
    Last edited: Jan 23, 2021
  3. XRaiderV17

    XRaiderV17 expert wingnut

    31
    2
    Jan 15, 2021
    ..I'm lost...
    I think I noticed something in the settings regarding usb modes..lemme go fire my tivo up and check.

    edit: its in developer options under the networking header for some odd reason. mine's defaulted to charging. maybe that could be useful?
     
  4. Ernie Salazar

    Ernie Salazar New Member

    17
    1
    Jun 6, 2020
    I will try that next time I am working in the closet. I am not sure it will make a difference since I would not think a software setting for affect a cold boot but its worth a shot. Thanks!
     
  5. XRaiderV17

    XRaiderV17 expert wingnut

    31
    2
    Jan 15, 2021
    ..I'm lost...

    Advertisements

    bear in mind..I'm just a fellow user, so either it'll do something or it'll do a whole lot of nothing.
     
  6. OldCableGuy

    OldCableGuy New Member

    4
    2
    Jan 25, 2021
    I have no idea what I am doing but here it goes....

    Got the T4KS because the Edge no longer supported the HBO app. So I got two T4KSs for the house
    WiFi only connection in two spots, 1 where the coverage is sparce and one where it is very good.
    Always interested in using ethernet vs WiFi for connectivity.
    I could NOT get the ethernet connection to work after looking a videos and researching what other people were doing.
    Going through various network connections I found a Trendnet USB-A ethernet connection laying around (model TU2-ET100, white) tried it with a USB-A to USB-c connection and what do you know? Ethernet connectivity with the ol' T4KS.
    Checked my speed and honestly, not all that great versus WiFi despite the ethernet connection. So I substituted the Trendnet with a QGeeM USB-c ethernet connection and the speeds were ripping right up until the T4KS dongle crashed with the QGeeM ethernet connection. Could not get the T4KS to work with anything other than the Trendnet or the UGreen ethernet connection referenced in earlier posts. Again, the UGreen did not give me speeds all that faster than WiFi and you need to by a microUSB-b to USB-c adapter.
    So it is what is it.
    I will be using a USB-c to 5 in 1 Hub Model #V7UC3U-HUB-BLK to connect my Trendnet USB-A ethernet connection along with a Sandisk memory stick and we'll see how it goes.
     
    Last edited: Jan 28, 2021
  7. Feb 6, 2021 #227 of 231
    spitzcor

    spitzcor New Member

    5
    0
    Mar 12, 2005
    I'm tempted to try out Monoprice Consul Series USB-C Gigabit Ethernet Adapter with USB 3.0, SD/MicroSD Reader, USB-C 100W PD 3.0 - Monoprice.com. This model is appealing because it has Gigabit Ethernet, USB 3.0 Type A, USB-C w/Power Delivery, SD/micro SD, ....and nothing else that I don't need (like HDMI or any of the other things in in those 11-in-one type adapters). By chance has anyone tried it?

    Of course, it'd be ideal if the USB PD passthrough worked to power the T4KS, but I'd be OK if it didn't. I think I've seen other posts in this forum saying that the microUSB port was still needed to power up. However, I'd hope that I could use the Ethernet and SD/micro SD reader without external power in that case.
     
  8. Feb 9, 2021 #228 of 231
    RandyRJ

    RandyRJ New Member

    1
    0
    Feb 9, 2021
    I wish I had seen this thread a few weeks ago. I got the newer version of the Ugreen 1Gb USB adapter
    https://www.amazon.com/gp/product/B07MK6DJ6M/ref=ppx_yo_dt_b_asin_title_o03_s00?ie=UTF8&psc=1
    and I had to buy a new Ugreen OTG cable
    https://www.amazon.com/gp/product/B072V9CNTK/ref=ppx_yo_dt_b_asin_title_o09_s00?ie=UTF8&psc=1
    because the one I already had (Anker USB-C to USB A 3.1) didn't work.
    Speed tests with my current setup maxed out at 90Mbps down and 240Mbps up.
    I'm trying to get higher bitrate 4K movies playing in Plex, but 120Mbps seems to be the limit
     
  9. Vm19

    Vm19 New Member

    16
    2
    Feb 10, 2021
    I just connected a generic usb to Ethernet adapter and it worked, don’t know why you guys have so much trouble.
     
  10. BushyTail

    BushyTail New Member

    2
    1
    Nov 24, 2020
    Greetings! I might have found the cheapest working ethernet adapter for TS4k.

    this one ships to many European countries from China ($5.44)
    PORTABLE USB 2.0 TO NETWORK CARD DRIVE-FREE ETHERNET ADAPTER BUILT-IN CABLE CHEE | eBay
    this one ships to US from China ($7.63)
    Portable USB 2.0 Wired Built-in Cable Network Card Drive-free Ethernet Adapter | eBay

    (yes, shipping takes an eternity in both cases)


    I easily got speeds of 75 mbps download and 97 mbps upload on a 100 mbps ethernet connection. I've been using it for 2 weeks - it's working reliably.


    Setup: the ethernet cable is connected to this adapter and the adapter is connected to the usb c port through a generic OTG usb A to usb c adapter. As an experiment, I tried to reverse the ports – I connected the power cable to the usb c port and the ethernet adapter to the micro usb port but TS4k notified that it didn't see any ethernet connection (maybe it would work with something like this?? USB PORT ADAPTER OTG Cable For Cable 4K 2nd Gen Fire TV3 Fire US Fast & O5K4 | eBay if yes, then it would allow to connect both the power and ethernet through the micro usb port).


    One more thing I need to mention! This adapter didn't work immediately. In fact, after wasting more than an hour trying to connect it (and ensuring ALL other components were working flawlessly), all I was getting were notifications that Ethernet didn't work. I enabled developer settings, navigated to a rubric that said something like "What do you want the usb connection to do?" There were options like “automatic?”, "power?”, “file transfer?”, and “Ethernet!". I enabled the last option and that very moment the Ethernet connection started working.

    But then I connected the SECOND TS4k device to Ethernet using the very same parts and planning to enable the same setting when I suddenly discovered that the ethernet connection WAS WORKING!! (despite the fact that it didn’t work prior to this). So, I thought I can disable developer options altogether (on both devices) and did so without any effect.

    I have very little knowledge about Android, so I can't judge whether it was a simple coincidence or enabling that setting did something (could it trigger the downloading of a driver or some other action that would help TS4k recognize the adapter?).

    Btw, this adapter is somewhat peculiar since it stores its drivers on a tiny internal flash card – on Windows, it mounts as a CD and installs the drivers automatically (but it might be the case only for Windows). The reason I bought this adapter was because I've seen reviews on Aliexpress stating that it works with lots of Android TV devices (at that point I didn’t know TS4k was so picky about Ethernet adapters).
    [​IMG]
     
    Last edited: Mar 6, 2021
  11. Mar 1, 2021 #231 of 231
    dbpaddler

    dbpaddler Well-Known Member

    958
    359
    Sep 25, 2004
    Philly
    Considering you don't know the chipset inside, you could've just gotten lucky and had it be the right one. Or, the firmware updates could have brought wider compatibility too.

    Sent from my Surface Duo using Tapatalk
     
    OldCableGuy likes this.

Share This Page

spam firewall

Advertisements