UPgraded Roamio and now my lights are very happy, but my drive is not.

Discussion in 'TiVo Roamio DVRs' started by gigaquad, Nov 22, 2016.

  1. gigaquad

    gigaquad Tivo Image Master

    190
    114
    Oct 25, 2004
    Has anyone upgraded their Roamio and had it fail? I've formatted two disks (one 500gb, one 1TB) and still my Roamio doesn't want to play nice with them. Both are Seagate.

    I pulled the old drive, put the new one in, and booted up. I get to the "Welcome, Starting up!" then the lights on the front act like they've had too much caffeine, blinking like crazy - all four of them.

    I've tried formatting as MBR and also as GPT and with a partition and without, but still I get nothing.

    :(
     
  2. gigaquad

    gigaquad Tivo Image Master

    190
    114
    Oct 25, 2004
    Well I figured this one out myself. Can a Mod mark this as Solved?

    I opened Ubuntu in a virtual machine (you could use a boot disk too) and ran this command on my second hand 1tb drive

    sudo dd if=/dev/zero of=/dev/sdc bs=512 count=1


    This deletes the master boot record on that drive (don't do it on your C drive by accident!) and makes the disk appear as brand new to the Tivo. After that a simple reboot of the tivo with the drive inside started the process. Now I'm back up and running 100%

    Hope this helps someone else.

    SideNote: I couldn't find any partition tools for Windows that would work either. And I tried at least 6. None would delete the MBR altogether. All wanted to rebuild it or move it to another operating system type.
     
  3. fcfc2

    fcfc2 Well-Known Member

    2,514
    499
    Feb 19, 2015
    Normally, I just use Windows Disk Manager and delete all partitions/volumes, but if this does not work for any reason, you might check out this program, Best Free Partition Manager for Windows | MiniTool Partition Free
    And the price is right.
     
  4. gigaquad

    gigaquad Tivo Image Master

    190
    114
    Oct 25, 2004
    tHANKS FCFC2,

    Minitool won't let you delete an MBR either, unfortunately. I also found out another problem with this Roamio - The power supply was weak. After getting it up and running, it failed on reboot. I discovered that if I jumped in a powersupply from a computer to run the disk it worked great. Here's my test setup.


    [​IMG]









    Now to figure out how to run it with a smaller PSU unit or replace the one in the roamio.....
     
  5. ggieseke

    ggieseke Well-Known Member

    5,444
    622
    May 30, 2008
    Most of the manufacturer's drive testing utilities like SeaTools or WD's Data Lifeguard Diagnostics have a Write Zeros test. The short version that only wipes the first and last few thousand sectors works well. If you know what you're doing, the Windows diskpart command can also "clean" a drive, but it's a lot safer to use one of the tools I listed because you can see the make, model & serial number of all the drives in your system.

    I always run a full write zeros test and the long read test before even considering putting a drive in a TiVo, so it has never been an issue for me.
     

Share This Page