Upgrade Help for Toshiba SD-H400

Discussion in 'TiVo Upgrade Center' started by JoeWagner, Sep 30, 2006.

  1. JoeWagner

    JoeWagner New Member

    2
    0
    Sep 30, 2006

    Advertisements

    Tried to upgrade my Toshiba SD-H400 from its stock 80GB drive to a Seagate 400GB drive and didn't have much success. Hoping I can get some help here to set me on the right path. I'm using ptvupggrade V4.04 with MFSTools 2.0 and instructions from Weaknees and Hinsdale.

    Started by backing up my 80GB drive using mfsbackup -f 9999 -6so
    Then did mfsrestore -s 127 -xzpi
    Finally used sd-h400_unlock -w
    Ended up with a forever rebooting green screen of death

    Next I started with the same backup file and only did mfsrestore -s 127 -zpi
    The 400GB drive worked OK and had the same 83 hour capacity as my 80GB drive

    Took that drive back out and did mfsadd -x and sd-h400_unlock and I had a rebooting green screen again.

    Started again with the original image and changed the order. Did the mfsrestore, then the sd-h400_unlock, and finally the mfsadd. Once again the constantly rebooting green screen.

    My final try was mfsrestore then mfsadd but no sd-h400_unlock. I expected to get a working drive with 137 hours capacity but instead once again got the rebooting green screen. It seems like anything I do that expands into the area beyond the original 80GB I end up with a non-working system

    I've gone back to the only working configuration so far and have my 400GB drive working OK but only 83 hours capacity.

    Only thing I haven't tried is the copykern but it doesn't look like I should be using that on Series 2 systems like the Toshiba.

    Can someone let me know what I'm doing wrong?

    Thanks, Joe
     
  2. wscannell

    wscannell Member

    2,352
    0
    Dec 6, 2003
    You would need the -r 4 switch on the restore.

    mfsrestore -s 127 -r 4 -xzpi ......
     
  3. funtoupgrade

    funtoupgrade New Member

    2,000
    0
    Mar 15, 2005
    You also need a bigger swap file.

    mfsrestore -s 200 -r 4 -xzpi ...... then run tpip after the restore is done.
    tpip --swapped -s /dev/hd? (assumes tpip 1.1)
     
  4. JoeWagner

    JoeWagner New Member

    2
    0
    Sep 30, 2006
    Thanks for your help. I used the -r 4 parameter, the swap of 200, did tpip, then the sd-400_unlock and everything seems to be working. Basic recording capacity is now 497 hours as opposed to the preupgrade 83 hours.

    Thanks again, Joe
     

Share This Page

spam firewall

Advertisements